Mình dùng Dynamips là một bài lab đơn giản về RIP update unicast nhưng kết quả không như mong muốn. Các bác xem giúp.
Sơ đồ:
Không hiểu sao em đã cấu hình passive-interface Fastethernet 0/0 và neighbor 192.168.1.3 trên R1 mà ở Router R3 vẫn không nhận được update unicast từ R1 :(
file .net:
# Simple Ethernet Switch lab
autostart = false
[localhost]
[[3660]]
image = \Program Files\Dynamips\images\c3660-ik9o3s-mz.123-6.image
#npe = npe-400
ram = 160
[[ROUTER R1]]
model= 3660
F0/0 = S1 1
[[router R2]]
model= 3660
F0/0 = S1 2
[[router R3]]
model= 3660
F0/0 = S1 3
[[ethsw S1]]
1 = access 1
2 = access 1
3 = access 1
File cấu hình R1:
interface Loopback1
ip address 192.168.2.1 255.255.255.0
ip rip advertise 5
!
interface Loopback2
ip address 192.168.3.1 255.255.255.0
ip rip advertise 5
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip rip advertise 5
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router rip
timers basic 5 20 20 50
passive-interface FastEthernet0/0
network 192.168.1.0
network 192.168.2.0
network 192.168.3.0
neighbor 192.168.1.3
!
File cấu hình R2:
interface Loopback10
ip address 192.168.4.1 255.255.255.0
ip rip advertise 5
!
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.0
ip rip advertise 5
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router rip
timers basic 5 20 20 50
network 192.168.1.0
network 192.168.4.0
!
File cấu hình R3:
interface FastEthernet0/0
ip address 192.168.1.3 255.255.255.0
ip rip advertise 5
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router rip
timers basic 5 20 20 50
network 192.168.1.0
!
Kết quả bảng định tuyến:
R1:
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
R 192.168.4.0/24 [120/1] via 192.168.1.2, 00:00:01, FastEthernet0/0
C 192.168.1.0/24 is directly connected, FastEthernet0/0
C 192.168.2.0/24 is directly connected, Loopback1
C 192.168.3.0/24 is directly connected, Loopback2
R2:
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
C 192.168.4.0/24 is directly connected, Loopback10
C 192.168.1.0/24 is directly connected, FastEthernet0/0
R3:
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
R 192.168.4.0/24 [120/1] via 192.168.1.2, 00:00:00, FastEthernet0/0
C 192.168.1.0/24 is directly connected, FastEthernet0/0
Debug rip trên R1:
*Mar 1 00:03:55.395: RIP: sending v1 update to 255.255.255.255 via Loopback2 (192.168.3.1)
*Mar 1 00:03:55.399: RIP: build update entries
*Mar 1 00:03:55.399: network 192.168.1.0 metric 1
*Mar 1 00:03:55.403: network 192.168.2.0 metric 1
*Mar 1 00:03:55.403: network 192.168.4.0 metric 2
*Mar 1 00:03:55.775: RIP: sending v1 update to 255.255.255.255 via Loopback1 (192.168.2.1)
*Mar 1 00:03:55.775: RIP: build update entries
*Mar 1 00:03:55.779: network 192.168.1.0 metric 1
*Mar 1 00:03:55.779: network 192.168.3.0 metric 1
*Mar 1 00:03:55.783: network 192.168.4.0 metric 2
*Mar 1 00:03:56.403: RIP: received v1 update from 192.168.1.2 on FastEthernet0/0
*Mar 1 00:03:56.403: 192.168.4.0 in 1 hops
*Mar 1 00:04:00.047: RIP: sending v1 update to 255.255.255.255 via Loopback2 (192.168.3.1)
*Mar 1 00:04:00.047: RIP: build update entries
*Mar 1 00:04:00.047: network 192.168.1.0 metric 1
*Mar 1 00:04:00.047: network 192.168.2.0 metric 1
*Mar 1 00:04:00.047: network 192.168.4.0 metric 2
*Mar 1 00:04:00.459: RIP: sending v1 update to 255.255.255.255 via Loopback1 (192.168.2.1)
*Mar 1 00:04:00.459: RIP: build update entries
*Mar 1 00:04:00.463: network 192.168.1.0 metric 1
*Mar 1 00:04:00.463: network 192.168.3.0 metric 1
*Mar 1 00:04:00.467: network 192.168.4.0 metric 2
*Mar 1 00:04:01.323: RIP: received v1 update from 192.168.1.2 on FastEthernet0/0
*Mar 1 00:04:01.327: 192.168.4.0 in 1 hops
Hình như cái lệnh neighbor không ăn thua hay sao ấy, theo debug được thì R1 không gởi thông tin định tuyến ra mạng 192.168.1.0/24
Không biết có sai sót gì không???
Sơ đồ:
Không hiểu sao em đã cấu hình passive-interface Fastethernet 0/0 và neighbor 192.168.1.3 trên R1 mà ở Router R3 vẫn không nhận được update unicast từ R1 :(
file .net:
# Simple Ethernet Switch lab
autostart = false
[localhost]
[[3660]]
image = \Program Files\Dynamips\images\c3660-ik9o3s-mz.123-6.image
#npe = npe-400
ram = 160
[[ROUTER R1]]
model= 3660
F0/0 = S1 1
[[router R2]]
model= 3660
F0/0 = S1 2
[[router R3]]
model= 3660
F0/0 = S1 3
[[ethsw S1]]
1 = access 1
2 = access 1
3 = access 1
File cấu hình R1:
interface Loopback1
ip address 192.168.2.1 255.255.255.0
ip rip advertise 5
!
interface Loopback2
ip address 192.168.3.1 255.255.255.0
ip rip advertise 5
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip rip advertise 5
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router rip
timers basic 5 20 20 50
passive-interface FastEthernet0/0
network 192.168.1.0
network 192.168.2.0
network 192.168.3.0
neighbor 192.168.1.3
!
File cấu hình R2:
interface Loopback10
ip address 192.168.4.1 255.255.255.0
ip rip advertise 5
!
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.0
ip rip advertise 5
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router rip
timers basic 5 20 20 50
network 192.168.1.0
network 192.168.4.0
!
File cấu hình R3:
interface FastEthernet0/0
ip address 192.168.1.3 255.255.255.0
ip rip advertise 5
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router rip
timers basic 5 20 20 50
network 192.168.1.0
!
Kết quả bảng định tuyến:
R1:
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
R 192.168.4.0/24 [120/1] via 192.168.1.2, 00:00:01, FastEthernet0/0
C 192.168.1.0/24 is directly connected, FastEthernet0/0
C 192.168.2.0/24 is directly connected, Loopback1
C 192.168.3.0/24 is directly connected, Loopback2
R2:
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
C 192.168.4.0/24 is directly connected, Loopback10
C 192.168.1.0/24 is directly connected, FastEthernet0/0
R3:
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
R 192.168.4.0/24 [120/1] via 192.168.1.2, 00:00:00, FastEthernet0/0
C 192.168.1.0/24 is directly connected, FastEthernet0/0
Debug rip trên R1:
*Mar 1 00:03:55.395: RIP: sending v1 update to 255.255.255.255 via Loopback2 (192.168.3.1)
*Mar 1 00:03:55.399: RIP: build update entries
*Mar 1 00:03:55.399: network 192.168.1.0 metric 1
*Mar 1 00:03:55.403: network 192.168.2.0 metric 1
*Mar 1 00:03:55.403: network 192.168.4.0 metric 2
*Mar 1 00:03:55.775: RIP: sending v1 update to 255.255.255.255 via Loopback1 (192.168.2.1)
*Mar 1 00:03:55.775: RIP: build update entries
*Mar 1 00:03:55.779: network 192.168.1.0 metric 1
*Mar 1 00:03:55.779: network 192.168.3.0 metric 1
*Mar 1 00:03:55.783: network 192.168.4.0 metric 2
*Mar 1 00:03:56.403: RIP: received v1 update from 192.168.1.2 on FastEthernet0/0
*Mar 1 00:03:56.403: 192.168.4.0 in 1 hops
*Mar 1 00:04:00.047: RIP: sending v1 update to 255.255.255.255 via Loopback2 (192.168.3.1)
*Mar 1 00:04:00.047: RIP: build update entries
*Mar 1 00:04:00.047: network 192.168.1.0 metric 1
*Mar 1 00:04:00.047: network 192.168.2.0 metric 1
*Mar 1 00:04:00.047: network 192.168.4.0 metric 2
*Mar 1 00:04:00.459: RIP: sending v1 update to 255.255.255.255 via Loopback1 (192.168.2.1)
*Mar 1 00:04:00.459: RIP: build update entries
*Mar 1 00:04:00.463: network 192.168.1.0 metric 1
*Mar 1 00:04:00.463: network 192.168.3.0 metric 1
*Mar 1 00:04:00.467: network 192.168.4.0 metric 2
*Mar 1 00:04:01.323: RIP: received v1 update from 192.168.1.2 on FastEthernet0/0
*Mar 1 00:04:01.327: 192.168.4.0 in 1 hops
Hình như cái lệnh neighbor không ăn thua hay sao ấy, theo debug được thì R1 không gởi thông tin định tuyến ra mạng 192.168.1.0/24
Không biết có sai sót gì không???
Comment