I. Diagram
II. Yêu cầu
III. Cấu hình mẫu của các router
Router HO
sh run
Building configuration...
Current configuration : 1300 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname HO
!
interface Tunnel1
ip address 10.0.1.1 255.255.255.0
tunnel source 193.168.123.6
tunnel destination 194.168.123.7
delay 500
!
interface FastEthernet0/0
ip address 193.168.123.6 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.0.0.1 255.255.255.0
duplex auto
speed auto
no keepalive
!
interface Serial0/1/0
ip address 192.168.123.6 255.255.255.0
delay 100
no fair-queue
clockrate 64000
!
router eigrp 1
network 10.0.0.0 0.0.0.255
network 10.0.1.0 0.0.0.255
network 192.168.123.0
no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 193.168.123.7
!
end
HO#
Router Branch
sh run
Building configuration...
Current configuration : 1245 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Branch
!
interface Tunnel1
ip address 10.0.1.2 255.255.255.0
delay 500
tunnel source 194.168.123.7
tunnel destination 193.168.123.6
!
interface FastEthernet0/0
ip address 194.168.123.7 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.0.2.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/2/0
ip address 192.168.123.5 255.255.255.0
delay 100
no fair-queue
!
router eigrp 1
network 10.0.1.0 0.0.0.255
network 10.0.2.0 0.0.0.255
network 192.168.123.0
no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 194.168.123.6
!
end
Branch#
II. Yêu cầu
- Gắn cáp theo sơ đồ hình vẽ.
- Router HO và Branch là các router có hỗ trợ VPN.
- Một GRE tunnels sẽ được tạo giữa router HO và router Branch.
- Giao thức định tuyến động EIGRP sẽ được dùng giữa các routers.
- Metric của EIGRP sẽ đuợc thao tác sao cho EIGRP ưu tiên đường đi thông qua leased line. Thao tác này được thực hiện thông qua cấu hình thông số delay của các interface serials và interface tunnels. Delay của serial là 100. Delay của interface tunnel là 500 (ms).
- Khả năng dự phòng dựa vào đặc tính của các giao thức IGP, trong trường hợp này là EIGRP. Nếu đường leased line bị sự cố, router branch sẽ nhận thấy còn một đường đi khác về mạng HO thông qua tunnels.
III. Cấu hình mẫu của các router
Router HO
sh run
Building configuration...
Current configuration : 1300 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname HO
!
interface Tunnel1
ip address 10.0.1.1 255.255.255.0
tunnel source 193.168.123.6
tunnel destination 194.168.123.7
delay 500
!
interface FastEthernet0/0
ip address 193.168.123.6 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.0.0.1 255.255.255.0
duplex auto
speed auto
no keepalive
!
interface Serial0/1/0
ip address 192.168.123.6 255.255.255.0
delay 100
no fair-queue
clockrate 64000
!
router eigrp 1
network 10.0.0.0 0.0.0.255
network 10.0.1.0 0.0.0.255
network 192.168.123.0
no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 193.168.123.7
!
end
HO#
Router Branch
sh run
Building configuration...
Current configuration : 1245 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Branch
!
interface Tunnel1
ip address 10.0.1.2 255.255.255.0
delay 500
tunnel source 194.168.123.7
tunnel destination 193.168.123.6
!
interface FastEthernet0/0
ip address 194.168.123.7 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.0.2.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/2/0
ip address 192.168.123.5 255.255.255.0
delay 100
no fair-queue
!
router eigrp 1
network 10.0.1.0 0.0.0.255
network 10.0.2.0 0.0.0.255
network 192.168.123.0
no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 194.168.123.6
!
end
Branch#