Em là sv năm cuối,
Em đang làm đồ án Về MPLS VPN, các bác giúp em với.
cisco IOS: 3745
chạy bằng dynamip
trong mạng core chạy OSPF/MPLS
customer A: CE1A, CE2A
vrf name: customer_A
RIP
RD: 100:110
RT: 100:1000
customer B: CE1B, CE2B
vrf name: customer_B
static route
RD: 100:120
RT: 100:2000
cái lab của em nó lỗi thế này:
-các PE và P đều ping thấy nhau,
-các PE router không ping được các router ở customer site (CE)
nhưng router ở customer (CE) site lại ping được PE router???????????
-và dĩ nhiên là các site không ping thấy nhau :109::109::109::109::109:
đây là cấu hình:
PE1:
memory-size iomem 5
ip cef
!
!
!
!
ip vrf customer_A
rd 100:110
route-target export 100:1000
route-target import 100:1000
!
ip vrf customer_B
rd 100:120
route-target export 100:2000
route-target import 100:2000
!
interface Loopback10
ip address 10.10.10.10 255.255.255.0
ip ospf 1 area 0
!
interface FastEthernet0/0
ip vrf forwarding customer_A
ip address 10.1.1.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip vrf forwarding customer_B
ip address 10.2.2.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.12.1 255.255.255.0
ip ospf 1 area 0
speed auto
full-duplex
mpls ip
no cdp log mismatch duplex
!
router ospf 1
mpls ldp autoconfig area 0
router-id 10.10.10.10
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
router rip
version 2
no auto-summary
!
address-family ipv4 vrf customer_A
redistribute bgp 100 metric 1
network 10.0.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 100
no synchronization
bgp router-id 10.10.10.10
bgp log-neighbor-changes
neighbor 10.20.20.20 remote-as 100
neighbor 10.20.20.20 update-source Loopback10
no auto-summary
!
address-family vpnv4
neighbor 10.20.20.20 activate
neighbor 10.20.20.20 send-community extended
exit-address-family
!
address-family ipv4 vrf customer_B
redistribute connected
redistribute static
no synchronization
exit-address-family
!
address-family ipv4 vrf customer_A
redistribute connected
redistribute rip
no synchronization
exit-address-family
!
ip route 192.168.1.0 255.255.255.0 FastEthernet0/1 10.2.2.2
ip route vrf customer_B 192.168.1.0 255.255.255.0 10.2.2.2
!
PE2:
!
ip vrf customer_A
rd 100:110
route-target export 100:1000
route-target import 100:1000
!
ip vrf customer_B
rd 100:120
route-target export 100:2000
route-target import 100:2000
!
interface Loopback20
ip address 10.20.20.20 255.255.255.255
ip ospf 1 area 0
!
interface FastEthernet0/0
ip vrf forwarding customer_A
ip address 10.3.3.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip vrf forwarding customer_B
ip address 10.4.4.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.34.4 255.255.255.0
ip ospf 1 area 0
speed auto
full-duplex
mpls ip
no cdp log mismatch duplex
!
router ospf 1
router-id 10.20.20.20
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
router rip
version 2
no auto-summary
!
address-family ipv4 vrf customer_A
redistribute bgp 100 metric 0
network 10.0.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 10.10.10.10 remote-as 100
neighbor 10.10.10.10 update-source Loopback20
no auto-summary
!
address-family vpnv4
neighbor 10.10.10.10 activate
neighbor 10.10.10.10 send-community extended
exit-address-family
!
address-family ipv4 vrf customer_B
redistribute connected
redistribute static
no synchronization
exit-address-family
!
address-family ipv4 vrf customer_A
redistribute connected
redistribute rip
no synchronization
exit-address-family
!
ip route 192.168.2.0 255.255.255.0 FastEthernet0/1 10.4.4.2
ip route vrf customer_B 192.168.2.0 255.255.255.0 10.4.4.2
!
P1:
!
interface FastEthernet0/0
ip address 192.168.23.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/1
ip address 192.168.12.2 255.255.255.0
speed auto
full-duplex
mpls ip
no cdp log mismatch duplex
!
router ospf 1
log-adjacency-changes
network 192.168.12.0 0.0.0.255 area 0
network 192.168.23.0 0.0.0.255 area 0
!
P2:
!
interface FastEthernet0/0
ip address 192.168.23.3 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/1
ip address 192.168.34.3 255.255.255.0
speed auto
full-duplex
mpls ip
no cdp log mismatch duplex
!
router ospf 1
log-adjacency-changes
network 192.168.23.0 0.0.0.255 area 0
network 192.168.34.0 0.0.0.255 area 0
!
CE1A:
!
interface Loopback11
ip address 172.16.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.1.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router rip
version 2
redistribute static
network 10.0.0.0
network 172.16.0.0
no auto-summary
!
CE2A:
!
interface Loopback12
ip address 172.16.2.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.3.3.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router rip
version 2
redistribute static
network 10.0.0.0
network 172.16.0.0
no auto-summary
!
CE1B:
!
interface Loopback21
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.2.2.2 255.255.255.252
duplex auto
speed auto
!
ip route 0.0.0.0 0.0.0.0 10.2.2.1
!
CE2B:
!
interface Loopback22
ip address 192.168.2.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.4.4.2 255.255.255.252
duplex auto
speed auto
!
ip route 0.0.0.0 0.0.0.0 10.4.4.1
!
!
ip http server
no ip http secure-server
!
-------------------------------
CE1A#sh ip route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 2 subnets
C 172.16.1.0 is directly connected, Loopback11
R 172.16.2.0 [120/1] via 10.1.1.1, 00:00:11, FastEthernet0/0
10.0.0.0/30 is subnetted, 2 subnets
R 10.3.3.0 [120/1] via 10.1.1.1, 00:00:11, FastEthernet0/0
C 10.1.1.0 is directly connected, FastEthernet0/0
---------------------------------
CE2A#sh ip route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 2 subnets
R 172.16.1.0 [120/1] via 10.3.3.1, 00:00:20, FastEthernet0/0
C 172.16.2.0 is directly connected, Loopback12
10.0.0.0/30 is subnetted, 2 subnets
C 10.3.3.0 is directly connected, FastEthernet0/0
R 10.1.1.0 [120/1] via 10.3.3.1, 00:00:20, FastEthernet0/0
--------------------------------
CE1B#sh ip route
Gateway of last resort is 10.2.2.1 to network 0.0.0.0
10.0.0.0/30 is subnetted, 1 subnets
C 10.2.2.0 is directly connected, FastEthernet0/1
C 192.168.1.0/24 is directly connected, Loopback21
S* 0.0.0.0/0 [1/0] via 10.2.2.1
---------------------------------
CE2B#sh ip route
Gateway of last resort is 10.4.4.1 to network 0.0.0.0
10.0.0.0/30 is subnetted, 1 subnets
C 10.4.4.0 is directly connected, FastEthernet0/1
C 192.168.2.0/24 is directly connected, Loopback22
S* 0.0.0.0/0 [1/0] via 10.4.4.1
----------------------------------
PE1#sh ip route vrf customer_A
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 2 subnets
R 172.16.1.0 [120/1] via 10.1.1.2, 00:00:00, FastEthernet0/0
B 172.16.2.0 [200/1] via 10.20.20.20, 00:55:58
10.0.0.0/30 is subnetted, 2 subnets
B 10.3.3.0 [200/0] via 10.20.20.20, 00:55:58
C 10.1.1.0 is directly connected, FastEthernet0/0
----------------------------------
PE2#sh ip route vrf customer_A
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 2 subnets
B 172.16.1.0 [200/1] via 10.10.10.10, 00:56:47
R 172.16.2.0 [120/1] via 10.3.3.2, 00:00:14, FastEthernet0/0
10.0.0.0/30 is subnetted, 2 subnets
C 10.3.3.0 is directly connected, FastEthernet0/0
B 10.1.1.0 [200/0] via 10.10.10.10, 00:56:47
-----------------------------------
PE2#sh ip route vrf customer_B
Gateway of last resort is not set
10.0.0.0/30 is subnetted, 2 subnets
C 10.4.4.0 is directly connected, FastEthernet0/1
B 10.2.2.0 [200/0] via 10.10.10.10, 00:59:15
B 192.168.1.0/24 [200/0] via 10.10.10.10, 00:59:15
S 192.168.2.0/24 [1/0] via 10.4.4.2
-----------------------------------
PE1#sh ip route vrf customer_B
Gateway of last resort is not set
10.0.0.0/30 is subnetted, 2 subnets
B 10.4.4.0 [200/0] via 10.20.20.20, 01:00:07
C 10.2.2.0 is directly connected, FastEthernet0/1
S 192.168.1.0/24 [1/0] via 10.2.2.2
B 192.168.2.0/24 [200/0] via 10.20.20.20, 01:00:07
------------------------------------
MONG CÁC BÁC GIÚP đỡ :
đây là các site em đã tham khảo:
Comment