Hi các anh/chị,
Em đang cấu hình lab MPLS VPN and RIP, tuy nhiên em đang bị mắc khi không ping được giữa 2 router CE với nhau, em cấu hình như dưới đây :
Mô hình :
R7-----R3-----R1------R6------R11
Cấu hình R7
interface Loopback0
ip address 7.7.7.7 255.255.255.255
!
interface Serial0/0
description *** Link to R3 ***
ip address 37.37.37.7 255.255.255.0
serial restart-delay 0
!
router rip
version 2
network 7.0.0.0
network 37.0.0.0
Cấu hình R11
interface Loopback0
ip address 11.11.11.11 255.255.255.255
!
interface Serial0/0
description *** Link to R6 ***
ip address 61.61.61.11 255.255.255.0
serial restart-delay 0
!
router rip
version 2
network 11.0.0.0
network 61.0.0.0
Cấu hình R1
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Serial0/0
description *** Link to R5 ***
ip address 56.56.56.1 255.255.255.0
mpls ip
serial restart-delay 0
!
interface Serial0/1
description *** Link to R3 ***
ip address 13.13.13.1 255.255.255.0
mpls ip
serial restart-delay 0
!
router rip
version 2
network 1.0.0.0
network 13.0.0.0
network 56.0.0.0
no auto-summary
Cấu hình R3
ip vrf vpn_1
rd 65000:1
route-target export 65000:1
route-target import 65000:1
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Serial0/0
description *** Link to R1 ***
ip address 13.13.13.3 255.255.255.0
mpls ip
serial restart-delay 0
!
interface Serial0/1
description *** Link to R7 ***
ip vrf forwarding vpn_1
ip address 37.37.37.3 255.255.255.0
serial restart-delay 0
!
router rip
version 2
network 3.0.0.0
network 13.0.0.0
!
address-family ipv4 vrf vpn_1
redistribute bgp 65000 metric transparent
network 37.0.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 65000
no synchronization
bgp log-neighbor-changes
neighbor 6.6.6.6 remote-as 65000
neighbor 6.6.6.6 update-source Loopback0
neighbor 6.6.6.6 next-hop-self
no auto-summary
!
address-family vpnv4
neighbor 6.6.6.6 activate
neighbor 6.6.6.6 send-community both
exit-address-family
!
address-family ipv4 vrf vpn_1
redistribute rip
no synchronization
exit-address-family
!
Cấu hình R6
ip vrf vpn_1
rd 65000:1
route-target export 65000:1
route-target import 65000:1
!
interface Loopback0
ip address 6.6.6.6 255.255.255.255
!
interface Serial0/0
description *** Link to R1 ***
ip address 56.56.56.6 255.255.255.0
mpls ip
serial restart-delay 0
!
interface Serial0/1
description *** Link to R11 ***
ip vrf forwarding vpn_1
ip address 61.61.61.6 255.255.255.0
serial restart-delay 0
!
router rip
version 2
network 6.0.0.0
network 56.0.0.0
!
address-family ipv4 vrf vpn_1
redistribute bgp 65000 metric transparent
network 61.0.0.0
network 11.0.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 65000
no synchronization
bgp log-neighbor-changes
neighbor 3.3.3.3 remote-as 65000
neighbor 3.3.3.3 update-source Loopback0
neighbor 3.3.3.3 next-hop-self
no auto-summary
!
address-family vpnv4
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 vrf vpn_1
redistribute rip
no synchronization
exit-address-family
Kiểm tra trên Router:
R3#show ip bgp summary
BGP router identifier 3.3.3.3, local AS number 65000
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
6.6.6.6 4 65000 100 100 1 0 0 01:33:35 0
R3#
R3#show ip route vrf vpn_1
Routing Table: vpn_1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
37.0.0.0/24 is subnetted, 1 subnets
C 37.37.37.0 is directly connected, Serial0/1
R 7.0.0.0/8 [120/1] via 37.37.37.7, 00:00:18, Serial0/1
B 11.0.0.0/8 [200/1] via 6.6.6.6, 01:31:13
61.0.0.0/24 is subnetted, 1 subnets
B 61.61.61.0 [200/0] via 6.6.6.6, 01:31:13
R3#
R6#show ip route vrf vpn_1
Routing Table: vpn_1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
37.0.0.0/24 is subnetted, 1 subnets
B 37.37.37.0 [200/0] via 3.3.3.3, 01:32:23
B 7.0.0.0/8 [200/1] via 3.3.3.3, 01:32:23
R 11.0.0.0/8 [120/1] via 61.61.61.11, 00:00:25, Serial0/1
61.0.0.0/24 is subnetted, 1 subnets
C 61.61.61.0 is directly connected, Serial0/1
R6#
R6#show ip bgp summary
BGP router identifier 6.6.6.6, local AS number 65000
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
3.3.3.3 4 65000 101 101 1 0 0 01:34:11 0
R6#
Kiểm tra route trên R7, R11
R7#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
37.0.0.0/24 is subnetted, 1 subnets
C 37.37.37.0 is directly connected, Serial0/0
7.0.0.0/32 is subnetted, 1 subnets
C 7.7.7.7 is directly connected, Loopback0
R 11.0.0.0/8 [120/2] via 37.37.37.3, 00:00:20, Serial0/0
61.0.0.0/24 is subnetted, 1 subnets
R 61.61.61.0 [120/1] via 37.37.37.3, 00:00:20, Serial0/0
R7#
R11#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
37.0.0.0/24 is subnetted, 1 subnets
R 37.37.37.0 [120/1] via 61.61.61.6, 00:00:29, Serial0/0
R 7.0.0.0/8 [120/2] via 61.61.61.6, 00:00:29, Serial0/0
11.0.0.0/32 is subnetted, 1 subnets
C 11.11.11.11 is directly connected, Loopback0
61.0.0.0/24 is subnetted, 1 subnets
C 61.61.61.0 is directly connected, Serial0/0
R11#
Tuy nhiên, khi ping giữa hai router R7 và R11 lại không được :
R7#ping 11.11.11.11
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.11.11.11, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R7#ping 61.61.61.11
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 61.61.61.11, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R7#
Trên R3 không ping được R11 :
R3#ping vrf vpn_1 11.11.11.11
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.11.11.11, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Trên R6 ping được R11 :
R6#ping vrf vpn_1 11.11.11.11
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.11.11.11, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/23/28 ms
R6#
Anh chị xem giúp em lỗi là ở đâu với.
Em cám ơn nhiều.
Em đang cấu hình lab MPLS VPN and RIP, tuy nhiên em đang bị mắc khi không ping được giữa 2 router CE với nhau, em cấu hình như dưới đây :
Mô hình :
R7-----R3-----R1------R6------R11
Cấu hình R7
interface Loopback0
ip address 7.7.7.7 255.255.255.255
!
interface Serial0/0
description *** Link to R3 ***
ip address 37.37.37.7 255.255.255.0
serial restart-delay 0
!
router rip
version 2
network 7.0.0.0
network 37.0.0.0
Cấu hình R11
interface Loopback0
ip address 11.11.11.11 255.255.255.255
!
interface Serial0/0
description *** Link to R6 ***
ip address 61.61.61.11 255.255.255.0
serial restart-delay 0
!
router rip
version 2
network 11.0.0.0
network 61.0.0.0
Cấu hình R1
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Serial0/0
description *** Link to R5 ***
ip address 56.56.56.1 255.255.255.0
mpls ip
serial restart-delay 0
!
interface Serial0/1
description *** Link to R3 ***
ip address 13.13.13.1 255.255.255.0
mpls ip
serial restart-delay 0
!
router rip
version 2
network 1.0.0.0
network 13.0.0.0
network 56.0.0.0
no auto-summary
Cấu hình R3
ip vrf vpn_1
rd 65000:1
route-target export 65000:1
route-target import 65000:1
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Serial0/0
description *** Link to R1 ***
ip address 13.13.13.3 255.255.255.0
mpls ip
serial restart-delay 0
!
interface Serial0/1
description *** Link to R7 ***
ip vrf forwarding vpn_1
ip address 37.37.37.3 255.255.255.0
serial restart-delay 0
!
router rip
version 2
network 3.0.0.0
network 13.0.0.0
!
address-family ipv4 vrf vpn_1
redistribute bgp 65000 metric transparent
network 37.0.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 65000
no synchronization
bgp log-neighbor-changes
neighbor 6.6.6.6 remote-as 65000
neighbor 6.6.6.6 update-source Loopback0
neighbor 6.6.6.6 next-hop-self
no auto-summary
!
address-family vpnv4
neighbor 6.6.6.6 activate
neighbor 6.6.6.6 send-community both
exit-address-family
!
address-family ipv4 vrf vpn_1
redistribute rip
no synchronization
exit-address-family
!
Cấu hình R6
ip vrf vpn_1
rd 65000:1
route-target export 65000:1
route-target import 65000:1
!
interface Loopback0
ip address 6.6.6.6 255.255.255.255
!
interface Serial0/0
description *** Link to R1 ***
ip address 56.56.56.6 255.255.255.0
mpls ip
serial restart-delay 0
!
interface Serial0/1
description *** Link to R11 ***
ip vrf forwarding vpn_1
ip address 61.61.61.6 255.255.255.0
serial restart-delay 0
!
router rip
version 2
network 6.0.0.0
network 56.0.0.0
!
address-family ipv4 vrf vpn_1
redistribute bgp 65000 metric transparent
network 61.0.0.0
network 11.0.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 65000
no synchronization
bgp log-neighbor-changes
neighbor 3.3.3.3 remote-as 65000
neighbor 3.3.3.3 update-source Loopback0
neighbor 3.3.3.3 next-hop-self
no auto-summary
!
address-family vpnv4
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 vrf vpn_1
redistribute rip
no synchronization
exit-address-family
Kiểm tra trên Router:
R3#show ip bgp summary
BGP router identifier 3.3.3.3, local AS number 65000
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
6.6.6.6 4 65000 100 100 1 0 0 01:33:35 0
R3#
R3#show ip route vrf vpn_1
Routing Table: vpn_1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
37.0.0.0/24 is subnetted, 1 subnets
C 37.37.37.0 is directly connected, Serial0/1
R 7.0.0.0/8 [120/1] via 37.37.37.7, 00:00:18, Serial0/1
B 11.0.0.0/8 [200/1] via 6.6.6.6, 01:31:13
61.0.0.0/24 is subnetted, 1 subnets
B 61.61.61.0 [200/0] via 6.6.6.6, 01:31:13
R3#
R6#show ip route vrf vpn_1
Routing Table: vpn_1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
37.0.0.0/24 is subnetted, 1 subnets
B 37.37.37.0 [200/0] via 3.3.3.3, 01:32:23
B 7.0.0.0/8 [200/1] via 3.3.3.3, 01:32:23
R 11.0.0.0/8 [120/1] via 61.61.61.11, 00:00:25, Serial0/1
61.0.0.0/24 is subnetted, 1 subnets
C 61.61.61.0 is directly connected, Serial0/1
R6#
R6#show ip bgp summary
BGP router identifier 6.6.6.6, local AS number 65000
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
3.3.3.3 4 65000 101 101 1 0 0 01:34:11 0
R6#
Kiểm tra route trên R7, R11
R7#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
37.0.0.0/24 is subnetted, 1 subnets
C 37.37.37.0 is directly connected, Serial0/0
7.0.0.0/32 is subnetted, 1 subnets
C 7.7.7.7 is directly connected, Loopback0
R 11.0.0.0/8 [120/2] via 37.37.37.3, 00:00:20, Serial0/0
61.0.0.0/24 is subnetted, 1 subnets
R 61.61.61.0 [120/1] via 37.37.37.3, 00:00:20, Serial0/0
R7#
R11#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
37.0.0.0/24 is subnetted, 1 subnets
R 37.37.37.0 [120/1] via 61.61.61.6, 00:00:29, Serial0/0
R 7.0.0.0/8 [120/2] via 61.61.61.6, 00:00:29, Serial0/0
11.0.0.0/32 is subnetted, 1 subnets
C 11.11.11.11 is directly connected, Loopback0
61.0.0.0/24 is subnetted, 1 subnets
C 61.61.61.0 is directly connected, Serial0/0
R11#
Tuy nhiên, khi ping giữa hai router R7 và R11 lại không được :
R7#ping 11.11.11.11
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.11.11.11, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R7#ping 61.61.61.11
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 61.61.61.11, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R7#
Trên R3 không ping được R11 :
R3#ping vrf vpn_1 11.11.11.11
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.11.11.11, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Trên R6 ping được R11 :
R6#ping vrf vpn_1 11.11.11.11
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.11.11.11, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/23/28 ms
R6#
Anh chị xem giúp em lỗi là ở đâu với.
Em cám ơn nhiều.
Comment