Mình có topology mạng như sau:
3 con router R2, R3, R4 chạy OSPF. cổng fas0/1 trên R3,R4 nối với SW1. Các cấu hình trên 3 router như sau
R2#sh run
!
!
!
interface Loopback0
no ip address
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
encapsulation dot1Q 1 native
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 192.168.2.1 255.255.255.0
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.1
encapsulation dot1Q 1 native
ip address 172.16.16.1 255.255.255.0
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
!
interface FastEthernet1/0.1
encapsulation dot1Q 1 native
ip address 172.16.1.1 255.255.255.0
!
!
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
redistribute connected subnets
redistribute static subnets
network 172.16.1.0 0.0.0.255 area 0
network 172.16.16.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0
!
!
!
R3#sh run
!
interface Loopback0
no ip address
!
interface FastEthernet0/0
ip address 172.16.16.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.10.10.1 255.255.255.0
duplex auto
speed auto
glbp 2 ip 10.10.10.3
glbp 2 timers 5 8
glbp 2 priority 150
glbp 2 preempt delay minimum 1
glbp 2 weighting 110 lower 95 upper 105
glbp 2 weighting track 1 decrement 70
glbp 2 forwarder preempt delay minimum 0
!
!
router ospf 1
router-id 3.3.3.3
log-adjacency-changes
redistribute connected subnets
redistribute static subnets
network 10.10.10.0 0.0.0.255 area 0
network 172.16.16.0 0.0.0.255 area 0
!
!
!
ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
R4#sh run
Building configuration...
!
interface FastEthernet0/0
ip address 172.16.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.10.10.2 255.255.255.0
duplex auto
speed auto
glbp 2 ip 10.10.10.3
glbp 2 timers 5 8
glbp 2 weighting 110 lower 95 upper 105
glbp 2 weighting track 1 decrement 70
glbp 2 forwarder preempt delay minimum 0
!
!
router ospf 1
router-id 4.4.4.4
log-adjacency-changes
redistribute connected subnets
redistribute static subnets
network 10.10.10.0 0.0.0.255 area 0
network 172.16.1.0 0.0.0.255 area 0
!
!
!
ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
Khi show bảng route trên router 2 thì chỉ thấy 1 câu route về mạng 10.10.10.0/24
R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 2 subnets
C 172.16.16.0 is directly connected, FastEthernet0/1.1
C 172.16.1.0 is directly connected, FastEthernet1/0.1
10.0.0.0/24 is subnetted, 1 subnets
O 10.10.10.0 [110/11] via 172.16.1.2, 00:19:04, FastEthernet1/0.1
C 192.168.1.0/24 is directly connected, FastEthernet0/0.1
C 192.168.2.0/24 is directly connected, FastEthernet0/0.2
Ý mình muốn là phải có 2 câu route về mạng 10.10.10.0/24 để load balance OSPF từ router R2 về mạng 10.10.10.0/24
ai biêt xin chỉ giúp
3 con router R2, R3, R4 chạy OSPF. cổng fas0/1 trên R3,R4 nối với SW1. Các cấu hình trên 3 router như sau
R2#sh run
!
!
!
interface Loopback0
no ip address
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
encapsulation dot1Q 1 native
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 192.168.2.1 255.255.255.0
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.1
encapsulation dot1Q 1 native
ip address 172.16.16.1 255.255.255.0
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
!
interface FastEthernet1/0.1
encapsulation dot1Q 1 native
ip address 172.16.1.1 255.255.255.0
!
!
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
redistribute connected subnets
redistribute static subnets
network 172.16.1.0 0.0.0.255 area 0
network 172.16.16.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0
!
!
!
R3#sh run
!
interface Loopback0
no ip address
!
interface FastEthernet0/0
ip address 172.16.16.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.10.10.1 255.255.255.0
duplex auto
speed auto
glbp 2 ip 10.10.10.3
glbp 2 timers 5 8
glbp 2 priority 150
glbp 2 preempt delay minimum 1
glbp 2 weighting 110 lower 95 upper 105
glbp 2 weighting track 1 decrement 70
glbp 2 forwarder preempt delay minimum 0
!
!
router ospf 1
router-id 3.3.3.3
log-adjacency-changes
redistribute connected subnets
redistribute static subnets
network 10.10.10.0 0.0.0.255 area 0
network 172.16.16.0 0.0.0.255 area 0
!
!
!
ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
R4#sh run
Building configuration...
!
interface FastEthernet0/0
ip address 172.16.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.10.10.2 255.255.255.0
duplex auto
speed auto
glbp 2 ip 10.10.10.3
glbp 2 timers 5 8
glbp 2 weighting 110 lower 95 upper 105
glbp 2 weighting track 1 decrement 70
glbp 2 forwarder preempt delay minimum 0
!
!
router ospf 1
router-id 4.4.4.4
log-adjacency-changes
redistribute connected subnets
redistribute static subnets
network 10.10.10.0 0.0.0.255 area 0
network 172.16.1.0 0.0.0.255 area 0
!
!
!
ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
Khi show bảng route trên router 2 thì chỉ thấy 1 câu route về mạng 10.10.10.0/24
R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 2 subnets
C 172.16.16.0 is directly connected, FastEthernet0/1.1
C 172.16.1.0 is directly connected, FastEthernet1/0.1
10.0.0.0/24 is subnetted, 1 subnets
O 10.10.10.0 [110/11] via 172.16.1.2, 00:19:04, FastEthernet1/0.1
C 192.168.1.0/24 is directly connected, FastEthernet0/0.1
C 192.168.2.0/24 is directly connected, FastEthernet0/0.2
Ý mình muốn là phải có 2 câu route về mạng 10.10.10.0/24 để load balance OSPF từ router R2 về mạng 10.10.10.0/24
ai biêt xin chỉ giúp
Comment