Xin chào ! Nếu đây là lần đầu tiên bạn đến với diễn đàn, xin vui lòng danh ra một phút bấm vào đây để đăng kí và tham gia thảo luận cùng VnPro.

Announcement

Collapse
No announcement yet.

Lab 1: Cấu hình e1 back-to-back

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Lab 1: Cấu hình e1 back-to-back

    LAB 1: CấU HÌNH E1 BACK-TO-BACK
    (by Minh Dang, 03/2015)
    1.Sơ đồ lab và yêu cầu

    • Gắn cáp theo sơ đồ hình vẽ.
    • Router backbone (site PSTN) gắn 1 x VWIC-2MFT-E1T1.
    • Router VnPro gắn 1 x VWIC-1MFT-E1T1
    • Switch có hỗ trợ PoE. Nếu không có hai switch PoE thì dùng vlan trên một switch.
    • Hai Cisco IP Phone 7942 hoặc 7960 hỗ trợ SIP/SCCP.
    • Cáp dùng giữa IP Phone và switch, switch và router dùng cáp thẳng.
    • Cáp UTP nối giữa hai router dùng E1 back to back theo sơ đồ cụ thể bên dưới:

    Cáp back-to-back này sẽ gắn vào card E1/T1 trên mỗi router.
    Yêu cầu:
    • IP Phone 1 trong nội bộ VnPro có số điện thoại là 3001.
    • Router VnPro chạy CME 8.6 hoặc 9.0
    • Router PSTN chạy CME 8.6 hoặc 9.0
    • IP Phone 2 gắn vào router backbone được gán số 35124222 là một số điện thoại công cộng.
    • Khi kết thúc bài lab, từ IPPhone1 phải có thể gọi được IPPhone 2 (35124222) và ngược lại.
    2. Cấu hình hạ tầng mạng (VLAN/DHCP/Trunking) và card E1 trên router.
    2.1 Router VnPro
    Router(config)#hostname VnPro
    Gán các địa chỉ IP cho router như bên dưới. Mạng bên trong router VnPro tạo các vlan 31 cho DATA và vlan32 cho VOICE. Cấu hình trunking trên router dùng các sub-interface. Cấu hình cổng loopback. Đoạn cấu hình dưới đây không hướng dẫn cách cấu hình VLAN trên switch, cấu hình trunking trên switch.
    Code:
    [I]interface Loopback0[/I]
    [I]ip address 10.10.3.3 255.255.255.255[/I]
    [I]![/I]
    [I]interface FastEthernet0/0[/I]
    [I]description connect to switch 3560 using trunking[/I]
    [I]no ip address[/I]
    [I]duplex auto[/I]
    [I]speed auto[/I]
    [I]![/I]
    [I]interface FastEthernet0/0.31[/I]
    [I]encapsulation dot1Q 31 native[/I]
    [I]ip address 10.10.31.1 255.255.255.0[/I]
    [I]![/I]
    [I]interface FastEthernet0/0.32[/I]
    [I]encapsulation dot1Q 32[/I]
    [I]ip address 10.10.32.1 255.255.255.0[/I]
    Cấu hình DHCP trên router VnPro để cung cấp địa chỉ IP cho các IP Phones trong mạng VnPro
    Code:
    !
    [I]ip dhcp pool vlan31[/I]
    [I]network 10.10.31.0 255.255.255.0[/I]
    [I]default-router 10.10.31.1[/I]
    [I]option 150 ip 10.10.3.3[/I]
    [I]![/I]
    [I]ip dhcp pool vlan32[/I]
    [I]network 10.10.32.0 255.255.255.0[/I]
    [I]default-router 10.10.32.1[/I]
    [I]option 150 ip 10.10.3.3[/I]
    [I]![/I]
    Kiểm tra địa chỉ IP của các cổng của router VnPro
    Code:
    [I]VnPro#sh ip int brief[/I]
    [I]Interface IP-Address OK? Method Status Protocol[/I]
    [I]FastEthernet0/0 unassigned YES NVRAM up up [/I]
    [I]FastEthernet0/0.31 10.10.31.1 YES NVRAM up up [/I]
    [I]FastEthernet0/0.32 10.10.32.1 YES NVRAM up up [/I]
    [I]Loopback0 10.10.3.3 YES NVRAM up up [/I]
    **Chú ý: Học viên tự cấu hình vlan trên switch gắn vào router. Cấu hình các cổng tương ứng trên switch để gắn IP Phone vào. Đoạn cấu hình switch dưới đây để học viên tham khảo.
    Code:
    [I]![/I]
    [I]interface FastEthernet0/17[/I]
    [I]description connet to ip phone[/I]
    [I]switchport access vlan 31[/I]
    [I]switchport trunk encapsulation dot1q[/I]
    [I]switchport mode access[/I]
    [I]switchport voice vlan 32[/I]
    [I]spanning-tree portfast[/I]
    [I]![/I]
    [I]interface FastEthernet0/18[/I]
    [I]switchport access vlan 31[/I]
    [I]switchport mode access[/I]
    [I]switchport voice vlan 32[/I]
    [I]spanning-tree portfast[/I]
    [I]![/I]
    [I]interface FastEthernet0/19[/I]
    [I]switchport access vlan 31[/I]
    [I]switchport mode access[/I]
    [I]switchport voice vlan 32[/I]
    [I]spanning-tree portfast[/I]
    [I]![/I]
    [I]interface FastEthernet0/20[/I]
    [I]switchport access vlan 31[/I]
    [I]switchport mode access[/I]
    [I]switchport voice vlan 32[/I]
    [I]spanning-tree portfast[/I]
    [I]! [/I]
    Quay trở lại cấu hình router VnPro. Kiểm tra card E1/T1 và module PVDM2 có được router nhận ra chưa. Chú ý các slot number và subslot number vì các cổng tạo ra về sau trên router sẽ dùng các số này.
    Code:
    [I]VnPro#show inventory[/I]
    [I]NAME: "2811 chassis", DESCR: "2811 chassis"[/I]
    [I]PID: CISCO2811 , VID: V01 , SN: FTX0941A0TS[/I]
    [I]NAME: "WAN Interface Card - Serial (1T) on Slot 0 SubSlot 0", DESCR: "WAN Interface Card - Serial (1T)"[/I]
    [I]PID: WIC-1T= , VID: 1.0, SN: 35700624[/I]
    [B][I]NAME: "VWIC2-2MFT-T1/E1 - 2-Port RJ-48 Multiflex Trunk - T1/E1 on Slot 0 SubSlot 3", DESCR: "VWIC2-2MFT-T1/E1 - 2-Port RJ-48 Multiflex Trunk - T1/E1"[/I][/B]
    [I]PID: VWIC2-2MFT-T1/E1 , VID: V01 , SN: FOC12033ZKG[/I]
    [B][I]NAME: "PVDMII DSP SIMM with Two DSPs on Slot 0 SubSlot 4", DESCR: "PVDMII DSP SIMM with Two DSPs[/I][/B][I]"[/I]
    [I]PID: PVDM2-32 , VID: V01 , SN: FOC11416XW9[/I]
    [I]NAME: "AIM Service Engine 1", DESCR: "AIM Service Engine"[/I]
    [I]PID: AIM-CUE , VID: V02 , SN: FOC111931E4[/I]
    Cấu hình để chuyển card sang hoạt động ở chế độ E1. Dùng lệnh network-clock-participate để router lấy thời gian và đồng bộ thời gian từ đường truyền E1. Dùng lệnh network-clock-select để router đồngbộ thời gian từ card E1. Dùng kiểu tổng đài ISDN là primary-ni hoặc primary-net5.
    Code:
    [I]VnPro#conf t[/I]
    [I]Enter configuration commands, one per line. End with CNTL/Z.[/I]
    [I]VnPro(config)#card type e1 0 3[/I]
    [I]VnPro(config)#network-clock-participate wic 3[/I]
    [I]VnPro(config)#network-clock-select 1 e1 0/3/0[/I]
    [I]Oct 16 18:54:49.044: %MARS_NETCLK-3-CLK_TRANS: Network clock source transitioned from priority 10 to priority 1[/I]
    [I]VnPro(config)#isdn switch-type primary-ni[/I]
    Cấu hình cổng E1 dùng timeslot 1-3.
    [I]![/I]
    [I]controller E1 0/3/0[/I]
    [I]pri-group timeslots 1-3,16[/I]
    [I]![/I]
    Framing được dùng mặc định là CRC4 và linecode HDB3. Sau khi nhập vào lệnh trên, router sẽ tự động tạo ra một cổng Serial0/3/0:15. Kênh D của ISDN dùng timeslot 16.
    Code:
    [I]VnPro#sh run int s0/3/0:15[/I]
    [I]![/I]
    [I]interface Serial0/3/0:15[/I]
    [I]no ip address[/I]
    [I]encapsulation hdlc[/I]
    [I]isdn switch-type primary-ni[/I]
    [I]isdn incoming-voice voice[/I]
    [I]no cdp enable[/I]
    [I]end[/I]
    ​​​​​​​2.2 Router backbone
    Cấu hình các bước tương tự như trên.
    • Gán hostname
    • Cấu hình DHCP
    • Cấu hình E1, ISDN switchtype
    Kiểm tra phần cứng của router. Trong kết quả bên dưới, router này có gắn 3 card VWIC-2MFT-E1T1. Trong router mà học viên sử dụng, số lượng card có thể sẽ khác. Trong bài lab này card 0/1/0 sẽ dùng để kết nối về router VnPro thông qua cáp E1 back-to-back. Học viên có thể chọn card, tùy thuộc vào sơ đồ cáp cụ thể.
    Code:
    [I]BB-Router#show inventory[/I]
    [I]NAME: "2851 chassis", DESCR: "2851 chassis"[/I]
    [I]PID: CISCO2851 , VID: V03 , SN: FHK1107F2P8[/I]
    [B][I]NAME: "VWIC2-2MFT-T1/E1 - 2-Port RJ-48 Multiflex Trunk - T1/E1 on Slot 0 SubSlot 0", DESCR: "VWIC2-2MFT-T1/E1 - 2-Port RJ-48 Multiflex Trunk - T1/E1"[/I][/B]
    [B][I]PID: VWIC2-2MFT-T1/E1 , VID: V01 , SN: FOC13313PY6[/I][/B]
    [B][I]NAME: "VWIC2-2MFT-T1/E1 - 2-Port RJ-48 Multiflex Trunk - T1/E1 on Slot 0 SubSlot 1", DESCR: "VWIC2-2MFT-T1/E1 - 2-Port RJ-48 Multiflex Trunk - T1/E1"[/I][/B]
    [I]PID: VWIC2-2MFT-T1/E1 , VID: V01 , SN: FOC11230B6T[/I]
    [B][I]NAME: "Two port T1 voice interface daughtercard on Slot 0 SubSlot 3", DESCR: "Tw o port T1 voice interface daughtercard"[/I][/B]
    [B][I]PID: VWIC-2MFT-T1= , VID: 1.0, SN: 33701390[/I][/B]
    [I]NAME: "PVDMII DSP SIMM with one DSP on Slot 0 SubSlot 4", DESCR: "PVDMII DSP SIM M with one DSP"[/I]
    [I]PID: PVDM2-16 , VID: V01 , SN: FOC12311VTE[/I]
    [I]NAME: "Four Port Low-Speed A/S Serial on Slot 1", DESCR: "Four Port Low-Speed A/ S Serial"[/I]
    [I]PID: NM-4A/S= , VID: 1.0, SN: 17144078[/I]
    Do loại card này hỗ trợ cả T1/E1 nên ta cấu hình để chuyển card sang kiểu E1.
    [I]card type e1 0 1[/I]
    [I]![/I]
    [I]network-clock-participate wic 0[/I]
    [I]network-clock-participate wic 1[/I]
    [I]network-clock-participate wic 3[/I]
    Cấu hình kiểu tổng đài isdn switchtype
    [I]![/I]
    [I]isdn switch-type primary-ni[/I]
    [I]![/I]
    Cấu hình controller E1, chú ý lệnh clock source. Lệnh này chỉ đặt ở một phía khi kết nối E1 back-to-back.
    Code:
    [I]![/I]
    [I]controller E1 0/1/0[/I]
    [I]clock source internal[/I]
    [I]pri-group timeslots 1-3,16[/I]
    [I]description **voice to VnPro router**[/I]
    [I]![/I]
    Router sẽ tự tạo ra một cổng Serial0/1/0:15. Kênh D là kênh điều khiển của ISDN. Trạng thái của cổng S0/1/0:15 phải là UP/UP.
    Code:
    [I]![/I]
    [I]interface Serial0/1/0:15[/I]
    [I]no ip address[/I]
    [I]encapsulation hdlc[/I]
    [I]isdn switch-type primary-ni[/I]
    [I]isdn protocol-emulate network[/I]
    [I]isdn incoming-voice voice[/I]
    [I]no cdp enable[/I]
    [I]! [/I]
    [I]BB-Router#show int serial0/1/0:15[/I]
    [B][I]Serial0/1/0:15 is up, line protocol is up (spoofing)[/I][/B]
    [I]Hardware is DSX1[/I]
    [I]MTU 1500 bytes, BW 64 Kbit/sec, DLY 20000 usec,[/I]
    [I]reliability 255/255, txload 1/255, rxload 1/255[/I]
    [I]Encapsulation HDLC, loopback not set[/I]
    [I]Keepalive set (10 sec)[/I]
    [I]Last input 00:00:04, output never, output hang never[/I]
    [I]Last clearing of "show interface" counters never[/I]
    [I]Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0[/I]
    [I]Queueing strategy: weighted fair[/I]
    [I]Output queue: 0/1000/64/0 (size/max total/threshold/drops)[/I]
    [I]Conversations 0/1/256 (active/max active/max total)[/I]
    [I]Reserved Conversations 0/0 (allocated/max allocated)[/I]
    [I]Available Bandwidth 48 kilobits/sec[/I]
    [I]5 minute input rate 0 bits/sec, 0 packets/sec[/I]
    [I]5 minute output rate 0 bits/sec, 0 packets/sec[/I]
    [I]825 packets input, 3298 bytes, 0 no buffer[/I]
    [I]Received 0 broadcasts (0 IP multicasts)[/I]
    [I]0 runts, 0 giants, 0 throttles[/I]
    [I]0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort[/I]
    [I]828 packets output, 3307 bytes, 0 underruns[/I]
    [I]0 output errors, 0 collisions, 0 interface resets[/I]
    [I]0 unknown protocol drops[/I]
    [I]0 output buffer failures, 0 output buffers swapped out[/I]
    [I]1 carrier transitions[/I]
    [I]Timeslot(s) Used:16, SCC: 0, Transmitter delay is 0 flags[/I]
    Kiểm tra trạng thái của card E1 có kết nối với router VnPro. Nếu trạng thái là Multiple Frame Established có nghĩa là router Backbone đã có thể gửi và nhận cuộc gọi trên luồng E1 này.
    Code:
    [I]BB-Router#show isdn status[/I]
    [I]Global ISDN Switchtype = primary-ni[/I]
    [I]ISDN Serial0/1/0:15 interface[/I]
    [I]******* Network side configuration *******[/I]
    [I]dsl 1, interface ISDN Switchtype = primary-ni[/I]
    [I]Layer 1 Status:[/I]
    [I][B]ACTIVE[/B][/I]
    [I]Layer 2 Status:[/I]
    [I]TEI = 0, Ces = 1, SAPI = 0, State = [B]MULTIPLE_FRAME_ESTABLISHED[/B][/I]
    [I]Layer 3 Status:[/I]
    [I][B]0 Active Layer 3 Call(s[/B])[/I]
    [I]Active dsl 1 CCBs = 0[/I]
    [I]The Free Channel Mask: 0x80000007[/I]
    [I]Number of L2 Discards = 0, L2 Session ID = 0[/I]
    Bước tiếp theo, cấu hình router Backbone làm DHCP server và gán các địa chỉ IP cho các cổng. Các IP Phone gắn vào mạng ở router backbone sẽ dùng DHCP server này.
    Code:
    [I]![/I]
    [I]ip dhcp pool BB[/I]
    [I]network 10.10.253.0 255.255.255.0[/I]
    [I]option 150 ip 10.10.4.4[/I]
    [I]default-router 10.10.253.1[/I]
    [I]![/I]
    [I]interface Loopback0[/I]
    [I]ip address 10.10.4.4 255.255.255.255[/I]
    [I]![/I]
    [I]interface GigabitEthernet0/0[/I]
    [I]description connect to BB vlan[/I]
    [I]ip address 10.10.253.1 255.255.255.0[/I]
    [I]duplex auto[/I]
    [I]speed auto[/I]
    [I]![/I]
    [I]interface Serial0/1/0:15[/I]
    [I]no ip address[/I]
    [I]encapsulation hdlc[/I]
    [I]isdn switch-type primary-ni[/I]
    [I]isdn protocol-emulate network[/I]
    [I]isdn incoming-voice voice[/I]
    [I]no cdp enable[/I]
    [I]![/I]
    Kiểm tra trạng thái của các cổng
    Code:
    [I]BB-Router#show ip int brief[/I]
    [I]Interface IP-Address OK? Method Status Protocol[/I]
    [I]GigabitEthernet0/0 10.10.253.1 YES NVRAM up up[/I]
    [I]Serial0/1/0:15 unassigned YES unset up up[/I]
    [I]Loopback0 10.10.4.4 YES NVRAM up up[/I]
    Và voice-port
    [I]#show run[/I]
    [I]![/I]
    [I]![/I]
    [I]voice-port 0/1/0:15[/I]
    [I]![/I]
    Quay lại router Vnpro, kiểm tra trạng thái ISDN và các cổng voice-port
    Code:
    [I]VnPro#show isdn status[/I]
    [I]Global ISDN Switchtype = primary-ni[/I]
    [I]ISDN Serial0/3/0:15 interface[/I]
    [I]dsl 0, interface ISDN Switchtype = [B]primary-ni[/B][/I]
    [I]Layer 1 Status:[/I]
    [I]ACTIVE[/I]
    [I]Layer 2 Status:[/I]
    [I]TEI = 0, Ces = 1, SAPI = 0, State = [B]MULTIPLE_FRAME_ESTABLISHED[/B][/I]
    [I]Layer 3 Status:[/I]
    [B][I]0 Active Layer 3 Call([/I][/B][I]s)[/I]
    [I]Active dsl 0 CCBs = 0[/I]
    [I]The Free Channel Mask: 0x80000007[/I]
    [I]Number of L2 Discards = 0, L2 Session ID = 1[/I]
    [I]Total Allocated ISDN CCBs = 0[/I]
    [I]VnPro#[/I]
    Và các voice-port
    [I]![/I]
    [I]voice-port 0/3/0:15[/I]
    [I]![/I]
    Code:
    [I]VnPro#show int s0/3/0:15[/I]
    [B][I]Serial0/3/0:15 is up, line protocol is up (spoofing)[/I][/B]
    [I]Hardware is DSX1[/I]
    [I]MTU 1500 bytes, BW 64 Kbit/sec, DLY 20000 usec,[/I]
    [I]reliability 255/255, txload 1/255, rxload 1/255[/I]
    [I]Encapsulation HDLC, loopback not set[/I]
    [I]Keepalive set (10 sec)[/I]
    [I]Last input 00:00:18, output never, output hang never[/I]
    [I]Last clearing of "show interface" counters never[/I]
    [I]Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0[/I]
    [I]Queueing strategy: weighted fair[/I]
    [I]Output queue: 0/1000/64/0 (size/max total/threshold/drops)[/I]
    [I]Conversations 0/1/256 (active/max active/max total)[/I]
    [I]Reserved Conversations 0/0 (allocated/max allocated)[/I]
    [I]Available Bandwidth 48 kilobits/sec[/I]
    [I]5 minute input rate 0 bits/sec, 0 packets/sec[/I]
    [I]5 minute output rate 0 bits/sec, 0 packets/sec[/I]
    [I]Timeslot(s) Used:16, SCC: 0, Transmitter delay is 0 flags[/I]
    Kiểm tra trạng thái của E1 controller trên router. Nếu không có slip nghĩa là đường truyền không bị nhiễu.
    Code:
    [I]VnPro#show controller e1[/I]
    [B][I]E1 0/3/0 is up.[/I][/B]
    [I]Applique type is Channelized E1 - balanced[/I]
    [I]No alarms detected.[/I]
    [I]alarm-trigger is not set[/I]
    [I]Version info Firmware: 20100222, FPGA: 13, spm_count = 0[/I]
    [I][B]Framing is CRC4, Line Code is HDB3, Clock Source is Line.[/B][/I]
    [I]Data in current interval (7 seconds elapsed):[/I]
    [I]0 Line Code Violations, 0 Path Code Violations[/I]
    [I][B]0 Slip Secs[/B], 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins[/I]
    [I]0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs[/I]
    [I]Total Data (last 15 15 minute intervals):[/I]
    [I]1 Line Code Violations, 1 Path Code Violations,[/I]
    [I][B]1 Slip Secs,[/B] 0 Fr Loss Secs, 1 Line Err Secs, 0 Degraded Mins,[/I]
    [I]2 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs[/I]
    Code:
    [I]VnPro#show network-clocks[/I]
    [I]Network Clock Configuration[/I]
    [I]---------------------------[/I]
    [I]Priority Clock Source Clock State Clock Type[/I]
    
    [I][B]1 E1 0/3/0 GOOD E1[/B][/I]
    [I]10 Backplane GOOD PLL[/I]
    
    [I]Current Primary Clock Source[/I]
    [I]---------------------------[/I]
    [I]Priority Clock Source Clock State Clock Type[/I]
    
    [I]1 [B]E1 0/3/0 GOOD E1[/B][/I]
    3.Cấu hình telephony, CME, dial-peer

    3.1 Backbone router
    Download và tải các file firmware của IP Phone vào flash. Cấu hình router backbone như CME để nhận cuộc gọi từ router Vnpro.
    Cho phép router nhận các cuộc gọi voip
    Code:
    [I]![/I]
    [I]voice service voip[/I]
    [I]no ip address trusted authenticate[/I]
    [I]allow-connections h323 to h323[/I]
    [I]allow-connections h323 to sip[/I]
    [I]allow-connections sip to h323[/I]
    [I]allow-connections sip to sip[/I]
    [I]sip[/I]
    [I]bind control source-interface GigabitEthernet0/1[/I]
    [I]bind media source-interface GigabitEthernet0/1[/I]
    [I]![/I]
    Chép các file firmware vào flash. Cấu hình router như TFTP-server để các IP Phone có thể download các firmware khi khởi động
    Code:
    [I]![/I]
    [I]tftp-server flash:apps41.9-4-2TH1-1.sbn[/I]
    [I]tftp-server flash:cnu41.9-4-2TH1-1.sbn[/I]
    [I]tftp-server flash:cvm41sccp.9-4-2TH1-1.sbn[/I]
    [I]tftp-server flash:dsp41.9-4-2TH1-1.sbn[/I]
    [I]tftp-server flash:jar41sccp.9-4-2TH1-1.sbn[/I]
    [I]tftp-server flash:SCCP41.9-4-2-1S.loads[/I]
    [I]tftp-server flash:term41.default.loads[/I]
    [I]tftp-server flash:term61.default.loads[/I]
    [I]![/I]
    Cấu hình telephony-service
    Code:
    [I]![/I]
    [I]telephony-service[/I]
    [I]no auto-reg-ephone[/I]
    [I]max-ephones 5[/I]
    [I]max-dn 20[/I]
    [I]ip source-address 10.10.4.4 port 2000[/I]
    [I]system message VnPro CCNA Voice Lab[/I]
    [I]load 7961 SCCP41.9-4-2-1S[/I]
    [I]max-conferences 8 gain -6[/I]
    [I]web admin system name admin password vnpro[/I]
    [I]dn-webedit[/I]
    [I]time-webedit[/I]
    [I]transfer-system full-consult[/I]
    [I]create cnf-files version-stamp 7960 Mar 08 2015 16:08:47[/I]
    [I]![/I]
    Tạo các ephone-dn (directory number, ephone)
    [I]![/I]
    [I]ephone-dn 1 dual-line[/I]
    [I]number 35124222[/I]
    [I]![/I]
    [I]ephone 1[/I]
    [I]device-security-mode none[/I]
    [I]mac-address 0023.339D.9386[/I]
    [I]type 7961[/I]
    [I]button 1:1 [/I]
    [I]![/I]
    Gắn IP Phone, kiểm tra xem IP Phone đã nhận đăng ký chưa.
    Code:
    [I]BB-Router#show ephone registered[/I]
    [I]ephone-1[0] Mac:0023.339D.9386 TCP socket:[2] activeLine:0 whisperLine:0 REGISTERED in SCCP ver 22/17 max_streams=5[/I]
    [I]mediaActive:0 whisper_mediaActive:0 startMedia:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:8[/I]
    [I]IP:10.10.253.3 * 52570 7961GE keepalive 309 max_line 6 available_line 6[/I]
    [I]button 1: cw:1 ccw:(0 0)[/I]
    [I]dn 1 number 911 CH1 IDLE CH2 IDLE[/I]
    [I]button 2: cw:1 ccw:(0)[/I]
    [I]dn 2 number 999 CH1 IDLE[/I]
    [I]button 4: cw:1 ccw:(0)[/I]
    [I]dn 4 number 3127764016 CH1 IDLE[/I]
    [I]button 5: cw:1 ccw:(0)[/I]
    [I]dn 5 number 307128788 CH1 IDLE[/I]
    [I]button 6: cw:1 ccw:(0)[/I]
    [I]dn 6 number 689220420 CH1 IDLE[/I]
    [I]Preferred Codec: g711ulaw[/I]
    [I]Lpcor Type: none[/I]
    Cấu hình các dial-peer để có thể nhận vào chuyển cuộc gọi vào/ra.
    Code:
    [I]![/I]
    [I]dial-peer voice 301 pots[/I]
    [I]destination-pattern 3...$[/I]
    [I]port 0/1/0:15[/I]
    [I]forward-digits all[/I]
    [I]![/I]
    [I]dial-peer voice 1 pots[/I]
    [I]incoming called-number .[/I]
    [I]direct-inward-dial[/I]
    [I]![/I]
    ​​​​​​​3.2 VnPro router
    Download và tải các file IOS firmware của các IP Phone vào flash. Nếu trong bài lab dùng IP Phone 7960 và 7942 thì download các firmware tương ứng.
    Code:
    [I]VnPro#dir flash:[/I]
    [I]Directory of flash:/[/I]
    
    [I]1 -rw- 5237 Jan 24 2009 08:42:18 +00:00 7970-71-75-Background-readme-v1.txt[/I]
    [I]2 -rw- 67922508 May 19 2014 16:27:44 +00:00 c2800nm-adventerprisek9-mz.151-4.M8.bin[/I]
    [I]3 -rw- 496521 Mar 29 2004 11:40:48 +00:00 music-on-hold.au[/I]
    [I]4 drw- 0 Oct 3 2014 14:20:34 +00:00 7970-71-75-backgroundsv1[/I]
    [I]24 drw- 0 Oct 3 2014 14:20:34 +00:00 cme-b-acd-3.0.0.2[/I]
    [I]29 drw- 0 Oct 3 2014 14:20:36 +00:00 cme-tsp-2.2.0.5[/I]
    [I]32 drw- 0 Oct 3 2014 14:20:36 +00:00 cucme-mlpp[/I]
    [I]51 drw- 0 Oct 3 2014 14:20:38 +00:00 GUI[/I]
    [I]70 drw- 0 Oct 3 2014 14:21:16 +00:00 IP_Phones[/I]
    [I]205 drw- 0 Oct 3 2014 14:21:16 +00:00 ringtones[/I]
    [I][B]239 -rw- 3153295 Jan 25 2015 04:01:14 +00:00 apps41.9-4-2TH1-1.sbn[/B][/I]
    [B][I]240 -rw- 557123 Jan 25 2015 04:01:40 +00:00 cnu41.9-4-2TH1-1.sbn[/I][/B]
    [B][I]241 -rw- 2216031 Jan 25 2015 04:02:20 +00:00 cvm41sccp.9-4-2TH1-1.sbn[/I][/B]
    [B][I]242 -rw- 561897 Jan 25 2015 04:02:48 +00:00 dsp41.9-4-2TH1-1.sbn[/I][/B]
    [B][I]243 -rw- 1630056 Jan 25 2015 04:03:32 +00:00 jar41sccp.9-4-2TH1-1.sbn[/I][/B]
    [B][I]244 -rw- 654 Jan 25 2015 04:03:56 +00:00 SCCP41.9-4-2-1S.loads[/I][/B]
    [B][I]245 -rw- 654 Jan 25 2015 04:04:16 +00:00 term41.default.loads[/I][/B]
    [I]246 -rw- 654 Jan 25 2015 04:04:34 +00:00 term61.default.loads[/I]
    [I]247 drw- 0 Jan 25 2015 04:13:52 +00:00 its[/I]
    [I]259 -rw- 10728 Feb 22 2015 19:17:08 +00:00 dkern9971.100609R2-9-4-2SR1-2.sebn[/I]
    [I]260 -rw- 1676960 Feb 22 2015 19:17:46 +00:00 kern9971.9-4-2SR1-2.sebn[/I]
    [I]261 -rw- 37536512 Feb 22 2015 19:22:32 +00:00 rootfs9971.9-4-2SR1-2.sebn[/I]
    [I]262 -rw- 147256 Feb 22 2015 19:23:00 +00:00 sboot9971.031610R1-9-4-2SR1-2.sebn[/I]
    [I]263 -rw- 1297 Feb 22 2015 19:23:22 +00:00 sip9971.9-4-2SR1-2.loads[/I]
    [I]264 -rw- 67000 Feb 22 2015 19:23:42 +00:00 skern9971.022809R2-9-4-2SR1-2.sebn[/I]
    [I]265 -rw- 69 Mar 8 2015 14:58:54 +00:00 syncinfo.xml[/I]
    [I]266 -rw- 1994 Mar 8 2015 14:58:56 +00:00 SIPDefault.cnf[/I]
    [I]267 -rw- 4342 Mar 8 2015 14:58:56 +00:00 softkeyDefault_kpml.xml[/I]
    [I]268 -rw- 4376 Mar 8 2015 14:58:56 +00:00 softkeyDefault.xml[/I]
    [I]269 -rw- 825 Mar 8 2015 14:58:58 +00:00 featurePolicyDefault.xml[/I]
    [I]270 -rw- 4248 Mar 8 2015 14:58:58 +00:00 SEP0008308B8AE5.cnf.xml[/I]
    [I]271 -rw- 68406112 Feb 22 2015 20:29:22 +00:00 c2800nm-adventerprisek9_ivs-mz.151-4.M9.bin[/I]
    1014267904 bytes total (413024256 bytes free)
    Code:
    [I]VnPro#[/I]
    Cấu hình TFTP-server
    [I]VnPro#config t[/I]
    [I]tftp-server flash:term61.default.loads[/I]
    [I]tftp-server flash:term41.default.loads[/I]
    [I]tftp-server flash:SCCP41.9-4-2-1S.loads[/I]
    [I]tftp-server flash:jar41sccp.9-4-2TH1-1.sbn[/I]
    [I]tftp-server flash:dsp41.9-4-2TH1-1.sbn[/I]
    [I]tftp-server flash:cnu41.9-4-2TH1-1.sbn[/I]
    [I]tftp-server flash:apps41.9-4-2TH1-1.sbn[/I]
    [I]VnPro#[/I]
    Cấu hình CUBE và SIP server. Cấu hình bên dưới cho phép router chuyển nhận các cuộc gọi VoIP. Router cũng hoạt động như một sip server để nhận các đăng ký từ các sip phones.
    Code:
    [I]![/I]
    [I]voice service voip[/I]
    [I]allow-connections h323 to h323[/I]
    [I]allow-connections h323 to sip[/I]
    [I]allow-connections sip to h323[/I]
    [I]allow-connections sip to sip[/I]
    [I]sip[/I]
    [I]bind control source-interface FastEthernet0/0.31[/I]
    [I]bind media source-interface FastEthernet0/0.31[/I]
    [I]registrar server expires max 600 min 60[/I]
    [I]![/I]
    Cấu hình telephony-service
    Code:
    [I]![/I]
    [I]telephony-service[/I]
    [I]no auto-reg-ephone[/I]
    [I]max-ephones 5[/I]
    [I]max-dn 10[/I]
    [I]ip source-address 10.10.31.1 port 2000[/I]
    [I]system message VnPro CCNA Voice Lab[/I]
    [I]cnf-file location flash:[/I]
    [I]cnf-file perphone[/I]
    [I]load 7961 SCCP41.9-4-2-1S.loads[/I]
    [I]time-zone 24[/I]
    [I]time-format 24[/I]
    [I]date-format dd-mm-yy[/I]
    [I]max-conferences 8 gain -6[/I]
    [I]call-park system application[/I]
    [I]transfer-system full-consult[/I]
    [I]![/I]
    Cấu hình ephone-dn và ephone cho điện thoại SCCP. Chú ý thay đổi MAC address tương ứng.
    Code:
    [I]![/I]
    [I]ephone-dn 1 [/I]
    [I]number 3001[/I]
    [I]description 3001[/I]
    [I]name VnPro Phone 1[/I]
    [I]![/I]
    [I]ephone 1[/I]
    [I]device-security-mode none[/I]
    [I]mac-address 0015.C65C.629F[/I]
    [I]type 7960[/I]
    [I]button 1:1 [/I]
    [I]![/I]
    Gắn điện thoại IP Phone1 vào switch. Kiểm tra xem điện thoại đã được đăng ký thành công không:
    Code:
    [I]VnPro#show ephone registered[/I]
    [I]ephone-1[0] Mac:0015.C65C.629F TCP socket:[1] activeLine:0 whisperLine:0 REGISTERED in SCCP ver 11/9 max_streams=0[/I]
    [I]mediaActive:0 whisper_mediaActive:0 startMedia:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:8 privacy:1[/I]
    [I]IP:10.10.32.4 * 49818 Telecaster 7960 keepalive 267 max_line 6 available_line 2[/I]
    [I]button 1: cw:1 ccw:(0 0 0 0 0 0 0 0)[/I]
    [I]dn 1 number 3001 CH1 IDLE CH2 IDLE [/I]
    [I]button 2: cw:1 ccw:(0)[/I]
    [I]dn 2 number 3011 CH1 IDLE overlay[/I]
    [I]overlay 2: 2(3011) 3(3012)[/I]
    [I]speed dial 1:3002 SC Phone 2[/I]
    [I]blf speed dial 2:3002 SC Phone 2 BLF[/I]
    [I]paging-dn 8[/I]
    [I]Preferred Codec: g711ulaw[/I]
    [I]Lpcor Type: none[/I]
    Cấu hình dial-peer để router nhận tất cả các cuộc gọi từ bên ngoài gọi vào
    [I]R3(config)#dial-peer voice 1 pots[/I]
    [I]R3(config-dial-peer)#incoming called-number .[/I]
    [I]R3(config-dial-peer)#direct-inward-dial[/I]
    Lệnh direct-inward-dial để router không tạo secondary tone. Lệnh incoming called-number sẽ làm cho dial-peer này nhận được tất cả các số gọi.
    Cấu hình dial-peer cho gọi ra mạng PSTN. Mạng PSTN nên kiểu dial-peer là pots.
    [I]dial-peer voice 2 pots[/I]
    [I]destination-pattern 35124222$[/I]
    [I]port 0/3/0:15[/I]
    [I]forward-digits all[/I]
    [I]![/I]
    Sau khi thực hiện xong bước này, bạn có thể thực hiện cuộc gọi giữa các IP Phone. Từ Vnpro IP Phone 1, gọi ra PSTN Phone. Tiến hành các lệnh #debug isdn q931 để quan sát trạng thái kết nối.
    Để tên của người gọi và số của người gọi có thể hiển thị và gửi ra mạng điện thoại công cộng, dùng thêm lệnh
    [I]VnPro(config)#int s0/0/0:15[/I]
    [I]Vnpro(config-if)#isdn outgoing display-ie[/I]
    4. Toàn bộ cấu hình
    4.1Backbone router

    Code:
    number 6131218
    !
    !
    ephone-dn 4
    number 3127764016
    !
    !
    ephone-dn 5
    number 307128788
    !
    !
    ephone-dn 6
    number 689220420
    !
    !
    ephone-dn 7
    number 8662258064
    !
    !
    ephone-dn 8
    number 8103321444
    !
    !
    ephone 1
    device-security-mode none
    mac-address 0023.339D.9386
    type 7961
    button 1:1 2:2 4:4 5:5
    button 6:6
    !
    !
    !
    ephone 2
    device-security-mode none
    mac-address 0022.905A.7E61
    type 7961
    button 1:3 2:7 3:8
    !
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    login
    transport input all
    !
    scheduler allocate 20000 1000
    ntp master
    end
    
    BB-Router#$
    
    BB-Router#sh run
    Building configuration...
    
    
    Current configuration : 9338 bytes
    !
    ! No configuration change since last restart
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname BB-Router
    !
    card type t1 0 0
    card type e1 0 1
    !
    network-clock-participate wic 0
    network-clock-participate wic 1
    network-clock-participate wic 3
    !
    ip cef
    !
    ip dhcp pool BB
    network 10.10.253.0 255.255.255.0
    option 150 ip 10.10.4.4
    default-router 10.10.253.1
    !
    no ip domain lookup
    isdn switch-type primary-ni
    !
    voice service voip
    no ip address trusted authenticate
    allow-connections h323 to h323
    allow-connections h323 to sip
    allow-connections sip to h323
    allow-connections sip to sip
    sip
    bind control source-interface GigabitEthernet0/1
    bind media source-interface GigabitEthernet0/1
    !
    voice class codec 1
    codec preference 1 g711ulaw
    codec preference 2 g729r8
    !
    controller E1 0/1/0
    clock source internal
    pri-group timeslots 1-3,16
    description **voice to site VnPro**
    !
    interface Loopback0
    ip address 10.10.4.4 255.255.255.255
    !
    interface GigabitEthernet0/0
    description connect to BB vlan
    ip address 10.10.253.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface Serial0/1/0:15
    no ip address
    encapsulation hdlc
    isdn switch-type primary-ni
    isdn protocol-emulate network
    isdn incoming-voice voice
    no cdp enable
    !
    ip forward-protocol nd
    ip http server
    no ip http secure-server
    ip http path flash:GUI
    !
    tftp-server flash:apps41.9-4-2TH1-1.sbn
    tftp-server flash:cnu41.9-4-2TH1-1.sbn
    tftp-server flash:cvm41sccp.9-4-2TH1-1.sbn
    tftp-server flash:dsp41.9-4-2TH1-1.sbn
    tftp-server flash:jar41sccp.9-4-2TH1-1.sbn
    tftp-server flash:SCCP41.9-4-2-1S.loads
    tftp-server flash:term41.default.loads
    tftp-server flash:term61.default.loads
    !
    control-plane
    !
    voice-port 0/1/0:15
    !
    dial-peer voice 2 pots
    destination-pattern 3...$
    port 0/1/0:15
    forward-digits all
    !
    dial-peer voice 1 pots
    incoming called-number .
    direct-inward-dial
    !
    telephony-service
    no auto-reg-ephone
    max-ephones 5
    max-dn 20
    ip source-address 10.10.4.4 port 2000
    system message VnPro CCNA Voice Lab
    load 7961 SCCP41.9-4-2-1S
    max-conferences 8 gain -6
    web admin system name admin password vnpro
    dn-webedit
    time-webedit
    transfer-system full-consult
    create cnf-files version-stamp 7960 Mar 08 2015 16:08:47
    !
    ephone-dn 1 dual-line
    number 35124222
    !
    ephone 1
    device-security-mode none
    mac-address 0023.339D.9386
    type 7961
    button 1:1
    !
    ntp master
    end
    4.2 VnPro router
    Code:
    BB-Router con0 is now available
    
    
    
    
    
    Press RETURN to get started.
    
    
    VnPro#sh run
    Building configuration...
    Current configuration : 7372 bytes
    !
    ! Last configuration change at 15:54:14 UTC Sun Mar 8 2015
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname VnPro
    !
    boot system flash:c2800nm-adventerprisek9_ivs-mz.151-4.M9.bin
    !
    card type e1 0 3
    !
    no aaa new-model
    !
    network-clock-participate wic 3
    network-clock-select 1 E1 0/3/0
    !
    dot11 syslog
    ip source-route
    ip cef
    !
    ip dhcp pool vlan31
    network 10.10.31.0 255.255.255.0
    default-router 10.10.31.1
    option 150 ip 10.10.3.3
    !
    ip dhcp pool vlan32
    network 10.10.32.0 255.255.255.0
    default-router 10.10.32.1
    option 150 ip 10.10.3.3
    !
    no ip domain lookup
    no ipv6 cef
    !
    isdn switch-type primary-ni
    !
    voice service voip
    allow-connections h323 to h323
    allow-connections h323 to sip
    allow-connections sip to h323
    allow-connections sip to sip
    sip
    bind control source-interface FastEthernet0/0.31
    bind media source-interface FastEthernet0/0.31
    registrar server expires max 600 min 60
    !
    voice class codec 1
    codec preference 1 g711ulaw
    codec preference 2 g729r8
    !
    voice register global
    mode cme
    source-address 10.10.31.1 port 5060
    max-dn 144
    max-pool 42
    load 9971 sip9971.9-4-2SR1-2
    authenticate register
    timezone 24
    time-format 24
    date-format D/M/Y
    url authentication http://10.10.31.1/CCMCIP/authenticate.asp
    tftp-path flash:
    create profile sync 0014533448234022
    ntp-server 10.10.1.1 mode directedbroadcast
    !
    !
    voice-card 0
    !
    controller E1 0/3/0
    pri-group timeslots 1-3,16
    !
    interface Loopback0
    ip address 10.10.3.3 255.255.255.255
    !
    interface FastEthernet0/0
    description connect to switch trunking
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet0/0.31
    encapsulation dot1Q 31 native
    ip address 10.10.31.1 255.255.255.0
    !
    interface FastEthernet0/0.32
    encapsulation dot1Q 32
    ip address 10.10.32.1 255.255.255.0
    !
    ip forward-protocol nd
    ip http server
    no ip http secure-server
    ip http path flash:
    !
    tftp-server flash:term61.default.loads
    tftp-server flash:term41.default.loads
    tftp-server flash:SCCP41.9-4-2-1S.loads
    tftp-server flash:jar41sccp.9-4-2TH1-1.sbn
    tftp-server flash:dsp41.9-4-2TH1-1.sbn
    tftp-server flash:cnu41.9-4-2TH1-1.sbn
    tftp-server flash:apps41.9-4-2TH1-1.sbn
    !
    voice-port 0/3/0:15
    !
    mgcp profile default
    !
    dial-peer voice 1 pots
    incoming called-number .
    direct-inward-dial
    !
    dial-peer voice 2 pots
    destination-pattern 35124222$
    port 0/3/0:15
    forward-digits all
    !
    sip-ua
    presence enable
    !
    gatekeeper
    shutdown
    !
    !
    telephony-service
    no auto-reg-ephone
    max-ephones 5
    max-dn 10
    ip source-address 10.10.31.1 port 2000
    system message VnPro CCNA Voice Lab
    cnf-file location flash:
    cnf-file perphone
    load 7961 SCCP41.9-4-2-1S.loads
    time-zone 24
    time-format 24
    date-format dd-mm-yy
    max-conferences 8 gain -6
    call-park system application
    transfer-system full-consult
    create cnf-files version-stamp 7960 Feb 22 2015 21:21:46
    !
    ephone-dn 1
    number 3001
    description 3001
    name VnPro Phone 1
    !
    ephone 1
    device-security-mode none
    mac-address 0015.C65C.629F
    type 7960
    button 1:1
    !
    end

    Phan Trung Tín
    Email: phantrungtin@vnpro.org
    .
    Trung Tâm Tin Học VnPro
    149/1D Ung Văn Khiêm, P.25, Q.Bình Thạnh, Tp.HCM
    Tel: (028) 35124257 (028) 36222234
    Fax: (028) 35124314

    Home Page: http://www.vnpro.vn
    Forum: http://www.vnpro.org
    Twitter: https://twitter.com/VnVnpro
    LinkedIn: https://www.linkedin.com/in/VnPro
    - Chuyên đào tạo quản trị mạng và hạ tầng Internet
    - Phát hành sách chuyên môn
    - Tư vấn và tuyển dụng nhân sự IT
    - Tư vấn thiết kế và hỗ trợ kỹ thuật hệ thống mạng

    Videos: http://www.dancisco.com
    Blog: http://www.vnpro.org/blog
    Facebook: http://facebook.com/VnPro
    Zalo: https://zalo.me/1005309060549762169
    ​​​​​​
Working...
X