Trong mô hình trên Con FR cấu hình để được các PVC là R1->R2, R1->R3.
Cấu hình của FR:
hostname FRSW
no ip domain lookup
frame-relay switching
interface s1/0
encapsulation frame-relay ietf
frame-relay intf-type dce
frame-relay lmi-type q933a
frame-relay route 102 interface Serial1/1 201
frame-relay route 103 interface Serial1/2 301
no shutdown
exit
interface s1/1
encapsulation frame-relay ietf
frame-relay intf-type dce
frame-relay lmi-type q933a
frame-relay route 201 interface Serial1/0 102
no shutdown
exit
interface s1/2
encapsulation frame-relay ietf
frame-relay intf-type dce
frame-relay lmi-type q933a
frame-relay route 301 interface Serial1/0 103
no shutdown
exit
no ip domain lookup
frame-relay switching
interface s1/0
encapsulation frame-relay ietf
frame-relay intf-type dce
frame-relay lmi-type q933a
frame-relay route 102 interface Serial1/1 201
frame-relay route 103 interface Serial1/2 301
no shutdown
exit
interface s1/1
encapsulation frame-relay ietf
frame-relay intf-type dce
frame-relay lmi-type q933a
frame-relay route 201 interface Serial1/0 102
no shutdown
exit
interface s1/2
encapsulation frame-relay ietf
frame-relay intf-type dce
frame-relay lmi-type q933a
frame-relay route 301 interface Serial1/0 103
no shutdown
exit
hostname R1
no ip domain lookup
interface fa0/0
ip address 172.16.1.1 255.255.255.0
no shutdown
keepalive
exit
interface S1/0
encapsulation frame-relay ietf
frame-relay lmi-type q933a
no ip address
no shutdown
exit
interface s1/0.1 multipoint
ip address 194.1.1.1 255.255.255.0
no ip split-horizon
frame-relay map ip 194.1.1.2 102 broadcast
frame-relay map ip 194.1.1.3 103 broadcast
no shutdown
exit
router rip
version 2
no auto-summary
network 194.1.1.0
network 172.16.0.0
exit
no ip domain lookup
interface fa0/0
ip address 172.16.1.1 255.255.255.0
no shutdown
keepalive
exit
interface S1/0
encapsulation frame-relay ietf
frame-relay lmi-type q933a
no ip address
no shutdown
exit
interface s1/0.1 multipoint
ip address 194.1.1.1 255.255.255.0
no ip split-horizon
frame-relay map ip 194.1.1.2 102 broadcast
frame-relay map ip 194.1.1.3 103 broadcast
no shutdown
exit
router rip
version 2
no auto-summary
network 194.1.1.0
network 172.16.0.0
exit
hostname R2
no ip domain lookup
interface fa0/0
ip address 172.16.2.1 255.255.255.0
no shutdown
keepalive
exit
interface S1/0
encapsulation frame-relay ietf
frame-relay lmi-type q933a
no ip address
no shutdown
exit
interface s1/0
ip address 194.1.1.2 255.255.255.0
frame-relay interface-dlci 201
no shutdown
exit
router rip
version 2
no auto-summary
network 194.1.1.0
network 172.16.0.0
exit
no ip domain lookup
interface fa0/0
ip address 172.16.2.1 255.255.255.0
no shutdown
keepalive
exit
interface S1/0
encapsulation frame-relay ietf
frame-relay lmi-type q933a
no ip address
no shutdown
exit
interface s1/0
ip address 194.1.1.2 255.255.255.0
frame-relay interface-dlci 201
no shutdown
exit
router rip
version 2
no auto-summary
network 194.1.1.0
network 172.16.0.0
exit
hostname R3
no ip domain lookup
interface fa0/0
ip address 172.16.3.1 255.255.255.0
no shutdown
keepalive
exit
interface S1/0
encapsulation frame-relay ietf
frame-relay lmi-type q933a
no ip address
no shutdown
exit
interface s1/0
ip address 194.1.1.3 255.255.255.0
frame-relay interface-dlci 301
no shutdown
exit
router rip
version 2
no auto-summary
network 194.1.1.0
network 172.16.0.0
exit
no ip domain lookup
interface fa0/0
ip address 172.16.3.1 255.255.255.0
no shutdown
keepalive
exit
interface S1/0
encapsulation frame-relay ietf
frame-relay lmi-type q933a
no ip address
no shutdown
exit
interface s1/0
ip address 194.1.1.3 255.255.255.0
frame-relay interface-dlci 301
no shutdown
exit
router rip
version 2
no auto-summary
network 194.1.1.0
network 172.16.0.0
exit
FRSW#show frame-relay route
Input Intf Input Dlci Output Intf Output Dlci Status
Serial1/0 102 Serial1/1 201 active
Serial1/0 103 Serial1/2 301 active
Serial1/1 201 Serial1/0 102 active
Serial1/2 301 Serial1/0 103 active
FRSW#
Input Intf Input Dlci Output Intf Output Dlci Status
Serial1/0 102 Serial1/1 201 active
Serial1/0 103 Serial1/2 301 active
Serial1/1 201 Serial1/0 102 active
Serial1/2 301 Serial1/0 103 active
FRSW#
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 3 subnets
C 172.16.1.0 is directly connected, FastEthernet0/0
R 172.16.2.0 [120/1] via 194.1.1.2, 00:00:26, Serial1/0.1
R 172.16.3.0 [120/1] via 194.1.1.3, 00:00:00, Serial1/0.1
C 194.1.1.0/24 is directly connected, Serial1/0.1
R1#
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 3 subnets
C 172.16.1.0 is directly connected, FastEthernet0/0
R 172.16.2.0 [120/1] via 194.1.1.2, 00:00:26, Serial1/0.1
R 172.16.3.0 [120/1] via 194.1.1.3, 00:00:00, Serial1/0.1
C 194.1.1.0/24 is directly connected, Serial1/0.1
R1#
R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 3 subnets
R 172.16.1.0 [120/1] via 194.1.1.1, 00:00:24, Serial1/0
C 172.16.2.0 is directly connected, FastEthernet0/0
R 172.16.3.0 [120/2] via 194.1.1.3, 00:00:24, Serial1/0
C 194.1.1.0/24 is directly connected, Serial1/0
R2#
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 3 subnets
R 172.16.1.0 [120/1] via 194.1.1.1, 00:00:24, Serial1/0
C 172.16.2.0 is directly connected, FastEthernet0/0
R 172.16.3.0 [120/2] via 194.1.1.3, 00:00:24, Serial1/0
C 194.1.1.0/24 is directly connected, Serial1/0
R2#
R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 3 subnets
R 172.16.1.0 [120/1] via 194.1.1.1, 00:00:00, Serial1/0
R 172.16.2.0 [120/2] via 194.1.1.2, 00:00:00, Serial1/0
C 172.16.3.0 is directly connected, FastEthernet0/0
C 194.1.1.0/24 is directly connected, Serial1/0
R3#
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 3 subnets
R 172.16.1.0 [120/1] via 194.1.1.1, 00:00:00, Serial1/0
R 172.16.2.0 [120/2] via 194.1.1.2, 00:00:00, Serial1/0
C 172.16.3.0 is directly connected, FastEthernet0/0
C 194.1.1.0/24 is directly connected, Serial1/0
R3#
R2#ping 172.16.3.1 source 172.16.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.1, timeout is 2 seconds:
Packet sent with a source address of 172.16.2.1
.....
Success rate is 0 percent (0/5)
R2#
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.1, timeout is 2 seconds:
Packet sent with a source address of 172.16.2.1
.....
Success rate is 0 percent (0/5)
R2#
Nhưng khi cấu hình subinterface trên R2 và R3 thì lại ping thành công.
R2:
interface s1/0.201 point-to-point
ip address 194.1.1.2 255.255.255.0
frame-relay interface-dlci 201
no shutdown
exit
ip address 194.1.1.2 255.255.255.0
frame-relay interface-dlci 201
no shutdown
exit
R3:
interface s1/0.301 point-to-point
ip address 194.1.1.3 255.255.255.0
frame-relay interface-dlci 301
no shutdown
exit
ip address 194.1.1.3 255.255.255.0
frame-relay interface-dlci 301
no shutdown
exit
R2#ping 172.16.3.1 source 172.16.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.1, timeout is 2 seconds:
Packet sent with a source address of 172.16.2.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 76/92/108 ms
R2#
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.1, timeout is 2 seconds:
Packet sent with a source address of 172.16.2.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 76/92/108 ms
R2#
R2#traceroute 172.16.3.1 source 172.16.2.1
Type escape sequence to abort.
Tracing the route to 172.16.3.1
1 194.1.1.1 40 msec 44 msec 44 msec
2 194.1.1.3 100 msec * 88 msec
R2#
Type escape sequence to abort.
Tracing the route to 172.16.3.1
1 194.1.1.1 40 msec 44 msec 44 msec
2 194.1.1.3 100 msec * 88 msec
R2#
còn khi cấu hình subinterface point to point lại là đi được.
Rất mong nhận được giải đáp
Thanks!
Comment