Cấu hình Frame Relay Point to point, dạng full-mesh. R2 và R3 có kết nối trực tiếp, chứ không thông qua R1 như mô hình dạng Hub&Spoke .
Chạy định tuyến RIP để quảng bá mạng cho nhau và mạng hội tụ, tất cả IP ping thấy nhau .
FRSW:
sh run
Building configuration...
!
hostname FRSW
!
no aaa new-model
ip subnet-zero
!
frame-relay switching
!
ip cef
!
interface Serial1/1
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay intf-type dce
frame-relay route 102 interface Serial1/2 201
frame-relay route 103 interface Serial1/3 301
!
interface Serial1/2
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay intf-type dce
frame-relay route 201 interface Serial1/1 102
frame-relay route 203 interface Serial1/3 302
!
interface Serial1/3
no ip address
encapsulation frame-relay
frame-relay intf-type dce
frame-relay route 301 interface Serial1/1 103
frame-relay route 302 interface Serial1/2 203
!
ip classless
!
end
FRSW#
Building configuration...
!
hostname FRSW
!
no aaa new-model
ip subnet-zero
!
frame-relay switching
!
ip cef
!
interface Serial1/1
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay intf-type dce
frame-relay route 102 interface Serial1/2 201
frame-relay route 103 interface Serial1/3 301
!
interface Serial1/2
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay intf-type dce
frame-relay route 201 interface Serial1/1 102
frame-relay route 203 interface Serial1/3 302
!
interface Serial1/3
no ip address
encapsulation frame-relay
frame-relay intf-type dce
frame-relay route 301 interface Serial1/1 103
frame-relay route 302 interface Serial1/2 203
!
ip classless
!
end
FRSW#
sh run
Building configuration...
!
hostname R1
!
ip subnet-zero
!
!
!
ip cef
!
interface Loopback1
ip address 1.1.1.1 255.255.255.0
!
!
interface Serial1/1
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial1/1.12 point-to-point
ip address 192.168.12.1 255.255.255.0
frame-relay interface-dlci 102
!
interface Serial1/1.13 point-to-point
ip address 192.168.13.1 255.255.255.0
frame-relay interface-dlci 103
!
router rip
network 1.0.0.0
network 192.168.12.0
network 192.168.13.0
!
ip classless
no ip http server
no ip http secure-server
!
end
R1#
Building configuration...
!
hostname R1
!
ip subnet-zero
!
!
!
ip cef
!
interface Loopback1
ip address 1.1.1.1 255.255.255.0
!
!
interface Serial1/1
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial1/1.12 point-to-point
ip address 192.168.12.1 255.255.255.0
frame-relay interface-dlci 102
!
interface Serial1/1.13 point-to-point
ip address 192.168.13.1 255.255.255.0
frame-relay interface-dlci 103
!
router rip
network 1.0.0.0
network 192.168.12.0
network 192.168.13.0
!
ip classless
no ip http server
no ip http secure-server
!
end
R1#
sh run
Building configuration...
!
hostname R2
!
ip subnet-zero
!
ip cef
!
!
interface Loopback1
ip address 2.2.2.2 255.255.255.0
!
interface Serial1/2
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial1/2.21 point-to-point
ip address 192.168.12.2 255.255.255.0
frame-relay interface-dlci 201
!
interface Serial1/2.23 point-to-point
ip address 192.168.23.2 255.255.255.0
frame-relay interface-dlci 203
!
router rip
network 2.0.0.0
network 192.168.12.0
network 192.168.23.0
!
ip classless
!
end
R2#
Building configuration...
!
hostname R2
!
ip subnet-zero
!
ip cef
!
!
interface Loopback1
ip address 2.2.2.2 255.255.255.0
!
interface Serial1/2
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial1/2.21 point-to-point
ip address 192.168.12.2 255.255.255.0
frame-relay interface-dlci 201
!
interface Serial1/2.23 point-to-point
ip address 192.168.23.2 255.255.255.0
frame-relay interface-dlci 203
!
router rip
network 2.0.0.0
network 192.168.12.0
network 192.168.23.0
!
ip classless
!
end
R2#
sh run
Building configuration...
!
hostname R3
!
ip subnet-zero
!
no ip cef
!
!
interface Loopback12
ip address 3.3.3.32 255.255.255.0
!
interface Serial1/3
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial1/3.31 point-to-point
ip address 192.168.13.3 255.255.255.0
frame-relay interface-dlci 301
!
interface Serial1/3.32 point-to-point
ip address 192.168.23.3 255.255.255.0
frame-relay interface-dlci 302
!
!
router rip
network 3.0.0.0
network 192.168.13.0
network 192.168.23.0
!
ip classless
!
end
R3#
Building configuration...
!
hostname R3
!
ip subnet-zero
!
no ip cef
!
!
interface Loopback12
ip address 3.3.3.32 255.255.255.0
!
interface Serial1/3
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial1/3.31 point-to-point
ip address 192.168.13.3 255.255.255.0
frame-relay interface-dlci 301
!
interface Serial1/3.32 point-to-point
ip address 192.168.23.3 255.255.255.0
frame-relay interface-dlci 302
!
!
router rip
network 3.0.0.0
network 192.168.13.0
network 192.168.23.0
!
ip classless
!
end
R3#
Comment