Lê Trường Sơn
RSVP – Cơ chế báo hiệu dành tài nguyên trong mô hình triển khai QoS theo kiểu IntServ
Sơ đồ:
Tóm tắt và yêu cầu
RSVP là giao thức báo hiệu giữa các thiết bị dọc đường đi được thực hiện từ ứng dụng gửi lưu lượng thiết bị gửi đến thiết bị nhận tương ứng, việc báo hiệu yêu cầu các thiết bị dọc đường đi dành riêng một số tham số về QoS để phục vụ cho việc gửi nhận dữ liệu đầu cuối- đầu cuối. Trong bài lab này, giao thức RSVP sẽ kết hợp chạy chung với cơ chế hàng đợi WFQ nhằm dành tài nguyên cho ứng dụng UDP.
Cổng Fa0/1 trên thiết bị R2 được lấy địa chỉ tự động bằng DHCP ( dùng câu lệnh ip address dhcp)
Thực hiện
Cấu hình ban đầu:
Cấu hình R1:
R1#sh run
Building configuration...
Current configuration : 1149 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
no ip dhcp use vrf connected
!
ip dhcp pool 10
network 10.10.20.0 255.255.255.0
default-router 10.10.20.1
dns-server 203.162.4.1 203.162.4.190 203.162.4.191
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
!
voice-card 0
no dspfarm
!
archive
log config
hidekeys
!
interface FastEthernet0/0
ip address 10.10.10.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.10.20.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1/0
ip address 192.1.1.1 255.255.255.0
clock rate 2000000
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.1.1.2
!
!
ip http server
no ip http secure-server
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
privilege level 15
no login
!
scheduler allocate 20000 1000
!
end
R1#
Cấu hình R2
R2#sh run
Building configuration...
Current configuration : 1178 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 15
!
!
ip cef
!
!
!
multilink bundle-name authenticated
!
!
voice-card 0
no dspfarm
!
!
!
interface FastEthernet0/0
ip address 20.20.20.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Serial0/1/0
ip address 192.1.1.2 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Serial0/3/0
no ip address
shutdown
clock rate 2000000
!
ip route 10.10.0.0 255.255.0.0 192.1.1.1
!
!
ip http server
no ip http secure-server
ip nat inside source list 1 interface FastEthernet0/1 overload
!
access-list 1 permit 10.10.0.0 0.0.255.255
!
!
control-plane
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
line vty 0 4
privilege level 15
logging synchronous
no login
!
scheduler allocate 20000 1000
!
end
Cấu hình trên thiết bị C262(thiết bị router 2800):
c262#sh run
Building configuration...
Current configuration : 1373 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname c262
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 15
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
!
no ftp-server write-enable
!
!
no crypto isakmp ccm
!
!
!
!
interface FastEthernet0/0
ip address 20.20.20.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
shutdown
clockrate 2000000
!
interface Serial0/2/0
no ip address
shutdown
clockrate 2000000
!
interface Serial0/3/0
no ip address
shutdown
clockrate 2000000
!
ip classless
ip route 0.0.0.0 0.0.0.0 20.20.20.1
!
!
no ip http server
no ip http secure-server
!
!
control-plane
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
privilege level 15
no login
!
scheduler allocate 20000 1000
!
end
Cấu hình trên thiết bị R1
c261#sh run
Building configuration...
Current configuration : 1060 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname c261
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 15
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
no ftp-server write-enable
!
!
no crypto isakmp ccm
!
!
!
!
interface FastEthernet0/0
ip address 10.10.10.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
shutdown
clockrate 2000000
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.10.1
!
!
no ip http server
no ip http secure-server
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
privilege level 15
no login
!
scheduler allocate 20000 1000
!
end
Các bước thực hiện
Bước 1: chỉnh lại tốc độ truyền là 128 kbps, chỉnh giá trị bandwidth tương ứng và bật cơ chế hàng đợi là WFQ (nếu chưa được bật lên trên cổng)
Cấu hình tương ứng trên R1 và R2
R1#Conf t
R1(config)#interface Serial0/1/0
R1(config-if)#bandwidth 128
R1(config-if)#ip address 192.1.1.1 255.255.255.0
R1(config-if)#fair-queue
R1(config-if)#clock rate 128000
R2#Conf t
R2(config)#interface Serial0/1/0
R2(config-if)#bandwidth 128
R2(config-if)#ip address 192.1.1.1 255.255.255.0
R2(config-if)#fair-queue
R2(config-if)#clock rate 128000
Bước 2: Bật giao thức RSVP trên các thiết bị R1 và R2
Thực hiện câu lệnh bật giao thức RSVP lên các cổng của 2 thiết bị R1 và R2
R1#config terminal
R1(config)#interface Serial0/1/0
R1(config-if)#ip rsvp bandwidth
R1(config-if)#int f0/0
R1(config-if)#ip rsvp bandwidth
R2#config terminal
R2(config)#interface Serial0/1/0
R2(config-if)#ip rsvp bandwidth
R2(config-if)#int f0/0
R2(config-if)#ip rsvp bandwidth
Câu lệnh ip rsvp bandwidth có 2 tham số [reservable bandwidth] [largest reservable flow] trong đó tham số đầu tiên chỉ ra cho phép tối đa bao nhiêu băng thông trên cổng này được sử dụng cho RSVP và tham số thứ 2 chỉ ra băng thông lớn nhất dành cho 1 dòng (flow). Trong trường hợp không sử dụng 2 tham số này thì băng thông lớn nhất cho phép sử dụng bởi RSVP là 75% băng thông đặc tả bằng câu lệnh bandwidth và tham số thứ 2 cho phép 1 flow lấy tối đa băng thông này.
Bước 3: dùng một số lệnh kiểm tra cấu hình ban đầu
Ngay khi cấu hình thì trên cổng giá trị mặc định của cơ chế hàng đợi thay đổi, có thể kiểm tra như sau:
R1#sh run int s0/1/0
Building configuration...
Current configuration : 137 bytes
!
interface Serial0/0
bandwidth 128
ip address 192.1.1.1 255.255.255.0
fair-queue 64 256 3
clock rate 128000
ip rsvp bandwidth
end
R2#sh run int s0/0
Building configuration...
Current configuration : 137 bytes
!
interface Serial0/0
bandwidth 128
ip address 192.1.1.2 255.255.255.0
fair-queue 64 256 3
clock rate 128000
ip rsvp bandwidth
end
R1#sh queueing interface s0/1/0
Interface Serial0/0 queueing strategy: fair
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 96 kilobits/sec
R2#sh queueing interface s0/1/0
Interface Serial0/0 queueing strategy: fair
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 96 kilobits/sec
R2#sh ip rsvp interface
interface allocated i/f max flow max sub max
Se0/0 0 96K 96K 0
Fa0/0 0 7500K 7500K 0
R2#
R1#sh ip rsvp interface
interface allocated i/f max flow max sub max
Se0/0 0 96K 96K 0
Fa0/0 0 7500K 7500K 0
R1#
R1#sh ip rsvp install
RSVP: Serial0/1/0 has no installed reservations
RSVP: FastEthernet0/0 has no installed reservations
R1#
R2#sh ip rsvp install
RSVP: Serial0/1/0 has no installed reservations
RSVP: FastEthernet0/0 has no installed reservations
R2#
Do chưa có dữ liệu phù hợp gửi qua báo hiệu dành bandwidth nên các thông số hầu như chưa có thay đổi
Bước 4: cấu hình thiết bị c262 và c261 đóng vai trò thiết bị gửi dữ liệu báo hiệu bằng RSVP.
c262(config)#int f0/0
c262(config-if)#ip rsvp bandwidth
c262(config)#ip rsvp sender-host 10.10.10.2 20.20.20.2 udp 0 0 8 1
Yêu cầu thiết bị c262 gửi thông tin báo hiệu RSVP cho luồng dữ liệu UDP với thông tin dành riêng là 8 kbps và lượng dữ liệu có thể được gửi tối đa liên tục là 1 Kbyte.
Làm tương tự trên R1 nhưng báo hiệu dành sẽ chạy ngược theo hướng về người gửi
c261(config)#int f0/0
c261(config-if)#ip rsvp bandwidth
c261(config-if)#exit
c261(config)#ip rsvp reservation-host 10.10.10.2 20.20.20.2 UDP 0 0 FF RATE 8 1
Yêu cầu thiết bị R1 báo hiệu ngược lại việc dành riêng tài nguyên là đảm bảo tốc độ (rate) là 8 Kbps với giá trị thông tin có thể gửi liên tục là 1 Kbyte, chỉ dành riêng các thông số này cho từng flow dữ liệu riêng lẻ (FF).
Kiểm tra trên các thiết bị R1 và R2 về việc nhận dạng các thông tin đăng ký này:
R1#sh ip rsvp sender
To From Pro Dport Sport Prev Hop I/F BPS
10.10.10.2 20.20.20.2 UDP 0 0 192.1.1.2 Se0/1/0 8K
R1#
R2#sh ip rsvp sender
To From Pro Dport Sport Prev Hop I/F BPS
10.10.10.2 20.20.20.2 UDP 0 0 20.20.20.2 Fa0/0 8K
R2#
R1#sh ip rsvp reservation
To From Pro Dport Sport Next Hop I/F Fi Serv BPS
10.10.10.2 20.20.20.2 UDP 0 0 10.10.10.2 Fa0/0 FF RATE 8K
R1#
R2#sh ip rsvp reservation
To From Pro DPort Sport Next Hop I/F Fi Serv BPS
10.10.10.2 20.20.20.2 UDP 0 0 192.1.1.1 Se0/0 FF RATE 8K
R2#
Có thể quan sát thấy được thông tin đăng ký giả lập từ c262 và c261 đã được ghi nhận tại R1 và R2
R1#sh queueing int s0/1/0
Interface Serial0/0 queueing strategy: fair
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1/256 (active/max active/max total)
Reserved Conversations 1/1 (allocated/max allocated)
Available Bandwidth 88 kilobits/sec
R2#sh queueing int s0/1/0
Interface Serial0/0 queueing strategy: fair
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1/256 (active/max active/max total)
Reserved Conversations 1/1 (allocated/max allocated)
Available Bandwidth 88 kilobits/sec
Hàng đợi dành riêng đã được bật lên để dành băng thông cho loại dữ liệu tương ứng (trong trường hợp này là UDP)
R1#sh ip rsvp installed
RSVP: Serial0/1/0 has no installed reservations
RSVP: FastEthernet0/0
BPS To From Protoc Dport Sport
8K 10.10.10.2 20.20.20.2 UDP 0 0
R1#
R2#sh ip rsvp installed
RSVP: Serial0/1/0
BPS To From Protoc Dport Sport Weight Conversation
8K 10.10.10.2 20.20.20.2 UDP 0 0 6 265
RSVP: FastEthernet0/0 has no installed reservations
R2#
Hướng dữ liệu chạy từ hướng người gửi (sender và người nhận reserve) đã được sẵn sàng.
Bước 5: cấu hình cơ chế SLA gửi dữ liệu UDP từ c262 đến c261 đồng thời tiến hành download file từ Internet và xem thông tin
Cấu hình tính năng sla responder trên c261 để đáp ứng thông tin nhận được.
c261(config)#ip sla monitor responder
Cấu hình tính năng SLA gửi lưu lượng UDP từ c262 đến c261
c262(config)#ip sla monitor 1
c262(config-sla-monitor)#type udpEcho dest-ipaddr 10.10.10.2 dest-port 16000 source-ipaddr 20.20.20.2 source-port 16000
c262(config-sla-monitor-udp)#request-data-size 1000
c262(config-sla-monitor-udp)#timeout 1
c262(config-sla-monitor-udp)#frequency 1
c262(config-sla-monitor-udp)#exit
c262(config)#ip sla monitor schedule 1 start-time now life forever
Xem thông tin hàng đợi tạo ra trong quá trình gửi nhận dữ liệu
R2#sq
Interface Serial0/1/0 queueing strategy: fair
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 2874
Queueing strategy: weighted fair
Output queue: 57/1000/64/2874 (size/max total/threshold/drops)
Conversations 37/45/256 (active/max active/max total)
Reserved Conversations 1/1 (allocated/max allocated)
Available Bandwidth 88 kilobits/sec
(depth/weight/total drops/no-buffer drops/interleaves) 1/6/0/0/0
Conversation 265, linktype: ip, length: 1032
source: 20.20.20.2, destination: 10.10.10.2, id: 0x0000, ttl: 254,
TOS: 0 prot: 17, source port 16000, destination port 16000
(depth/weight/total drops/no-buffer drops/interleaves) 1/32384/6/0/0
Conversation 164, linktype: ip, length: 244
source: 70.86.181.162, destination: 10.10.20.2, id: 0xF794, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1324
(depth/weight/total drops/no-buffer drops/interleaves) 1/32384/5/0/0
Conversation 166, linktype: ip, length: 244
source: 70.86.181.162, destination: 10.10.20.2, id: 0x855E, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1326
(depth/weight/total drops/no-buffer drops/interleaves) 1/32384/6/0/0
Conversation 154, linktype: ip, length: 244
source: 70.86.181.162, destination: 10.10.20.2, id: 0x8DA2, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1314
(depth/weight/total drops/no-buffer drops/interleaves) 2/32384/7/0/0
Conversation 147, linktype: ip, length: 244
source: 70.86.181.162, destination: 10.10.20.2, id: 0xBE35, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1307
(depth/weight/total drops/no-buffer drops/interleaves) 2/32384/4/0/0
Conversation 160, linktype: ip, length: 244
source: 70.86.181.162, destination: 10.10.20.2, id: 0x2860, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1320
(depth/weight/total drops/no-buffer drops/interleaves) 1/32384/4/0/0
Conversation 175, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0x7EF0, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1335
(depth/weight/total drops/no-buffer drops/interleaves) 2/32384/6/0/0
Conversation 162, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0x992D, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1322
(depth/weight/total drops/no-buffer drops/interleaves) 2/32384/31/0/0
Conversation 136, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0xE710, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1296
(depth/weight/total drops/no-buffer drops/interleaves) 2/32384/33/0/0
Conversation 137, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0x6E0C, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1297
(depth/weight/total drops/no-buffer drops/interleaves) 2/32384/6/0/0
Conversation 139, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0xD5A1, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1299
(depth/weight/total drops/no-buffer drops/interleaves) 2/32384/6/0/0
Conversation 150, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0x117E, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1310
(depth/weight/total drops/no-buffer drops/interleaves) 1/32384/5/0/0
Conversation 173, linktype: ip, length: 244
source: 70.86.181.162, destination: 10.10.20.2, id: 0xD264, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1333
(depth/weight/total drops/no-buffer drops/interleaves) 1/32384/3/0/0
Conversation 179, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0x0F93, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1339
(depth/weight/total drops/no-buffer drops/interleaves) 1/32384/9/0/0
Conversation 146, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0xC373, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1306
(depth/weight/total drops/no-buffer drops/interleaves) 1/32384/6/0/0
Conversation 165, linktype: ip, length: 244
source: 70.86.181.162, destination: 10.10.20.2, id: 0x01B7, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1325
(depth/weight/total drops/no-buffer drops/interleaves) 2/32384/3/0/0
Conversation 178, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0x2A75, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1338
(depth/weight/total drops/no-buffer drops/interleaves) 2/32384/5/0/0
Conversation 169, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0xF7C4, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1329
(depth/weight/total drops/no-buffer drops/interleaves) 2/32384/4/0/0
Conversation 180, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0xCA99, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1340
(depth/weight/total drops/no-buffer drops/interleaves) 1/32384/5/0/0
Conversation 151, linktype: ip, length: 244
source: 70.86.181.162, destination: 10.10.20.2, id: 0x8018, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1311
(depth/weight/total drops/no-buffer drops/interleaves) 1/32384/6/0/0
Conversation 167, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0xD09B, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1327
(depth/weight/total drops/no-buffer drops/interleaves) 1/32384/3/0/0
Conversation 170, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0xE8C0, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1330
(depth/weight/total drops/no-buffer drops/interleaves) 1/32384/4/0/0
Conversation 163, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0x0406, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1323
(depth/weight/total drops/no-buffer drops/interleaves) 2/32384/9/0/0
Conversation 148, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0x883A, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1308
(depth/weight/total drops/no-buffer drops/interleaves) 3/32384/24/0/0
Conversation 138, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0x1ECB, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1298
(depth/weight/total drops/no-buffer drops/interleaves) 2/32384/5/0/0
Conversation 159, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0xE2F7, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1319
(depth/weight/total drops/no-buffer drops/interleaves) 1/32384/2/0/0
Conversation 177, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0xB3FA, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1337
(depth/weight/total drops/no-buffer drops/interleaves) 2/32384/15/0/0
Conversation 143, linktype: ip, length: 244
source: 70.86.181.162, destination: 10.10.20.2, id: 0x9515, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1303
(depth/weight/total drops/no-buffer drops/interleaves) 1/32384/10/0/0
Conversation 157, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0xE9C2, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1317
(depth/weight/total drops/no-buffer drops/interleaves) 1/32384/4/0/0
Conversation 181, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0xEA47, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1341
Kiểm tra thêm thông tin
R2#sh ip rsvp install detail
RSVP: Serial0/1/0 has the following installed reservations
RSVP Reservation. Destination is 10.10.10.2. Source is 20.20.20.2,
Protocol is UDP, Destination port is 16000, Source port is 16000
Traffic Control ID handle: 04000404
Created: 08:27:49 UTC Fri Sep 18 2009
Admitted flowspec:
Reserved bandwidth: 8K bits/sec, Maximum burst: 1K bytes, Peak rate: 8K bits/sec
Min Policed Unit: 0 bytes, Max Pkt Size: 0 bytes
Resource provider for this flow:
WFQ on hw idb Se0/1/0: RESERVED queue 265. Weight: 6, BW 8 kbps
Conversation supports 1 reservations [0x4000403]
Data given reserved service: 98 packets (100744 bytes)
Data given best-effort service: 1 packets (1028 bytes)
Reserved traffic classified for 342 seconds
Long-term average bitrate (bits/sec): 2352 reserved, 24 best-effort
Policy: INSTALL. Policy source(s): Default
Như vậy dữ liệu của luồng UDP này đã được dành riêng, có thể thấy tham số total drops trong lệnh show trước ở luồng lưu lượng này bằng 0 trong khi các loại lưu lượng khác có xu hướng tăng lên.
Cấu hình cuối cùng của hệ thống
R2#sh run
Building configuration...
Current configuration : 1438 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 15
!
!
ip cef
!
!
no ip domain lookup
ip host r1 192.1.1.1
ip host c262 20.20.20.2
ip host c261 10.10.10.2
!
multilink bundle-name authenticated
!
!
voice-card 0
no dspfarm
!
!
interface FastEthernet0/0
ip address 20.20.20.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
ip rsvp bandwidth
!
interface FastEthernet0/1
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Serial0/1/0
bandwidth 128
ip address 192.1.1.2 255.255.255.0
ip nat inside
ip virtual-reassembly
fair-queue 64 256 6
ip rsvp bandwidth
!
interface Serial0/3/0
no ip address
shutdown
clock rate 2000000
!
ip route 10.10.0.0 255.255.0.0 192.1.1.1
!
!
ip http server
no ip http secure-server
ip nat inside source list 1 interface FastEthernet0/1 overload
!
access-list 1 permit 10.10.0.0 0.0.255.255
access-list 100 permit ip host 20.20.20.2 host 10.10.10.2
!
!
alias exec sq show queueing int s0/1/0
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
line vty 0 4
privilege level 15
logging synchronous
no login
!
scheduler allocate 20000 1000
!
end
R1#sh run
Building configuration...
Current configuration : 1353 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
dot11 syslog
!
!
ip cef
no ip dhcp use vrf connected
!
ip dhcp pool 10
network 10.10.20.0 255.255.255.0
default-router 10.10.20.1
dns-server 203.162.4.1 203.162.4.190 203.162.4.191
!
!
no ip domain lookup
ip host r2 192.1.1.2
ip host c261 10.10.10.1
ip host c262 20.20.20.1
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
!
voice-card 0
no dspfarm
!
!
archive
log config
hidekeys
!
!
interface FastEthernet0/0
ip address 10.10.10.1 255.255.255.0
duplex auto
speed auto
ip rsvp bandwidth
!
interface FastEthernet0/1
ip address 10.10.20.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1/0
bandwidth 128
ip address 192.1.1.1 255.255.255.0
fair-queue 64 256 6
clock rate 128000
ip rsvp bandwidth
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.1.1.2
!
!
ip http server
no ip http secure-server
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
login
line aux 0
line vty 0 4
privilege level 15
password 7 00071A150754
no login
!
scheduler allocate 20000 1000
!
end
c262#sh run
Building configuration...
Current configuration : 1373 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname c262
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 15
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
ip sla monitor 1
type udpEcho dest-ipaddr 10.10.10.2 dest-port 16000 source-ipaddr 20.20.20.2 source-port 16000
request-data-size 1000
timeout 0
frequency 1
ip sla monitor schedule 1 life forever start-time now
!
no ftp-server write-enable
!
no crypto isakmp ccm
!
!
!
!
interface FastEthernet0/0
ip address 20.20.20.2 255.255.255.0
duplex auto
speed auto
ip rsvp bandwidth
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
shutdown
clockrate 2000000
!
interface Serial0/2/0
no ip address
shutdown
clockrate 2000000
!
interface Serial0/3/0
no ip address
shutdown
clockrate 2000000
!
ip classless
ip route 0.0.0.0 0.0.0.0 20.20.20.1
!
!
no ip http server
no ip http secure-server
ip rsvp sender-host 10.10.10.2 20.20.20.2 UDP 16000 16000 8 1
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
privilege level 15
no login
!
scheduler allocate 20000 1000
!
end
c261#sh run
Building configuration...
Current configuration : 1060 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname c261
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 15
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
ip sla monitor responder
!
no ftp-server write-enable
!
no crypto isakmp ccm
!
interface FastEthernet0/0
ip address 10.10.10.2 255.255.255.0
duplex auto
speed auto
ip rsvp bandwidth
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
shutdown
clockrate 2000000
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.10.1
!
!
no ip http server
no ip http secure-server
ip rsvp reservation-host 10.10.10.2 20.20.20.2 UDP 16000 16000 FF RATE 8 1
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
privilege level 15
no login
!
scheduler allocate 20000 1000
!
end
RSVP – Cơ chế báo hiệu dành tài nguyên trong mô hình triển khai QoS theo kiểu IntServ
Sơ đồ:
Tóm tắt và yêu cầu
RSVP là giao thức báo hiệu giữa các thiết bị dọc đường đi được thực hiện từ ứng dụng gửi lưu lượng thiết bị gửi đến thiết bị nhận tương ứng, việc báo hiệu yêu cầu các thiết bị dọc đường đi dành riêng một số tham số về QoS để phục vụ cho việc gửi nhận dữ liệu đầu cuối- đầu cuối. Trong bài lab này, giao thức RSVP sẽ kết hợp chạy chung với cơ chế hàng đợi WFQ nhằm dành tài nguyên cho ứng dụng UDP.
Cổng Fa0/1 trên thiết bị R2 được lấy địa chỉ tự động bằng DHCP ( dùng câu lệnh ip address dhcp)
Thực hiện
Cấu hình ban đầu:
Cấu hình R1:
R1#sh run
Building configuration...
Current configuration : 1149 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
no ip dhcp use vrf connected
!
ip dhcp pool 10
network 10.10.20.0 255.255.255.0
default-router 10.10.20.1
dns-server 203.162.4.1 203.162.4.190 203.162.4.191
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
!
voice-card 0
no dspfarm
!
archive
log config
hidekeys
!
interface FastEthernet0/0
ip address 10.10.10.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.10.20.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1/0
ip address 192.1.1.1 255.255.255.0
clock rate 2000000
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.1.1.2
!
!
ip http server
no ip http secure-server
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
privilege level 15
no login
!
scheduler allocate 20000 1000
!
end
R1#
Cấu hình R2
R2#sh run
Building configuration...
Current configuration : 1178 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 15
!
!
ip cef
!
!
!
multilink bundle-name authenticated
!
!
voice-card 0
no dspfarm
!
!
!
interface FastEthernet0/0
ip address 20.20.20.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Serial0/1/0
ip address 192.1.1.2 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Serial0/3/0
no ip address
shutdown
clock rate 2000000
!
ip route 10.10.0.0 255.255.0.0 192.1.1.1
!
!
ip http server
no ip http secure-server
ip nat inside source list 1 interface FastEthernet0/1 overload
!
access-list 1 permit 10.10.0.0 0.0.255.255
!
!
control-plane
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
line vty 0 4
privilege level 15
logging synchronous
no login
!
scheduler allocate 20000 1000
!
end
Cấu hình trên thiết bị C262(thiết bị router 2800):
c262#sh run
Building configuration...
Current configuration : 1373 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname c262
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 15
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
!
no ftp-server write-enable
!
!
no crypto isakmp ccm
!
!
!
!
interface FastEthernet0/0
ip address 20.20.20.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
shutdown
clockrate 2000000
!
interface Serial0/2/0
no ip address
shutdown
clockrate 2000000
!
interface Serial0/3/0
no ip address
shutdown
clockrate 2000000
!
ip classless
ip route 0.0.0.0 0.0.0.0 20.20.20.1
!
!
no ip http server
no ip http secure-server
!
!
control-plane
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
privilege level 15
no login
!
scheduler allocate 20000 1000
!
end
Cấu hình trên thiết bị R1
c261#sh run
Building configuration...
Current configuration : 1060 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname c261
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 15
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
no ftp-server write-enable
!
!
no crypto isakmp ccm
!
!
!
!
interface FastEthernet0/0
ip address 10.10.10.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
shutdown
clockrate 2000000
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.10.1
!
!
no ip http server
no ip http secure-server
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
privilege level 15
no login
!
scheduler allocate 20000 1000
!
end
Các bước thực hiện
Bước 1: chỉnh lại tốc độ truyền là 128 kbps, chỉnh giá trị bandwidth tương ứng và bật cơ chế hàng đợi là WFQ (nếu chưa được bật lên trên cổng)
Cấu hình tương ứng trên R1 và R2
R1#Conf t
R1(config)#interface Serial0/1/0
R1(config-if)#bandwidth 128
R1(config-if)#ip address 192.1.1.1 255.255.255.0
R1(config-if)#fair-queue
R1(config-if)#clock rate 128000
R2#Conf t
R2(config)#interface Serial0/1/0
R2(config-if)#bandwidth 128
R2(config-if)#ip address 192.1.1.1 255.255.255.0
R2(config-if)#fair-queue
R2(config-if)#clock rate 128000
Bước 2: Bật giao thức RSVP trên các thiết bị R1 và R2
Thực hiện câu lệnh bật giao thức RSVP lên các cổng của 2 thiết bị R1 và R2
R1#config terminal
R1(config)#interface Serial0/1/0
R1(config-if)#ip rsvp bandwidth
R1(config-if)#int f0/0
R1(config-if)#ip rsvp bandwidth
R2#config terminal
R2(config)#interface Serial0/1/0
R2(config-if)#ip rsvp bandwidth
R2(config-if)#int f0/0
R2(config-if)#ip rsvp bandwidth
Câu lệnh ip rsvp bandwidth có 2 tham số [reservable bandwidth] [largest reservable flow] trong đó tham số đầu tiên chỉ ra cho phép tối đa bao nhiêu băng thông trên cổng này được sử dụng cho RSVP và tham số thứ 2 chỉ ra băng thông lớn nhất dành cho 1 dòng (flow). Trong trường hợp không sử dụng 2 tham số này thì băng thông lớn nhất cho phép sử dụng bởi RSVP là 75% băng thông đặc tả bằng câu lệnh bandwidth và tham số thứ 2 cho phép 1 flow lấy tối đa băng thông này.
Bước 3: dùng một số lệnh kiểm tra cấu hình ban đầu
Ngay khi cấu hình thì trên cổng giá trị mặc định của cơ chế hàng đợi thay đổi, có thể kiểm tra như sau:
R1#sh run int s0/1/0
Building configuration...
Current configuration : 137 bytes
!
interface Serial0/0
bandwidth 128
ip address 192.1.1.1 255.255.255.0
fair-queue 64 256 3
clock rate 128000
ip rsvp bandwidth
end
R2#sh run int s0/0
Building configuration...
Current configuration : 137 bytes
!
interface Serial0/0
bandwidth 128
ip address 192.1.1.2 255.255.255.0
fair-queue 64 256 3
clock rate 128000
ip rsvp bandwidth
end
R1#sh queueing interface s0/1/0
Interface Serial0/0 queueing strategy: fair
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 96 kilobits/sec
R2#sh queueing interface s0/1/0
Interface Serial0/0 queueing strategy: fair
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 96 kilobits/sec
R2#sh ip rsvp interface
interface allocated i/f max flow max sub max
Se0/0 0 96K 96K 0
Fa0/0 0 7500K 7500K 0
R2#
R1#sh ip rsvp interface
interface allocated i/f max flow max sub max
Se0/0 0 96K 96K 0
Fa0/0 0 7500K 7500K 0
R1#
R1#sh ip rsvp install
RSVP: Serial0/1/0 has no installed reservations
RSVP: FastEthernet0/0 has no installed reservations
R1#
R2#sh ip rsvp install
RSVP: Serial0/1/0 has no installed reservations
RSVP: FastEthernet0/0 has no installed reservations
R2#
Do chưa có dữ liệu phù hợp gửi qua báo hiệu dành bandwidth nên các thông số hầu như chưa có thay đổi
Bước 4: cấu hình thiết bị c262 và c261 đóng vai trò thiết bị gửi dữ liệu báo hiệu bằng RSVP.
c262(config)#int f0/0
c262(config-if)#ip rsvp bandwidth
c262(config)#ip rsvp sender-host 10.10.10.2 20.20.20.2 udp 0 0 8 1
Yêu cầu thiết bị c262 gửi thông tin báo hiệu RSVP cho luồng dữ liệu UDP với thông tin dành riêng là 8 kbps và lượng dữ liệu có thể được gửi tối đa liên tục là 1 Kbyte.
Làm tương tự trên R1 nhưng báo hiệu dành sẽ chạy ngược theo hướng về người gửi
c261(config)#int f0/0
c261(config-if)#ip rsvp bandwidth
c261(config-if)#exit
c261(config)#ip rsvp reservation-host 10.10.10.2 20.20.20.2 UDP 0 0 FF RATE 8 1
Yêu cầu thiết bị R1 báo hiệu ngược lại việc dành riêng tài nguyên là đảm bảo tốc độ (rate) là 8 Kbps với giá trị thông tin có thể gửi liên tục là 1 Kbyte, chỉ dành riêng các thông số này cho từng flow dữ liệu riêng lẻ (FF).
Kiểm tra trên các thiết bị R1 và R2 về việc nhận dạng các thông tin đăng ký này:
R1#sh ip rsvp sender
To From Pro Dport Sport Prev Hop I/F BPS
10.10.10.2 20.20.20.2 UDP 0 0 192.1.1.2 Se0/1/0 8K
R1#
R2#sh ip rsvp sender
To From Pro Dport Sport Prev Hop I/F BPS
10.10.10.2 20.20.20.2 UDP 0 0 20.20.20.2 Fa0/0 8K
R2#
R1#sh ip rsvp reservation
To From Pro Dport Sport Next Hop I/F Fi Serv BPS
10.10.10.2 20.20.20.2 UDP 0 0 10.10.10.2 Fa0/0 FF RATE 8K
R1#
R2#sh ip rsvp reservation
To From Pro DPort Sport Next Hop I/F Fi Serv BPS
10.10.10.2 20.20.20.2 UDP 0 0 192.1.1.1 Se0/0 FF RATE 8K
R2#
Có thể quan sát thấy được thông tin đăng ký giả lập từ c262 và c261 đã được ghi nhận tại R1 và R2
R1#sh queueing int s0/1/0
Interface Serial0/0 queueing strategy: fair
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1/256 (active/max active/max total)
Reserved Conversations 1/1 (allocated/max allocated)
Available Bandwidth 88 kilobits/sec
R2#sh queueing int s0/1/0
Interface Serial0/0 queueing strategy: fair
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1/256 (active/max active/max total)
Reserved Conversations 1/1 (allocated/max allocated)
Available Bandwidth 88 kilobits/sec
Hàng đợi dành riêng đã được bật lên để dành băng thông cho loại dữ liệu tương ứng (trong trường hợp này là UDP)
R1#sh ip rsvp installed
RSVP: Serial0/1/0 has no installed reservations
RSVP: FastEthernet0/0
BPS To From Protoc Dport Sport
8K 10.10.10.2 20.20.20.2 UDP 0 0
R1#
R2#sh ip rsvp installed
RSVP: Serial0/1/0
BPS To From Protoc Dport Sport Weight Conversation
8K 10.10.10.2 20.20.20.2 UDP 0 0 6 265
RSVP: FastEthernet0/0 has no installed reservations
R2#
Hướng dữ liệu chạy từ hướng người gửi (sender và người nhận reserve) đã được sẵn sàng.
Bước 5: cấu hình cơ chế SLA gửi dữ liệu UDP từ c262 đến c261 đồng thời tiến hành download file từ Internet và xem thông tin
Cấu hình tính năng sla responder trên c261 để đáp ứng thông tin nhận được.
c261(config)#ip sla monitor responder
Cấu hình tính năng SLA gửi lưu lượng UDP từ c262 đến c261
c262(config)#ip sla monitor 1
c262(config-sla-monitor)#type udpEcho dest-ipaddr 10.10.10.2 dest-port 16000 source-ipaddr 20.20.20.2 source-port 16000
c262(config-sla-monitor-udp)#request-data-size 1000
c262(config-sla-monitor-udp)#timeout 1
c262(config-sla-monitor-udp)#frequency 1
c262(config-sla-monitor-udp)#exit
c262(config)#ip sla monitor schedule 1 start-time now life forever
Xem thông tin hàng đợi tạo ra trong quá trình gửi nhận dữ liệu
R2#sq
Interface Serial0/1/0 queueing strategy: fair
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 2874
Queueing strategy: weighted fair
Output queue: 57/1000/64/2874 (size/max total/threshold/drops)
Conversations 37/45/256 (active/max active/max total)
Reserved Conversations 1/1 (allocated/max allocated)
Available Bandwidth 88 kilobits/sec
(depth/weight/total drops/no-buffer drops/interleaves) 1/6/0/0/0
Conversation 265, linktype: ip, length: 1032
source: 20.20.20.2, destination: 10.10.10.2, id: 0x0000, ttl: 254,
TOS: 0 prot: 17, source port 16000, destination port 16000
(depth/weight/total drops/no-buffer drops/interleaves) 1/32384/6/0/0
Conversation 164, linktype: ip, length: 244
source: 70.86.181.162, destination: 10.10.20.2, id: 0xF794, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1324
(depth/weight/total drops/no-buffer drops/interleaves) 1/32384/5/0/0
Conversation 166, linktype: ip, length: 244
source: 70.86.181.162, destination: 10.10.20.2, id: 0x855E, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1326
(depth/weight/total drops/no-buffer drops/interleaves) 1/32384/6/0/0
Conversation 154, linktype: ip, length: 244
source: 70.86.181.162, destination: 10.10.20.2, id: 0x8DA2, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1314
(depth/weight/total drops/no-buffer drops/interleaves) 2/32384/7/0/0
Conversation 147, linktype: ip, length: 244
source: 70.86.181.162, destination: 10.10.20.2, id: 0xBE35, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1307
(depth/weight/total drops/no-buffer drops/interleaves) 2/32384/4/0/0
Conversation 160, linktype: ip, length: 244
source: 70.86.181.162, destination: 10.10.20.2, id: 0x2860, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1320
(depth/weight/total drops/no-buffer drops/interleaves) 1/32384/4/0/0
Conversation 175, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0x7EF0, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1335
(depth/weight/total drops/no-buffer drops/interleaves) 2/32384/6/0/0
Conversation 162, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0x992D, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1322
(depth/weight/total drops/no-buffer drops/interleaves) 2/32384/31/0/0
Conversation 136, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0xE710, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1296
(depth/weight/total drops/no-buffer drops/interleaves) 2/32384/33/0/0
Conversation 137, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0x6E0C, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1297
(depth/weight/total drops/no-buffer drops/interleaves) 2/32384/6/0/0
Conversation 139, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0xD5A1, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1299
(depth/weight/total drops/no-buffer drops/interleaves) 2/32384/6/0/0
Conversation 150, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0x117E, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1310
(depth/weight/total drops/no-buffer drops/interleaves) 1/32384/5/0/0
Conversation 173, linktype: ip, length: 244
source: 70.86.181.162, destination: 10.10.20.2, id: 0xD264, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1333
(depth/weight/total drops/no-buffer drops/interleaves) 1/32384/3/0/0
Conversation 179, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0x0F93, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1339
(depth/weight/total drops/no-buffer drops/interleaves) 1/32384/9/0/0
Conversation 146, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0xC373, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1306
(depth/weight/total drops/no-buffer drops/interleaves) 1/32384/6/0/0
Conversation 165, linktype: ip, length: 244
source: 70.86.181.162, destination: 10.10.20.2, id: 0x01B7, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1325
(depth/weight/total drops/no-buffer drops/interleaves) 2/32384/3/0/0
Conversation 178, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0x2A75, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1338
(depth/weight/total drops/no-buffer drops/interleaves) 2/32384/5/0/0
Conversation 169, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0xF7C4, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1329
(depth/weight/total drops/no-buffer drops/interleaves) 2/32384/4/0/0
Conversation 180, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0xCA99, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1340
(depth/weight/total drops/no-buffer drops/interleaves) 1/32384/5/0/0
Conversation 151, linktype: ip, length: 244
source: 70.86.181.162, destination: 10.10.20.2, id: 0x8018, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1311
(depth/weight/total drops/no-buffer drops/interleaves) 1/32384/6/0/0
Conversation 167, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0xD09B, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1327
(depth/weight/total drops/no-buffer drops/interleaves) 1/32384/3/0/0
Conversation 170, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0xE8C0, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1330
(depth/weight/total drops/no-buffer drops/interleaves) 1/32384/4/0/0
Conversation 163, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0x0406, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1323
(depth/weight/total drops/no-buffer drops/interleaves) 2/32384/9/0/0
Conversation 148, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0x883A, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1308
(depth/weight/total drops/no-buffer drops/interleaves) 3/32384/24/0/0
Conversation 138, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0x1ECB, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1298
(depth/weight/total drops/no-buffer drops/interleaves) 2/32384/5/0/0
Conversation 159, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0xE2F7, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1319
(depth/weight/total drops/no-buffer drops/interleaves) 1/32384/2/0/0
Conversation 177, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0xB3FA, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1337
(depth/weight/total drops/no-buffer drops/interleaves) 2/32384/15/0/0
Conversation 143, linktype: ip, length: 244
source: 70.86.181.162, destination: 10.10.20.2, id: 0x9515, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1303
(depth/weight/total drops/no-buffer drops/interleaves) 1/32384/10/0/0
Conversation 157, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0xE9C2, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1317
(depth/weight/total drops/no-buffer drops/interleaves) 1/32384/4/0/0
Conversation 181, linktype: ip, length: 1304
source: 70.86.181.162, destination: 10.10.20.2, id: 0xEA47, ttl: 57,
TOS: 0 prot: 6, source port 80, destination port 1341
Kiểm tra thêm thông tin
R2#sh ip rsvp install detail
RSVP: Serial0/1/0 has the following installed reservations
RSVP Reservation. Destination is 10.10.10.2. Source is 20.20.20.2,
Protocol is UDP, Destination port is 16000, Source port is 16000
Traffic Control ID handle: 04000404
Created: 08:27:49 UTC Fri Sep 18 2009
Admitted flowspec:
Reserved bandwidth: 8K bits/sec, Maximum burst: 1K bytes, Peak rate: 8K bits/sec
Min Policed Unit: 0 bytes, Max Pkt Size: 0 bytes
Resource provider for this flow:
WFQ on hw idb Se0/1/0: RESERVED queue 265. Weight: 6, BW 8 kbps
Conversation supports 1 reservations [0x4000403]
Data given reserved service: 98 packets (100744 bytes)
Data given best-effort service: 1 packets (1028 bytes)
Reserved traffic classified for 342 seconds
Long-term average bitrate (bits/sec): 2352 reserved, 24 best-effort
Policy: INSTALL. Policy source(s): Default
Như vậy dữ liệu của luồng UDP này đã được dành riêng, có thể thấy tham số total drops trong lệnh show trước ở luồng lưu lượng này bằng 0 trong khi các loại lưu lượng khác có xu hướng tăng lên.
Cấu hình cuối cùng của hệ thống
R2#sh run
Building configuration...
Current configuration : 1438 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 15
!
!
ip cef
!
!
no ip domain lookup
ip host r1 192.1.1.1
ip host c262 20.20.20.2
ip host c261 10.10.10.2
!
multilink bundle-name authenticated
!
!
voice-card 0
no dspfarm
!
!
interface FastEthernet0/0
ip address 20.20.20.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
ip rsvp bandwidth
!
interface FastEthernet0/1
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Serial0/1/0
bandwidth 128
ip address 192.1.1.2 255.255.255.0
ip nat inside
ip virtual-reassembly
fair-queue 64 256 6
ip rsvp bandwidth
!
interface Serial0/3/0
no ip address
shutdown
clock rate 2000000
!
ip route 10.10.0.0 255.255.0.0 192.1.1.1
!
!
ip http server
no ip http secure-server
ip nat inside source list 1 interface FastEthernet0/1 overload
!
access-list 1 permit 10.10.0.0 0.0.255.255
access-list 100 permit ip host 20.20.20.2 host 10.10.10.2
!
!
alias exec sq show queueing int s0/1/0
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
line vty 0 4
privilege level 15
logging synchronous
no login
!
scheduler allocate 20000 1000
!
end
R1#sh run
Building configuration...
Current configuration : 1353 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
dot11 syslog
!
!
ip cef
no ip dhcp use vrf connected
!
ip dhcp pool 10
network 10.10.20.0 255.255.255.0
default-router 10.10.20.1
dns-server 203.162.4.1 203.162.4.190 203.162.4.191
!
!
no ip domain lookup
ip host r2 192.1.1.2
ip host c261 10.10.10.1
ip host c262 20.20.20.1
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
!
voice-card 0
no dspfarm
!
!
archive
log config
hidekeys
!
!
interface FastEthernet0/0
ip address 10.10.10.1 255.255.255.0
duplex auto
speed auto
ip rsvp bandwidth
!
interface FastEthernet0/1
ip address 10.10.20.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1/0
bandwidth 128
ip address 192.1.1.1 255.255.255.0
fair-queue 64 256 6
clock rate 128000
ip rsvp bandwidth
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.1.1.2
!
!
ip http server
no ip http secure-server
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
login
line aux 0
line vty 0 4
privilege level 15
password 7 00071A150754
no login
!
scheduler allocate 20000 1000
!
end
c262#sh run
Building configuration...
Current configuration : 1373 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname c262
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 15
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
ip sla monitor 1
type udpEcho dest-ipaddr 10.10.10.2 dest-port 16000 source-ipaddr 20.20.20.2 source-port 16000
request-data-size 1000
timeout 0
frequency 1
ip sla monitor schedule 1 life forever start-time now
!
no ftp-server write-enable
!
no crypto isakmp ccm
!
!
!
!
interface FastEthernet0/0
ip address 20.20.20.2 255.255.255.0
duplex auto
speed auto
ip rsvp bandwidth
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
shutdown
clockrate 2000000
!
interface Serial0/2/0
no ip address
shutdown
clockrate 2000000
!
interface Serial0/3/0
no ip address
shutdown
clockrate 2000000
!
ip classless
ip route 0.0.0.0 0.0.0.0 20.20.20.1
!
!
no ip http server
no ip http secure-server
ip rsvp sender-host 10.10.10.2 20.20.20.2 UDP 16000 16000 8 1
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
privilege level 15
no login
!
scheduler allocate 20000 1000
!
end
c261#sh run
Building configuration...
Current configuration : 1060 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname c261
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 15
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
ip sla monitor responder
!
no ftp-server write-enable
!
no crypto isakmp ccm
!
interface FastEthernet0/0
ip address 10.10.10.2 255.255.255.0
duplex auto
speed auto
ip rsvp bandwidth
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
shutdown
clockrate 2000000
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.10.1
!
!
no ip http server
no ip http secure-server
ip rsvp reservation-host 10.10.10.2 20.20.20.2 UDP 16000 16000 FF RATE 8 1
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
privilege level 15
no login
!
scheduler allocate 20000 1000
!
end
Comment