Tính năng QoS Preclassify
a
Mô tả:
Những bài tập trước chúng ta phân loại lưu lượng trên hướng vào hoặc hướng ra trên cống của Router. Trong bài thực hành này sẽ dùng tính năng phân loại kết hợp với công nghệ GRE. Như đã biết khi dùng tính năng GRE trên R1 và R3, thì lưu lượng ban đầu giữa hai thiết bị sẽ trong suốt đối với R2 và kể cả trên cổng serial của R1, do đó việc phân loại chỉ có thể được thực hiện trên hướng vào trên cống Ethernet của R1. Để có thể thực hiên việc phân loại trên hướng ra của cổng serial trên R1 ta phải dùng tính năng Pre-classify.
Thực hiên:
R1#sh run
Building configuration...
Current configuration : 1384 byte
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
logging queue-limit 100
!
ip subnet-zero
!
!
class-map match-all telnet
match access-group 100
class-map match-all ping
match access-group 101
!
!
policy-map test
class telnet
class ping
!
!
!
!
interface Tunnel0
ip address 172.16.1.1 255.255.255.0
tunnel source Serial0/0
tunnel destination 152.1.1.2
!
interface Ethernet0/0
ip address 192.168.1.1 255.255.255.0
half-duplex
!
interface Serial0/0
ip address 150.1.1.1 255.255.255.0
service-policy output test
no ip mroute-cache
load-interval 30
no fair-queue
!
ip classless
ip route 10.0.0.0 255.255.255.0 172.16.1.2
ip route 152.1.1.0 255.255.255.0 150.1.1.2
!
!
!
access-list 100 permit tcp host 192.168.1.2 any eq telnet
access-list 101 permit icmp host 192.168.1.2 host 10.0.0.1
!
!
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
no login
!
!
end
R2#sh run
Current configuration : 833 byte
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2
!
!
interface Ethernet0/0
ip address 152.1.1.1 255.255.255.0
half-duplex
!
interface Serial0/0
ip address 150.1.1.2 255.255.255.0
clockrate 2000000
no fair-queue
!
R3#sh run
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R3
!
!
!
!
!
!
memory-size iomem 10
ip subnet-zero
!
!
!
process-max-time 200
!
interface Loopback0
ip address 10.0.0.1 255.255.255.0
no ip directed-broadcast
!
interface Tunnel0
ip address 172.16.1.2 255.255.255.0
no ip directed-broadcast
tunnel source Ethernet0/0
tunnel destination 150.1.1.1
!
interface Ethernet0/0
ip address 152.1.1.2 255.255.255.0
no ip directed-broadcast
!
interface Serial0/0
no ip address
no ip directed-broadcast
shutdown
!
ip classless
ip route 150.1.1.0 255.255.255.0 152.1.1.1
ip route 192.168.1.0 255.255.255.0 172.16.1.1
ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
privilege level 15
no login
!
no scheduler allocate
end
Tạo Traffic liên qua trên host A
C:\>ping 10.0.0.1
Pinging 10.0.0.1 with 32 byte of data:
Reply from 10.0.0.1: byte=32 time=3ms TTL=254
Reply from 10.0.0.1: byte=32 time=3ms TTL=254
Reply from 10.0.0.1: byte=32 time=3ms TTL=254
Reply from 10.0.0.1: byte=32 time=3ms TTL=254
Ping statistics for 10.0.0.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0%
Approximate round trip times in milli-seconds:
Minimum = 3ms, Maximum = 3ms, Average = 3ms
C:\>telnet 10.0.0.1
Và quan sát kết quả:
R1#sh policy-map interface s0/0
Serial0/0
Service-policy output: test
Class-map: telnet (match-all)
0 packets, 0 byte
30 second offered rate 0 bps
Match: access-group 100
Class-map: ping (match-all)
0 packets, 0 byte
30 second offered rate 0 bps
Match: access-group 101
Class-map: class-default (match-any)
218 packets, 16327 byte
30 second offered rate 1000 bps, drop rate 0 bps
Match: any
Tất cả các Traffic đều thuộc lớp Default
Để phân loại được Traffic trong trường hợp này cần kích hoạt dòng lệnh:qos pre-classifytrên cống tunnel
R1(config)# interface tunnel0
R1(config-if)# qos pre-classify
Tạo lại Traffic trên host A và quan sát kết quả:
C:\>ping 10.0.0.1
Pinging 10.0.0.1 with 32 byte of data:
Reply from 10.0.0.1: byte=32 time=3ms TTL=254
Reply from 10.0.0.1: byte=32 time=3ms TTL=254
Reply from 10.0.0.1: byte=32 time=3ms TTL=254
Reply from 10.0.0.1: byte=32 time=3ms TTL=254
Ping statistics for 10.0.0.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0%
Approximate round trip times in milli-seconds:
Minimum = 3ms, Maximum = 3ms, Average = 3ms
C:\>telnet 10.0.0.1
R1#sh policy-map interface s0/0
Serial0/0
Service-policy output: test
Class-map: telnet (match-all)
5 packets, 379 byte
30 second offered rate 0 bps
Match: access-group 100
Class-map: ping (match-all)
4 packets, 352 byte
30 second offered rate 0 bps
Match: access-group 101
Class-map: class-default (match-any)
356 packets, 28690 byte
30 second offered rate 0 bps, drop rate 0 bps
Match: any
a
Mô tả:
Những bài tập trước chúng ta phân loại lưu lượng trên hướng vào hoặc hướng ra trên cống của Router. Trong bài thực hành này sẽ dùng tính năng phân loại kết hợp với công nghệ GRE. Như đã biết khi dùng tính năng GRE trên R1 và R3, thì lưu lượng ban đầu giữa hai thiết bị sẽ trong suốt đối với R2 và kể cả trên cổng serial của R1, do đó việc phân loại chỉ có thể được thực hiện trên hướng vào trên cống Ethernet của R1. Để có thể thực hiên việc phân loại trên hướng ra của cổng serial trên R1 ta phải dùng tính năng Pre-classify.
Thực hiên:
R1#sh run
Building configuration...
Current configuration : 1384 byte
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
logging queue-limit 100
!
ip subnet-zero
!
!
class-map match-all telnet
match access-group 100
class-map match-all ping
match access-group 101
!
!
policy-map test
class telnet
class ping
!
!
!
!
interface Tunnel0
ip address 172.16.1.1 255.255.255.0
tunnel source Serial0/0
tunnel destination 152.1.1.2
!
interface Ethernet0/0
ip address 192.168.1.1 255.255.255.0
half-duplex
!
interface Serial0/0
ip address 150.1.1.1 255.255.255.0
service-policy output test
no ip mroute-cache
load-interval 30
no fair-queue
!
ip classless
ip route 10.0.0.0 255.255.255.0 172.16.1.2
ip route 152.1.1.0 255.255.255.0 150.1.1.2
!
!
!
access-list 100 permit tcp host 192.168.1.2 any eq telnet
access-list 101 permit icmp host 192.168.1.2 host 10.0.0.1
!
!
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
no login
!
!
end
R2#sh run
Current configuration : 833 byte
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2
!
!
interface Ethernet0/0
ip address 152.1.1.1 255.255.255.0
half-duplex
!
interface Serial0/0
ip address 150.1.1.2 255.255.255.0
clockrate 2000000
no fair-queue
!
R3#sh run
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R3
!
!
!
!
!
!
memory-size iomem 10
ip subnet-zero
!
!
!
process-max-time 200
!
interface Loopback0
ip address 10.0.0.1 255.255.255.0
no ip directed-broadcast
!
interface Tunnel0
ip address 172.16.1.2 255.255.255.0
no ip directed-broadcast
tunnel source Ethernet0/0
tunnel destination 150.1.1.1
!
interface Ethernet0/0
ip address 152.1.1.2 255.255.255.0
no ip directed-broadcast
!
interface Serial0/0
no ip address
no ip directed-broadcast
shutdown
!
ip classless
ip route 150.1.1.0 255.255.255.0 152.1.1.1
ip route 192.168.1.0 255.255.255.0 172.16.1.1
ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
privilege level 15
no login
!
no scheduler allocate
end
Tạo Traffic liên qua trên host A
C:\>ping 10.0.0.1
Pinging 10.0.0.1 with 32 byte of data:
Reply from 10.0.0.1: byte=32 time=3ms TTL=254
Reply from 10.0.0.1: byte=32 time=3ms TTL=254
Reply from 10.0.0.1: byte=32 time=3ms TTL=254
Reply from 10.0.0.1: byte=32 time=3ms TTL=254
Ping statistics for 10.0.0.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0%
Approximate round trip times in milli-seconds:
Minimum = 3ms, Maximum = 3ms, Average = 3ms
C:\>telnet 10.0.0.1
Và quan sát kết quả:
R1#sh policy-map interface s0/0
Serial0/0
Service-policy output: test
Class-map: telnet (match-all)
0 packets, 0 byte
30 second offered rate 0 bps
Match: access-group 100
Class-map: ping (match-all)
0 packets, 0 byte
30 second offered rate 0 bps
Match: access-group 101
Class-map: class-default (match-any)
218 packets, 16327 byte
30 second offered rate 1000 bps, drop rate 0 bps
Match: any
Tất cả các Traffic đều thuộc lớp Default
Để phân loại được Traffic trong trường hợp này cần kích hoạt dòng lệnh:qos pre-classifytrên cống tunnel
R1(config)# interface tunnel0
R1(config-if)# qos pre-classify
Tạo lại Traffic trên host A và quan sát kết quả:
C:\>ping 10.0.0.1
Pinging 10.0.0.1 with 32 byte of data:
Reply from 10.0.0.1: byte=32 time=3ms TTL=254
Reply from 10.0.0.1: byte=32 time=3ms TTL=254
Reply from 10.0.0.1: byte=32 time=3ms TTL=254
Reply from 10.0.0.1: byte=32 time=3ms TTL=254
Ping statistics for 10.0.0.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0%
Approximate round trip times in milli-seconds:
Minimum = 3ms, Maximum = 3ms, Average = 3ms
C:\>telnet 10.0.0.1
R1#sh policy-map interface s0/0
Serial0/0
Service-policy output: test
Class-map: telnet (match-all)
5 packets, 379 byte
30 second offered rate 0 bps
Match: access-group 100
Class-map: ping (match-all)
4 packets, 352 byte
30 second offered rate 0 bps
Match: access-group 101
Class-map: class-default (match-any)
356 packets, 28690 byte
30 second offered rate 0 bps, drop rate 0 bps
Match: any
Comment