Lê Trường Sơn
Cấu hình thực hiện cuộc gọi giữa 2 vùng được quản lý bởi 2 Gatekeeper (Inter-zone)
Sơ đồ mạng
Yêu cầu cấu hình
Bài lab này mô tả cách cấu hình trao đổi thông tin giữa các vùng (zone) thuộc các gatekeeper khác nhau. Yêu cầu như sau:
Thực hiện
A. Cấu hình ban đầu:
Cấu hình ban đầu trên gatekeeper 1:
Gatekeeper-1#sh run
Building configuration...
Current configuration : 1092 bytes
!
version 12.1
!
hostname Gatekeeper-1
!
!
interface Loopback0
ip address 192.168.1.10 255.255.255.0
!
interface FastEthernet0/0
ip address 172.16.1.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 172.16.2.1 255.255.255.0
!
ip route 172.16.3.0 255.255.255.0 172.16.2.2
ip route 192.168.10.0 255.255.255.0 172.16.2.2
!
Cấu hình ban đầu trên gatekeeper 2:
Gatekeeper-2#sh run
Building configuration...
Current configuration : 1072 bytes
!
version 12.1
!
hostname Gatekeeper-2
!
interface Loopback0
ip address 192.168.10.10 255.255.255.0
!
interface Ethernet0/0
ip address 172.16.3.1 255.255.255.0
half-duplex
!
interface Serial0/0
ip address 172.16.2.2 255.255.255.0
!
ip route 172.16.1.0 255.255.255.0 172.16.2.1
ip route 192.168.1.0 255.255.255.0 172.16.2.1
!
Cấu hình ban đầu trên Saigon:
Saigon#sh run
Building configuration...
Current configuration : 824 bytes
!
version 12.3
!
hostname Saigon
!
interface FastEthernet0/0
ip address 172.16.1.2 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 172.16.1.1
!
voice-port 1/0/0
!
voice-port 1/0/1
!
Cấu hình trên Hanoi:
Hanoi#sh run
Building configuration...
Current configuration : 913 bytes
!
hostname Hanoi
!
interface Ethernet0/0
ip address 172.16.3.2 255.255.255.0
half-duplex
!
ip route 0.0.0.0 0.0.0.0 172.16.3.1
!
voice-port 1/0/0
!
voice-port 1/0/1
!
!
B. Các bước thực hiện:
Bước 1: Cấu hình gatekeeper
Cấu hình trên gatekeeper 1:
Gatekeeper-1#configure terminal
Gatekeeper-1(config)#gatekeeper
Gatekeeper-1(config−gk)#
Gatekeeper-1(config−gk)#zone local Saigon vnpro.org 192.168.1.10
! Định nghĩa vùng (zone) quản lý cục bộ
Gatekeeper-1(config−gk)#zone remote Hanoi cisco.com 192.168.10.10 1719
! Định nghĩa vùng từ xa (remote zone)
Gatekeeper-1(config−gk)#zone prefix Saigon 1*
! Định nghĩa số prefix quản lý bởi vùng cục bộ (local zone)
Gatekeeper-1(config−gk)#zone prefix Hanoi 2*
! Định nghĩa số prefix quản lý bởi vùng từ xa (remote zone)
Gatekeeper-1(config−gk)#no shutdown
!
Cấu hình trên gatekeeper 2:
Gatekeeper-2#configure terminal
Gatekeeper-2(config)#gatekeeper
Gatekeeper-2(config)#zone local Hanoi cisco.com 192.168.10.10
Gatekeeper-2(config)#zone remote Saigon vnpro.org 192.168.1.10 1719
Gatekeeper-2(config)#zone prefix Saigon 1*
Gatekeeper-2(config)#zone prefix Hanoi 2*
Gatekeeper-2(config)#no shutdown
Bước 2: Cấu hình gateway
Cấu hình trên gateway Saigon
(có thể tham khảo cú pháp trong bài lab 6)
Cấu hình cổng giao tiếp H323
Saigon(config)#gateway
Saigon(config)#interface FastEthernet0/0
Saigon(config-if)#ip address 172.16.1.2 255.255.255.0
Saigon(config-if)#h323-gateway voip interface
Saigon(config-if)#h323-gateway voip id Saigon ipaddr 192.168.1.10 1719
Cấu hình cổng voice
Saigon(config)#dial-peer voice 1 pots
Saigon(config-dial-peer)#destination-pattern 101
Saigon(config-dial-peer)#port 1/0/0
!
Saigon(config)#dial-peer voice 2 voip
Saigon(config-dial-peer)#destination-pattern 2..
Saigon(config-dial-peer)#session target ras
Cấu hình trên gateway Hanoi
Cấu hình cổng giao tiếp H323
Hanoi(config)#gateway
Hanoi(config)#interface Ethernet0/0
Hanoi(config-if)#ip address 172.16.3.2 255.255.255.0
Hanoi(config-if)#h323-gateway voip interface
Hanoi(config-if)#h323-gateway voip id Hanoi ipaddr 192.168.10.10 1719
!
Cấu hình cổng voice
Hanoi(config)#dial-peer voice 1 pots
Hanoi(config-dial-peer)#destination-pattern 201
Hanoi(config-dial-peer)#port 1/0/0
!
Hanoi(config-dial-peer)#dial-peer voice 2 voip
Hanoi(config-dial-peer)#destination-pattern 1..
Hanoi(config-dial-peer)#session target ras
C. Kiểm tra
Thực hiện cuộc gọi và kiểm tra
Gatekeeper#sh gatekeeper endpoints
GATEKEEPER ENDPOINT REGISTRATION
================================
E164-ID: 101
Voice Capacity Max.= Avail.= Current.= 1
Total number of active registrations = 1
Gatekeeper#
Xem các thông tin cuộc gọi hiện thời
Gatekeeper#sh gatekeeper calls
Total number of active calls = 1.
GATEKEEPER CALL INFO
====================
LocalCallID Age(secs) BW
4-57824 14 16(Kbps)
Endpt(s): Alias E.164Addr
src EP: 101
CallSignalAddr Port RASSignalAddr Port
172.16.1.2 1720 172.16.1.2 56921
Endpt(s): Alias E.164Addr
dst EP: Saigon1 201
CallSignalAddr Port RASSignalAddr Port
172.16.3.2 1720 172.16.3.2 1720
Gatekeeper#
Xem thông tin cấu hình zone trên gatekeeper
Gatekeeper#sh gatekeeper zone prefix
ZONE PREFIX TABLE
=================
GK-NAME E164-PREFIX
------- -----------
Saigon 1*
Hanoi 2*
Gatekeeper#
D. Cấu hình đầy đủ
Cấu hình trên gatekeeper 1:
Gatekeeper-1#sh run
Building configuration...
Current configuration : 1092 bytes
!
version 12.1
!
hostname Gatekeeper-1
!
!
interface Loopback0
ip address 192.168.1.10 255.255.255.0
!
interface FastEthernet0/0
ip address 172.16.1.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 172.16.2.1 255.255.255.0
!
ip route 172.16.3.0 255.255.255.0 172.16.2.2
ip route 192.168.10.0 255.255.255.0 172.16.2.2
!
gatekeeper
zone local Saigon vnpro.org 192.168.1.10
zone remote Hanoi cisco.com 192.168.10.10 1719
zone prefix Saigon 1*
zone prefix Hanoi 2*
no shutdown
!
Cấu hình trên gatekeeper 2:
Gatekeeper-2#sh run
Building configuration...
Current configuration : 1072 bytes
!
version 12.1
!
hostname Gatekeeper-2
!
interface Loopback0
ip address 192.168.10.10 255.255.255.0
!
interface Ethernet0/0
ip address 172.16.3.1 255.255.255.0
half-duplex
!
interface Serial0/0
ip address 172.16.2.2 255.255.255.0
!
ip route 172.16.1.0 255.255.255.0 172.16.2.1
ip route 192.168.1.0 255.255.255.0 172.16.2.1
!
gatekeeper
zone local Hanoi cisco.com 192.168.10.10
zone remote Saigon vnpro.org 192.168.1.10 1719
zone prefix Saigon 1*
zone prefix Hanoi 2*
no shutdown
!
Cấu hình trên Saigon:
Saigon#sh run
Building configuration...
Current configuration : 824 bytes
!
version 12.3
!
hostname Saigon
!
interface FastEthernet0/0
ip address 172.16.1.2 255.255.255.0
h323-gateway voip interface
h323-gateway voip id Saigon ipaddr 192.168.1.10 1719
!
ip route 0.0.0.0 0.0.0.0 172.16.1.1
!
voice-port 1/0/0
!
voice-port 1/0/1
!
dial-peer voice 1 pots
destination-pattern 101
port 1/0/0
!
dial-peer voice 2 voip
destination-pattern 2..
session target ras
!
gateway
!
Cấu hình trên Hanoi:
Hanoi#sh run
Building configuration...
Current configuration : 913 bytes
!
hostname Hanoi
!
interface Ethernet0/0
ip address 172.16.3.2 255.255.255.0
half-duplex
h323-gateway voip interface
h323-gateway voip id Hanoi ipaddr 192.168.10.10 1719
!
ip route 0.0.0.0 0.0.0.0 172.16.3.1
!
voice-port 1/0/0
!
voice-port 1/0/1
!
dial-peer voice 1 pots
destination-pattern 201
port 1/0/0
!
dial-peer voice 2 voip
destination-pattern 1..
session target ras
!
gateway
!
Cấu hình thực hiện cuộc gọi giữa 2 vùng được quản lý bởi 2 Gatekeeper (Inter-zone)
Sơ đồ mạng
Yêu cầu cấu hình
Bài lab này mô tả cách cấu hình trao đổi thông tin giữa các vùng (zone) thuộc các gatekeeper khác nhau. Yêu cầu như sau:
- Cấu hình Zone 1 tên Saigon trên gatekeeper 1 trên và Zone 2 tên Hanoi trên gatekeeper 2
- Cầu hình hai Router Saigon và Hanoi thực hiên cuộc gọi qua hai zone
Thực hiện
A. Cấu hình ban đầu:
Cấu hình ban đầu trên gatekeeper 1:
Gatekeeper-1#sh run
Building configuration...
Current configuration : 1092 bytes
!
version 12.1
!
hostname Gatekeeper-1
!
!
interface Loopback0
ip address 192.168.1.10 255.255.255.0
!
interface FastEthernet0/0
ip address 172.16.1.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 172.16.2.1 255.255.255.0
!
ip route 172.16.3.0 255.255.255.0 172.16.2.2
ip route 192.168.10.0 255.255.255.0 172.16.2.2
!
Cấu hình ban đầu trên gatekeeper 2:
Gatekeeper-2#sh run
Building configuration...
Current configuration : 1072 bytes
!
version 12.1
!
hostname Gatekeeper-2
!
interface Loopback0
ip address 192.168.10.10 255.255.255.0
!
interface Ethernet0/0
ip address 172.16.3.1 255.255.255.0
half-duplex
!
interface Serial0/0
ip address 172.16.2.2 255.255.255.0
!
ip route 172.16.1.0 255.255.255.0 172.16.2.1
ip route 192.168.1.0 255.255.255.0 172.16.2.1
!
Cấu hình ban đầu trên Saigon:
Saigon#sh run
Building configuration...
Current configuration : 824 bytes
!
version 12.3
!
hostname Saigon
!
interface FastEthernet0/0
ip address 172.16.1.2 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 172.16.1.1
!
voice-port 1/0/0
!
voice-port 1/0/1
!
Cấu hình trên Hanoi:
Hanoi#sh run
Building configuration...
Current configuration : 913 bytes
!
hostname Hanoi
!
interface Ethernet0/0
ip address 172.16.3.2 255.255.255.0
half-duplex
!
ip route 0.0.0.0 0.0.0.0 172.16.3.1
!
voice-port 1/0/0
!
voice-port 1/0/1
!
!
B. Các bước thực hiện:
Bước 1: Cấu hình gatekeeper
Cấu hình trên gatekeeper 1:
Gatekeeper-1#configure terminal
Gatekeeper-1(config)#gatekeeper
Gatekeeper-1(config−gk)#
Gatekeeper-1(config−gk)#zone local Saigon vnpro.org 192.168.1.10
! Định nghĩa vùng (zone) quản lý cục bộ
Gatekeeper-1(config−gk)#zone remote Hanoi cisco.com 192.168.10.10 1719
! Định nghĩa vùng từ xa (remote zone)
Gatekeeper-1(config−gk)#zone prefix Saigon 1*
! Định nghĩa số prefix quản lý bởi vùng cục bộ (local zone)
Gatekeeper-1(config−gk)#zone prefix Hanoi 2*
! Định nghĩa số prefix quản lý bởi vùng từ xa (remote zone)
Gatekeeper-1(config−gk)#no shutdown
!
Cấu hình trên gatekeeper 2:
Gatekeeper-2#configure terminal
Gatekeeper-2(config)#gatekeeper
Gatekeeper-2(config)#zone local Hanoi cisco.com 192.168.10.10
Gatekeeper-2(config)#zone remote Saigon vnpro.org 192.168.1.10 1719
Gatekeeper-2(config)#zone prefix Saigon 1*
Gatekeeper-2(config)#zone prefix Hanoi 2*
Gatekeeper-2(config)#no shutdown
Bước 2: Cấu hình gateway
Cấu hình trên gateway Saigon
(có thể tham khảo cú pháp trong bài lab 6)
Cấu hình cổng giao tiếp H323
Saigon(config)#gateway
Saigon(config)#interface FastEthernet0/0
Saigon(config-if)#ip address 172.16.1.2 255.255.255.0
Saigon(config-if)#h323-gateway voip interface
Saigon(config-if)#h323-gateway voip id Saigon ipaddr 192.168.1.10 1719
Cấu hình cổng voice
Saigon(config)#dial-peer voice 1 pots
Saigon(config-dial-peer)#destination-pattern 101
Saigon(config-dial-peer)#port 1/0/0
!
Saigon(config)#dial-peer voice 2 voip
Saigon(config-dial-peer)#destination-pattern 2..
Saigon(config-dial-peer)#session target ras
Cấu hình trên gateway Hanoi
Cấu hình cổng giao tiếp H323
Hanoi(config)#gateway
Hanoi(config)#interface Ethernet0/0
Hanoi(config-if)#ip address 172.16.3.2 255.255.255.0
Hanoi(config-if)#h323-gateway voip interface
Hanoi(config-if)#h323-gateway voip id Hanoi ipaddr 192.168.10.10 1719
!
Cấu hình cổng voice
Hanoi(config)#dial-peer voice 1 pots
Hanoi(config-dial-peer)#destination-pattern 201
Hanoi(config-dial-peer)#port 1/0/0
!
Hanoi(config-dial-peer)#dial-peer voice 2 voip
Hanoi(config-dial-peer)#destination-pattern 1..
Hanoi(config-dial-peer)#session target ras
C. Kiểm tra
Thực hiện cuộc gọi và kiểm tra
Gatekeeper#sh gatekeeper endpoints
GATEKEEPER ENDPOINT REGISTRATION
================================
CallSignalAddr Port RASSignalAddr Port Zone Name Type Flags
--------------- ----- ------------- ----- --------- ---- -----
172.16.1.2 1720 172.16.1.2 56921 Saigon VOIP-GW
Voice Capacity Max.= Avail.= Current.= 1
Total number of active registrations = 1
Gatekeeper#
Xem các thông tin cuộc gọi hiện thời
Gatekeeper#sh gatekeeper calls
Total number of active calls = 1.
GATEKEEPER CALL INFO
====================
LocalCallID Age(secs) BW
4-57824 14 16(Kbps)
Endpt(s): Alias E.164Addr
src EP: 101
CallSignalAddr Port RASSignalAddr Port
172.16.1.2 1720 172.16.1.2 56921
Endpt(s): Alias E.164Addr
dst EP: Saigon1 201
CallSignalAddr Port RASSignalAddr Port
172.16.3.2 1720 172.16.3.2 1720
Gatekeeper#
Xem thông tin cấu hình zone trên gatekeeper
Gatekeeper#sh gatekeeper zone prefix
ZONE PREFIX TABLE
=================
GK-NAME E164-PREFIX
------- -----------
Saigon 1*
Hanoi 2*
Gatekeeper#
D. Cấu hình đầy đủ
Cấu hình trên gatekeeper 1:
Gatekeeper-1#sh run
Building configuration...
Current configuration : 1092 bytes
!
version 12.1
!
hostname Gatekeeper-1
!
!
interface Loopback0
ip address 192.168.1.10 255.255.255.0
!
interface FastEthernet0/0
ip address 172.16.1.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 172.16.2.1 255.255.255.0
!
ip route 172.16.3.0 255.255.255.0 172.16.2.2
ip route 192.168.10.0 255.255.255.0 172.16.2.2
!
gatekeeper
zone local Saigon vnpro.org 192.168.1.10
zone remote Hanoi cisco.com 192.168.10.10 1719
zone prefix Saigon 1*
zone prefix Hanoi 2*
no shutdown
!
Cấu hình trên gatekeeper 2:
Gatekeeper-2#sh run
Building configuration...
Current configuration : 1072 bytes
!
version 12.1
!
hostname Gatekeeper-2
!
interface Loopback0
ip address 192.168.10.10 255.255.255.0
!
interface Ethernet0/0
ip address 172.16.3.1 255.255.255.0
half-duplex
!
interface Serial0/0
ip address 172.16.2.2 255.255.255.0
!
ip route 172.16.1.0 255.255.255.0 172.16.2.1
ip route 192.168.1.0 255.255.255.0 172.16.2.1
!
gatekeeper
zone local Hanoi cisco.com 192.168.10.10
zone remote Saigon vnpro.org 192.168.1.10 1719
zone prefix Saigon 1*
zone prefix Hanoi 2*
no shutdown
!
Cấu hình trên Saigon:
Saigon#sh run
Building configuration...
Current configuration : 824 bytes
!
version 12.3
!
hostname Saigon
!
interface FastEthernet0/0
ip address 172.16.1.2 255.255.255.0
h323-gateway voip interface
h323-gateway voip id Saigon ipaddr 192.168.1.10 1719
!
ip route 0.0.0.0 0.0.0.0 172.16.1.1
!
voice-port 1/0/0
!
voice-port 1/0/1
!
dial-peer voice 1 pots
destination-pattern 101
port 1/0/0
!
dial-peer voice 2 voip
destination-pattern 2..
session target ras
!
gateway
!
Cấu hình trên Hanoi:
Hanoi#sh run
Building configuration...
Current configuration : 913 bytes
!
hostname Hanoi
!
interface Ethernet0/0
ip address 172.16.3.2 255.255.255.0
half-duplex
h323-gateway voip interface
h323-gateway voip id Hanoi ipaddr 192.168.10.10 1719
!
ip route 0.0.0.0 0.0.0.0 172.16.3.1
!
voice-port 1/0/0
!
voice-port 1/0/1
!
dial-peer voice 1 pots
destination-pattern 201
port 1/0/0
!
dial-peer voice 2 voip
destination-pattern 1..
session target ras
!
gateway
!