Xin chào ! Nếu đây là lần đầu tiên bạn đến với diễn đàn, xin vui lòng danh ra một phút bấm vào đây để đăng kí và tham gia thảo luận cùng VnPro.

Announcement

Collapse
No announcement yet.

[Help] Cấu hình QoS trong MPLS

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Help] Cấu hình QoS trong MPLS

    Chào các anh chị em,
    Mình đang làm bài lab nâng cao chất lượng dịch vụ trong MPLS, ý của mình là muốn tăng khả năng truyền khi download, upload file. Trong mô hình máy Server ở Cloud 1, Client ở Cloud 2.
    Mô hình:


    IP:

    Tên
    Server
    IP
    192.168.3.2/30
    Gateway
    192.168.3.1
    Client 192.168.3.14/30 192.168.3.13

    s1/0 Fa2/0 Loopback 0
    CE1 192.168.3.5/30 192.168.3.1/30 192.168.1.1/32
    CE2 192.168.3.10/30 192.168.3.13/30 192.168.2.1/32

    s1/0 s1/1 Loopback 0
    PE1 204.134.83.1/30 192.168.3.6/30 204.134.84.1/32
    P1 204.134.83.5/30 204.134.83.2/30 204.134.84.2/32
    P2 204.134.83.6/30 204.134.83.9/30 204.134.84.3/32
    PE2 204.134.83.10/30 192.168.3.9/30 204.134.84.4/32
    Đây là file cấu hình:

    CE1
    Code:
    
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname CE1
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    !
    !
    ip cef
    no ip domain lookup
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    class-map match-all ftp-out
     match ip dscp af31 
    class-map match-all http-in
     match protocol http
    class-map match-all ftp-in
     match protocol ftp
    class-map match-all http-out
     match ip dscp af11 
    !
    !
    policy-map ip2mpls-in
      description *** Policy to set DSCP value for IP packets ***
     class http-in
      set ip dscp af11
     class ftp-in
      set ip dscp af31
    policy-map ip2mpls-out
      description *** Policy to shape traffic before coming into MPLS domain ***
     class http-out
      bandwidth percent 20
      shape average 1000000
     class ftp-out
      bandwidth percent 5
      shape average 600000
     class class-default
      bandwidth percent 50
    !
    !
    !
    !
    interface Loopback0
     ip address 192.168.1.1 255.255.255.255
    !
    interface FastEthernet0/0
     no ip address
     shutdown
     duplex half
    !
    interface Serial1/0
     description *** Connect to PE1 ***
     ip address 192.168.3.5 255.255.255.252
     duplex auto
     speed auto
     service-policy output ip2mpls-out
    !
    interface FastEthernet2/0
     description *** Default Gateway ***
     ip address 192.168.3.1 255.255.255.252
     duplex auto
     speed auto
     service-policy input ip2mpls-in
    !
    router rip
     version 2
     network 192.168.3.0
     no auto-summary
    !
    router bgp 65001
     no synchronization
     bgp log-neighbor-changes
     redistribute connected
     neighbor 192.168.3.6 remote-as 65000
     no auto-summary
    !
    ip forward-protocol nd
    !
    no ip http server
    !
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    gatekeeper
     shutdown
    !
    !
    line con 0
     exec-timeout 0 0
     logging synchronous
     stopbits 1
    line aux 0
     stopbits 1
    line vty 0 4
     login
    !
    !
    end
    CE2
    Code:
    
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname CE2
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    !
    !
    ip cef
    no ip domain lookup
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    class-map match-all ftp-out
     match ip dscp af31 
    class-map match-all http-out
     match ip dscp af11 
    !
    !
    policy-map mpls2ip-out
      description *** Policy to forward packets base on DSCP value ***
     class http-out
      bandwidth percent 20
      random-detect
     class ftp-out
      bandwidth percent 5
      random-detect
     class class-default
      bandwidth percent 50
      random-detect
    !
    !
    !
    !
    interface Loopback0
     ip address 192.168.2.1 255.255.255.255
    !
    interface FastEthernet0/0
     no ip address
     shutdown
     duplex half
    !
    interface Serial1/0
     description *** Connect to PE2 ***
     ip address 192.168.3.10 255.255.255.252
     duplex auto
     speed auto
    !
    interface FastEthernet2/0
     description *** Default Gateway ***
     ip address 192.168.3.13 255.255.255.252
     duplex auto
     speed auto
     service-policy output mpls2ip-out
    !
    router rip
     version 2
     network 192.168.3.0
     no auto-summary
    !
    router bgp 65002
     no synchronization
     bgp log-neighbor-changes
     redistribute connected
     neighbor 192.168.3.9 remote-as 65000
     no auto-summary
    !
    ip forward-protocol nd
    !
    no ip http server
    !
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    gatekeeper
     shutdown
    !
    !
    line con 0
     exec-timeout 0 0
     logging synchronous
     stopbits 1
    line aux 0
     stopbits 1
    line vty 0 4
     login
    !
    !
    end
    PE1
    Code:
    !
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname PE1
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    !
    !
    ip cef
    no ip domain lookup
    !
    !
    no mpls ip propagate-ttl 
    mpls ldp explicit-null
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    class-map match-all ftp-out
     match mpls experimental topmost 3 
    class-map match-all http-in
     match ip dscp af11 
    class-map match-all ftp-in
     match ip dscp af31 
    class-map match-all http-out
     match mpls experimental topmost 1 
    class-map match-all mpls2mpls-out
    !
    !
    policy-map ip2mpls-in
      description *** Policy to police traffic coming into MPLS domain ***
     class http-in
       police cir 1000000 bc 100000 be 100000
         conform-action set-mpls-exp-topmost-transmit 1
         exceed-action drop 
         violate-action drop 
     class ftp-in
       police cir 600000 bc 100000 be 100000
         conform-action set-mpls-exp-topmost-transmit 3
         exceed-action drop 
    policy-map mpls2mpls-out
      description *** Policy to forward packets base on EXP value ***
     class http-out
      set mpls experimental topmost 1
      bandwidth percent 20
      random-detect
     class ftp-out
      set mpls experimental topmost 3
      bandwidth percent 5
     class class-default
      bandwidth percent 50
      random-detect
    !
    !
    !
    !
    interface Loopback0
     ip address 204.134.84.1 255.255.255.255
    !
    interface FastEthernet0/0
     no ip address
     shutdown
     duplex half
    !
    interface Serial1/0
     description *** Connect to P1 Router ***
     ip address 204.134.83.1 255.255.255.252
     duplex auto
     speed auto
     mpls label protocol ldp
     mpls ip
     service-policy output mpls2mpls-out
    !
    interface Serial1/1
     description *** Link to CE1 ***
     ip address 192.168.3.6 255.255.255.252
     duplex auto
     speed auto
     service-policy input ip2mpls-in
    !
    router eigrp 2011
     network 204.134.83.0
     network 204.134.84.0
     no auto-summary
    !
    router bgp 65000
     no synchronization
     bgp log-neighbor-changes
     neighbor 192.168.3.5 remote-as 65001
     neighbor 204.134.84.4 remote-as 65000
     neighbor 204.134.84.4 update-source Loopback0
     neighbor 204.134.84.4 next-hop-self
     no auto-summary
    !
    ip forward-protocol nd
    !
    no ip http server
    !
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    gatekeeper
     shutdown
    !
    !
    line con 0
     exec-timeout 0 0
     logging synchronous
     stopbits 1
    line aux 0
     stopbits 1
    line vty 0 4
     login
    !
    !
    end
    PE2
    Code:
    !
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname PE2
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    !
    !
    ip cef
    no ip domain lookup
    !
    !
    no mpls ip propagate-ttl 
    mpls ldp explicit-null
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    class-map match-all ftp-out
     match qos-group 3
    class-map match-all http-in
     match mpls experimental topmost 1 
    class-map match-all ftp-in
     match mpls experimental topmost 3 
    class-map match-all http-out
     match qos-group 1
    !
    !
    policy-map mpls2ip-in
      description *** Policy to map EXP value to DSCP value ***
     class http-in
      set qos-group mpls experimental topmost
     class ftp-in
      set qos-group mpls experimental topmost
    policy-map mpls2ip-out
      description *** Policy to forward packets base on DSCP value ***
     class http-out
      set ip dscp af11
      bandwidth percent 20
      random-detect
     class ftp-out
      set ip dscp af31
      bandwidth percent 5
      random-detect
     class class-default
      bandwidth percent 50
      random-detect
    !
    !
    !
    !
    interface Loopback0
     ip address 204.134.84.4 255.255.255.255
    !
    interface FastEthernet0/0
     no ip address
     shutdown
     duplex half
    !
    interface Serial1/0
     description *** Connect to P2 Router ***
     ip address 204.134.83.10 255.255.255.252
     duplex auto
     speed auto
     mpls label protocol ldp
     mpls ip
     service-policy input mpls2ip-in
    !
    interface Serial1/1
     description *** Link to CE2 ***
     ip address 192.168.3.9 255.255.255.252
     duplex auto
     speed auto
     service-policy output mpls2ip-out
    !
    router eigrp 2011
     network 204.134.83.0
     network 204.134.84.0
     no auto-summary
    !
    router bgp 65000
     no synchronization
     bgp log-neighbor-changes
     neighbor 192.168.3.10 remote-as 65002
     neighbor 204.134.84.1 remote-as 65000
     neighbor 204.134.84.1 update-source Loopback0
     neighbor 204.134.84.1 next-hop-self
     no auto-summary
    !
    ip forward-protocol nd
    !
    no ip http server
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    gatekeeper
     shutdown
    !
    !
    line con 0
     exec-timeout 0 0
     logging synchronous
     stopbits 1
    line aux 0
     stopbits 1
    line vty 0 4
     login
    !
    !
    end
    P1
    Code:
    !
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname P1
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    !
    !
    ip cef
    no ip domain lookup
    !
    !
    no mpls ip propagate-ttl 
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    class-map match-all ftp-out
     match mpls experimental topmost 3 
    class-map match-all http-out
     match mpls experimental topmost 1 
    !
    !
    policy-map mpls2mpls-out
      description *** Policy to forward packets base on EXP value ***
     class http-out
      set mpls experimental topmost 1
      bandwidth percent 20
      random-detect
     class ftp-out
      set mpls experimental topmost 3
      bandwidth percent 5
      random-detect
     class class-default
      set mpls experimental topmost 0
      bandwidth percent 50
      random-detect
    !
    !
    !
    !
    interface Loopback0
     ip address 204.134.84.2 255.255.255.255
    !
    interface FastEthernet0/0
     no ip address
     shutdown
     duplex half
    !
    interface Serial1/0
     description *** Link to P2 Router ***
     ip address 204.134.83.5 255.255.255.252
     duplex auto
     speed auto
     mpls label protocol ldp
     mpls ip
     service-policy output mpls2mpls-out
    !
    interface Serial1/1
     description *** Link to PE1 ***
     ip address 204.134.83.2 255.255.255.252
     duplex auto
     speed auto
     mpls label protocol ldp
     mpls ip
    !
    router eigrp 2011
     network 204.134.83.0
     network 204.134.84.0
     no auto-summary
    !
    ip forward-protocol nd
    !
    no ip http server
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    gatekeeper
     shutdown
    !
    !
    line con 0
     exec-timeout 0 0
     logging synchronous
     stopbits 1
    line aux 0
     stopbits 1
    line vty 0 4
     login
    !
    !
    end
    P2
    Code:
    !
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname P2
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    !
    !
    ip cef
    no ip domain lookup
    !
    !
    no mpls ip propagate-ttl 
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    class-map match-all ftp-out
     match mpls experimental topmost 3 
    class-map match-all http-out
     match mpls experimental topmost 1 
    !
    !
    policy-map mpls2mpls-out
      description *** Policy to forward packets base on EXP value ***
     class http-out
      set mpls experimental topmost 1
      bandwidth percent 20
      random-detect
     class ftp-out
      set mpls experimental topmost 3
      bandwidth percent 5
      random-detect
     class class-default
      set mpls experimental topmost 0
      bandwidth percent 50
      random-detect
    !
    !
    !
    !
    interface Loopback0
     ip address 204.134.84.3 255.255.255.255
    !
    interface FastEthernet0/0
     no ip address
     shutdown
     duplex half
    !
    interface Serial1/0
     description *** Link to P1 Router ***
     ip address 204.134.83.6 255.255.255.252
     duplex auto
     speed auto
     mpls label protocol ldp
     mpls ip
    !
    interface Serial1/1
     description *** Link to PE2 ***
     ip address 204.134.83.9 255.255.255.252
     duplex auto
     speed auto
     mpls label protocol ldp
     mpls ip
     service-policy output mpls2mpls-out
    !
    router eigrp 2011
     network 204.134.83.0
     network 204.134.84.0
     no auto-summary
    !
    ip forward-protocol nd
    !
    no ip http server
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    gatekeeper
     shutdown
    !
    !
    line con 0
     exec-timeout 0 0
     logging synchronous
     stopbits 1
    line aux 0
     stopbits 1
    line vty 0 4
     login
    !
    !
    end
    Đây là topology: http://www.mediafire.com/?bqja8lt361gxf6b
    Đây là code hoàn chỉnh: http://www.mediafire.com/?fvonc160ecjdu9r
    Nhưng hiện tại vẫn chưa ping thông từ Server đến Client, pro nào biết sai chỗ nào xin giúp mình với.

  • #2
    Mình chạy bài LAB của bạn, Ping từ Server tới Client ok mà bạn.
    Bạn hãy thử đổi 2 cái cloud thành 2 con router, để giả lập nó là PC, rồi ping lại thử xem.
    Nguyễn Bá Hiển
    Email: nguyenbahien@vnpro.org
    Yahoo: nguyenbahien_vnpro
    ------------------------------------------------------------------------------------------------------------
    Trung Tâm Tin Học VnPro
    149/1D Ung Văn Khiêm P25 Q.Bình thạnh TPHCM
    Tel : (08) 35124257 (5 lines)
    Fax: (08) 35124314

    Home page: http://www.vnpro.vn
    Support Forum: http://www.vnpro.org
    - Chuyên đào tạo quản trị mạng và hạ tầng Internet
    - Phát hành sách chuyên môn
    - Tư vấn và tuyển dụng nhân sự IT
    - Tư vấn thiết kế và hỗ trợ kỹ thuật hệ thống mạng

    Network channel: http://www.dancisco.com
    Blog: http://www.vnpro.org/blog

    Comment


    • #3
      Uh, nó thông rồi, nhưng hơi lâu. Cho mình hỏi này tí, cái này mình áp dụng QoS vào, nhưng có vấn đề mình chưa fix được.
      Lúc khi chưa áp vào thì download trên http và ftp thì tốc độ khoảng 130kb/s, nhưng khi áp vào (cấu hình như trên) thì tốc độ chỉ còn khoảng 70-80kb/s thôi.

      Mình đang cần bài lab QoS tăng tốc độ dịch vụ trên http và ftp trên nền MPLS, pro nào có cho mình xin với.
      (Nếu có tài liệu hướng dẫn càng tốt)

      Comment


      • #4
        Bạn có thể trình bày cách test như thế nào không?
        Cùng lúc bạn cho chạy qua hệ thống đó bao nhiêu loại lưu lượng?
        Theo như cấu hình trên, trên CE, bạn đang dùng cơ chế hàng đợi CBWFQ, và bạn chỉ dành cho FTP có 5% BW, HTTP thì 20% BW của cổng. Cơ chế hàng đợi này chỉ thực sự hoạt động khi có nghẽn xảy ra. Nếu có nghẽn xảy ra thì lưu lượng FTP chỉ được dành 5% BW cổng = 5%*1.5MB ~ 75 KB/s là hợp lý rồi.
        Đồng thời bạn điều hòa (shaping) 2 loại lưu lượng này với HTTP rate là 1000000 bps ~ 125 KB/s, FTP là 600000 ~ 75 KB/s.
        Đồng thời trên PE bạn cũng giám sát 2 loại lưu lượng này. nếu vượt qua rate trên thì drop. còn nếu nằm trong rate thì lại đánh dấu bằng MPLS.

        Regards
        Nguyễn Bá Hiển
        Email: nguyenbahien@vnpro.org
        Yahoo: nguyenbahien_vnpro
        ------------------------------------------------------------------------------------------------------------
        Trung Tâm Tin Học VnPro
        149/1D Ung Văn Khiêm P25 Q.Bình thạnh TPHCM
        Tel : (08) 35124257 (5 lines)
        Fax: (08) 35124314

        Home page: http://www.vnpro.vn
        Support Forum: http://www.vnpro.org
        - Chuyên đào tạo quản trị mạng và hạ tầng Internet
        - Phát hành sách chuyên môn
        - Tư vấn và tuyển dụng nhân sự IT
        - Tư vấn thiết kế và hỗ trợ kỹ thuật hệ thống mạng

        Network channel: http://www.dancisco.com
        Blog: http://www.vnpro.org/blog

        Comment

        Working...
        X