Nguồn: Sách CCNA Labpro
LAB 3-8: CẤU HÌNH IGRP UNEQUAL-COST LOAD BALANCING
Mô tả & yêu cầu:
- Router A, B, C sử dụng IGRP để quảng bá các thông tin định tuyến.
- Router B hoạt động như DCE cung cấp xung clock cho router A và C.
- Các router cấu hình IGRP và quảng bá tất cả các mạng nối trực tiếp.
- Cấu hình router A và B sử dụng IGRP cân bằng tải trên cổng S0, E0.
- Từ router A, b, C ping được hết các địa chỉ trong mạng.
Chú ý: Mặc định router sẽ cân bằng tải 4 tuyến đường đi có cost bằng nhau. Ta có thể cấu hình IGRP cân bằng tải được đến 4 tuyến đường đi có cost không bằng nhau để đến đích bằng cách sử dụng biến varian x với x=highest cost/lowest cost. Ví dụ nếu router A có 2 đường đi đến đích 3.3.3.3 một đường có cost là 4 và đường kia có cost là 8 thì mặc định sẽ sử dụng đường đi có cost 4 để đến 3.3.3.3. Tuy nhiên nếu ta thiết lập variance là 2 thì router sẽ cân bằng tải trên cả hai tuyến đường này.
Cấu hình:
Router A:
!
hostname RouterA
!
interface Loopback0 <- Định nghĩa cổng ảo
ip address 10.1.1.1 255.255.255.0
!
interface Ethernet0
ip address 152.1.1.1 255.255.255.0
keepalive
!
interface Serial0
ip addres 192.1.1.1 255.255.255.0
no shut
!
!
router IGRP 64 <- kích hoạt quá trình định tuyến IGRP trên router variance 2
network 10.0.0.0 <- chỉ ra mạng sẽ quảng bá và xác định cổng nào sẽ gởi và nhận thông tin định tuyến IGRP
network 152.1.0.0
network 192.1.1.0
!
no ip classless
!
end
!
hostname RouterA
!
interface Loopback0 <- Định nghĩa cổng ảo
ip address 10.1.1.1 255.255.255.0
!
interface Ethernet0
ip address 152.1.1.1 255.255.255.0
keepalive
!
interface Serial0
ip addres 192.1.1.1 255.255.255.0
no shut
!
!
router IGRP 64 <- kích hoạt quá trình định tuyến IGRP trên router variance 2
network 10.0.0.0 <- chỉ ra mạng sẽ quảng bá và xác định cổng nào sẽ gởi và nhận thông tin định tuyến IGRP
network 152.1.0.0
network 192.1.1.0
!
no ip classless
!
end
Router B:
!
hostname RouterB
!
interface Ethernet0
no ip address
ip address 152.1.1.2 255.255.255.0
!
interface Serial0
ip address 192.1.1.2 255.255.255.0
clockrate 64000 <- hoạt động như DCE cung cấp xung clock
no shut
!
interface Serial1
ip address 193.1.1.2 255.255.255.0
clockrate 64000 <- hoạt động như DCE cung cấp xung clock
no shut
!
router igrp 64 <-kích hoạt quá trình định tuyến IGRP trên router
network 192.1.1.0 <- chỉ ra mạng sẽ quảng bá và xác định cổng nào sẽ gởi và nhận thông tin định tuyến IGRP
network 193.1.1.0
network 152.1.0.0
!
no ip classless
!
end
!
hostname RouterB
!
interface Ethernet0
no ip address
ip address 152.1.1.2 255.255.255.0
!
interface Serial0
ip address 192.1.1.2 255.255.255.0
clockrate 64000 <- hoạt động như DCE cung cấp xung clock
no shut
!
interface Serial1
ip address 193.1.1.2 255.255.255.0
clockrate 64000 <- hoạt động như DCE cung cấp xung clock
no shut
!
router igrp 64 <-kích hoạt quá trình định tuyến IGRP trên router
network 192.1.1.0 <- chỉ ra mạng sẽ quảng bá và xác định cổng nào sẽ gởi và nhận thông tin định tuyến IGRP
network 193.1.1.0
network 152.1.0.0
!
no ip classless
!
end
Router C:
!
hostname RouterC
!
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface serial0
ip address 193.1.1.1 255.255.255.0
!
!
router igrp 64 <- kích hoạt quá trình định tuyến IGRP trên router, số 64 là số AS
network 193.1.1.0 <- chỉ ra mạng sẽ quảng bá và xác định cổng nào sẽ gởi và nhận thông tin định tuyến IGRP
network 3.0.0.0
!
no ip classless
!
end
!
hostname RouterC
!
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface serial0
ip address 193.1.1.1 255.255.255.0
!
!
router igrp 64 <- kích hoạt quá trình định tuyến IGRP trên router, số 64 là số AS
network 193.1.1.0 <- chỉ ra mạng sẽ quảng bá và xác định cổng nào sẽ gởi và nhận thông tin định tuyến IGRP
network 3.0.0.0
!
no ip classless
!
end
Kiểm tra:
- Xem bảng định tuyến trên Router A bằng lệnh show ip route
RouterA#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, 0 – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, * - candidate default
U – per-user static route, o – ODR
Gateway of last report is not set
I 3.0.0.0/8 [100/9076] via 152.1.1.1, 00:00:04, Ethernet0
[100/10976] via 192.1.1.2, 00:00:04, Serial0
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Loopback0
152.1.0.0/24 is subnetted, 1 subnets
C 152.1.1.0 is directly connected, Ethernet0
C 192.1.1.0/24 is directly connected, Serial0
I 193.1.1.0/24 [100/10476] via 192.1.1.2, 00:00:27, Serial0
[100/8576] via 152.1.1.1, 00:00:27, Ethernet0
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, 0 – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, * - candidate default
U – per-user static route, o – ODR
Gateway of last report is not set
I 3.0.0.0/8 [100/9076] via 152.1.1.1, 00:00:04, Ethernet0
[100/10976] via 192.1.1.2, 00:00:04, Serial0
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Loopback0
152.1.0.0/24 is subnetted, 1 subnets
C 152.1.1.0 is directly connected, Ethernet0
C 192.1.1.0/24 is directly connected, Serial0
I 193.1.1.0/24 [100/10476] via 192.1.1.2, 00:00:27, Serial0
[100/8576] via 152.1.1.1, 00:00:27, Ethernet0
Chú ý: Có 2 đường đi đến mạng 3.0.0.0, một đường qua Ethernet cổng (cost là 9076), đường kia qua cổng Serial (cost là 10976). Cost của 2 tuyến đường không bằng nhau, khi thiết lập variance là 2, tuyến đường qua Serial cổng có cost nhỏ hơn giá trị này (10976<18152=90786*2) nên sẽ được sử dụng.
- Từ Router A xem đường đi đến host 3.3.3.3 bằng lệnh show ip route 3.3.3.3
RouterA#show ip route 3.3.3.3
Routing entry for 3.0.0.0/8
Known via “igrp 64”, distance 100, metric 9076
Redistributing via igrp 64
Advertised by igrp 64 (self originated)
Last update from 192.1.1.2 on Serial0, 00:00:18 ago
Routing Descriptor Blocks:
* 152.1.1.1, from 152.1.1.1, 00:00:18 ago, via Ethernet0
Route metric is 9076, traffic share count is 1
Total delay is 26000 microseconds, minimum bandwith is 1544 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1
192.1.1.2, from 192.1.1.2,00:00:18 ago, via Serial0
Route metric is 10976, traffic share count is 1
Total delay is 45000 microseconds, minimum bandwith is 1544 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1
Ta thấy cả 2 tuyến đường đến host 3.3.3.3. Dấu * cho biết gói tin từ Router A sẽ sử dụng đường này để đến host 3.3.3.3Routing entry for 3.0.0.0/8
Known via “igrp 64”, distance 100, metric 9076
Redistributing via igrp 64
Advertised by igrp 64 (self originated)
Last update from 192.1.1.2 on Serial0, 00:00:18 ago
Routing Descriptor Blocks:
* 152.1.1.1, from 152.1.1.1, 00:00:18 ago, via Ethernet0
Route metric is 9076, traffic share count is 1
Total delay is 26000 microseconds, minimum bandwith is 1544 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1
192.1.1.2, from 192.1.1.2,00:00:18 ago, via Serial0
Route metric is 10976, traffic share count is 1
Total delay is 45000 microseconds, minimum bandwith is 1544 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1
- Từ router A ping host 3.3.3.3. Phép ping phải thành công
RouterA#ping 3.3.3.3
Type the escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 second:
!!!!!
Type the escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 second:
!!!!!
- Bây giờ xem lại tuyến đường đi đến host 3.3.3.3 bằng lệnh show ip route 3.3.3.3
RouterA#show ip route 3.3.3.3
Routing entry for 3.0.0.0/8
Known via “igrp 64”, distance 100, metric 9076
Redistributing via igrp 64
Advertised by igrp 64 (self originated)
Last update from 192.1.1.2 on Serial0, 00:00:06 ago
Routing Descriptor Blocks:
152.1.1.1, from 152.1.1.1, 00:00:06 ago, via Ethernet0
Route metric is 9076, traffic share count is 1
Total delay is 26000 microseconds, minimum bandwith is 1544 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1
* 192.1.1.2, from 192.1.1.2, 00:00:07 ago, via Serial0
Route metric is 10976, traffic share count is 1
Total delay is 45000 microseconds, minimum bandwith is 1544 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1
Ta thấy dấu * bây giờ ở tuyến đường thứ hai. điều này do router thực hiện cân bằng tải cho cả 2 tuyến đường để đến mạng 3.0.0.0Routing entry for 3.0.0.0/8
Known via “igrp 64”, distance 100, metric 9076
Redistributing via igrp 64
Advertised by igrp 64 (self originated)
Last update from 192.1.1.2 on Serial0, 00:00:06 ago
Routing Descriptor Blocks:
152.1.1.1, from 152.1.1.1, 00:00:06 ago, via Ethernet0
Route metric is 9076, traffic share count is 1
Total delay is 26000 microseconds, minimum bandwith is 1544 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1
* 192.1.1.2, from 192.1.1.2, 00:00:07 ago, via Serial0
Route metric is 10976, traffic share count is 1
Total delay is 45000 microseconds, minimum bandwith is 1544 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1
- Loại bỏ variance từ router A bằng lệnh no variance
RouterA#configuration terminal
RouterA(config)#router igrp 64
RouterA(config-router)#no variance
RouterA(config)#router igrp 64
RouterA(config-router)#no variance
- Từ router A xem lại đường đi đến host 3.3.3.3 bằng lệnh show ip route 3.3.3.3. Chú ý rằng chỉ có 1 tuyến đường được sử dụng sau khi loại bỏ variance đường này sẽ có metric nhỏ hơn vì ta không thực hiện cân bằng tải.