Nguồn: Sách CCNA Labpro
LAB 3-5: CẤU HÌNH PASSIVE INTERFACE
Mô tả và yêu cầu:
- Bài thực hành này mô tả cách dùng lệnh passive interface; lệnh này cho phép router có chạy RIP nhận, nhưng không gởi thông tin định tuyến ra ngoài cổng chỉ định.
- Các Router cấu hình RIP.
- Không cho gởi thông tin định tuyến qua cổng Serial 0 của router A.
- Router B và C quảng cáo tất cả các mạng nối trực tiếp.
Cấu hình:
Router A:
!
hostname Router A
!
interface Loopback0 <- Định nghĩa interface ảo để làm điểm kiểm tra
ip address 10.1.1.1 255.255.255.0
!
interface Ethernet0
ip address 148.1.1.1 255.255.255.0
no shutdown
no keepalive <- cho phép interface ethernet vẫn up khi không kết nối với HUB hoặc Switch.
!
interface Serial0
ip address 192.1.1.1 255.255.255.0
no shutdown
!
!
router rip <- kích hoạt quá trình định tuyến RIP trên router.
passive–interface Serial0 <- không cho gởi thông tin định tuyến RIP trên Serial 0
network 10.0.0.0 <- chỉ ra mạng sẽ quảng cáo và xác định cổng nào sẽ gởi và nhận thông tin định tuyến RIP.
network 148.1.0.0
network 192.1.1.0
!
no ip classless
!
end
!
hostname Router A
!
interface Loopback0 <- Định nghĩa interface ảo để làm điểm kiểm tra
ip address 10.1.1.1 255.255.255.0
!
interface Ethernet0
ip address 148.1.1.1 255.255.255.0
no shutdown
no keepalive <- cho phép interface ethernet vẫn up khi không kết nối với HUB hoặc Switch.
!
interface Serial0
ip address 192.1.1.1 255.255.255.0
no shutdown
!
!
router rip <- kích hoạt quá trình định tuyến RIP trên router.
passive–interface Serial0 <- không cho gởi thông tin định tuyến RIP trên Serial 0
network 10.0.0.0 <- chỉ ra mạng sẽ quảng cáo và xác định cổng nào sẽ gởi và nhận thông tin định tuyến RIP.
network 148.1.0.0
network 192.1.1.0
!
no ip classless
!
end
Router B:
!
hostname RouterB
!
interface Serial0
ip address 192.1.1.2 255.255.255.0
clock rate 64000 <- hoạt động như DCE cung cấp xung clock
no shutdown
!
interface Serial1
ip address 193.1.1.1 255.255.255.0
clock rate 64000 <- hoạt động như DCE cung cấp xung clock
no shutdown
!
router rip
network 192.1.1.0
network 193.1.1.0
!
end
!
hostname RouterB
!
interface Serial0
ip address 192.1.1.2 255.255.255.0
clock rate 64000 <- hoạt động như DCE cung cấp xung clock
no shutdown
!
interface Serial1
ip address 193.1.1.1 255.255.255.0
clock rate 64000 <- hoạt động như DCE cung cấp xung clock
no shutdown
!
router rip
network 192.1.1.0
network 193.1.1.0
!
end
Router C:
!
hostname RouterC
!
interface Ethernet0
ip address 152.1.1.1 255.255.255.0
no shutdown
no keepalive <- vô hiệu hóa keepalive trên Router cho phép cổng Ethernet 0 vẫn up khi không kết nối ra bên ngoài.
!
interface Serial0
ip address 193.1.1.1 255.255.255.0
no shutdown
!
router rip
network 152.1.0.0
network 193.1.1.0
!
no ip classless
!
end
!
hostname RouterC
!
interface Ethernet0
ip address 152.1.1.1 255.255.255.0
no shutdown
no keepalive <- vô hiệu hóa keepalive trên Router cho phép cổng Ethernet 0 vẫn up khi không kết nối ra bên ngoài.
!
interface Serial0
ip address 193.1.1.1 255.255.255.0
no shutdown
!
router rip
network 152.1.0.0
network 193.1.1.0
!
no ip classless
!
end
Kiểm tra:
- Xem quá trình gởi nhận thông tin định tuyến bằng lệnh dubug ip rip trên router A. Chú ý cập nhật RIP chỉ gởi ra cổng Ethernet0 và Loopback0, Serial0 chỉ nhận thông tin định tuyến RIP.
RouterA#debug ip rip
RIP: received v1 update from 192.1.1.2 on Serial0
152.1.0.0 in 2 hops
193.1.1.0 in 1 hops
RIP: sending v1 update to 255.255.255.255 via Ethernet0 (148.1.1.1)
network 10.0.0.0, metric 1
network 152.1.0.0, metric 3
network 192.1.1.0, metric 1
network 193.1.1.0, metric 2
RIP: sending v1 update to 255.255.255.255 via Loopback0 (10.1.1.1)
network 148.1.0.0, metric 1
network 152.1.0.0, metric 3
network 192.1.1.0, metric 1
network 193.1.1.0, metric 2
RIP: received v1 update from 192.1.1.2 on Serial0
152.1.0.0 in 2 hops
193.1.1.0 in 1 hops
RIP: sending v1 update to 255.255.255.255 via Ethernet0 (148.1.1.1)
network 10.0.0.0, metric 1
network 152.1.0.0, metric 3
network 192.1.1.0, metric 1
network 193.1.1.0, metric 2
RIP: sending v1 update to 255.255.255.255 via Loopback0 (10.1.1.1)
network 148.1.0.0, metric 1
network 152.1.0.0, metric 3
network 192.1.1.0, metric 1
network 193.1.1.0, metric 2
- Xem bảng định tuyến trên router A và router C bằng lệnh show ip route. Chú ý router A học tất cả các route từ Router C, router C không có route từ Router A.
RouterA# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route, o - ODR
Gateway of last resort is not set
10.0.0.0 /24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Loopback0
148.1.0.0/24 is subnetted, 1 subnets
C 148.1.1.0 is directly connected, Ethernet0
R 152.1.0.0/16 [120/2] via 192.1.1.2, 00:00:20, Serial0
C 192.1.1.0/24 is directly connected, Serial0
R 193.1.1.0/24 [120/1] via 192.1.1.2, 00:00:20, Serial0
RouterC# show ip route
...
Gateway of last resort is not set
152.1.0.0/24 is subnetted, 1 subnets
C 152.1.1.0 is directly connected, Ethernet0
R 192.1.1.0/24 [120/1] via 193.1.1.2, 00:00:20, Serial0
C 193.1.1.0/24 is directly connected, Serial0
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route, o - ODR
Gateway of last resort is not set
10.0.0.0 /24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Loopback0
148.1.0.0/24 is subnetted, 1 subnets
C 148.1.1.0 is directly connected, Ethernet0
R 152.1.0.0/16 [120/2] via 192.1.1.2, 00:00:20, Serial0
C 192.1.1.0/24 is directly connected, Serial0
R 193.1.1.0/24 [120/1] via 192.1.1.2, 00:00:20, Serial0
RouterC# show ip route
...
Gateway of last resort is not set
152.1.0.0/24 is subnetted, 1 subnets
C 152.1.1.0 is directly connected, Ethernet0
R 192.1.1.0/24 [120/1] via 193.1.1.2, 00:00:20, Serial0
C 193.1.1.0/24 is directly connected, Serial0
Chú ý: Debug ip rip events: lệnh này dùng để hiển thị quá trình trao đổi định tuyến RIP, nó hiển thị tất cả cập nhật định tuyến RIP được gởi và nhận bởi router. clear ip route [route | *]: loại bỏ một hoặc nhiều route từ bảng định tuyến. Lệnh này cho phép bạn xóa route chỉ định hay xóa toàn bộ route từ bảng định tuyến (dùng *).
Comment