Hi all
Em đang cần triển khai 1 KH MPLS/VPN như sơ đồ sau
KH có 4 site trong đó CE của site kết nối tới 2 router PE, chạy EIGRP để chọn 1 đường chính, 1 đường backup. Hiện tại em đang xử lý loop = cách thay dổi distance của EIGRP từ 170 lên 210. Tuy nhiên em có cảm giác topo này không đươc stable cho lắm. mong các bác góp ý
========================
Here are the configurations
************************** R1 ***************
R1#sh run
Building configuration...
Current configuration : 1624 bytes
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
hostname R1
no aaa new-model
resource policy
memory-size iomem 5
ip subnet-zero
ip cef
no ip domain lookup
no ip dhcp use vrf connected
tag-switching tdp router-id Loopback0
interface Loopback0
ip address 1.1.1.4 255.255.255.255
!
interface FastEthernet0/0
ip address 9.0.0.17 255.255.255.252
duplex auto
speed auto
mpls label protocol ldp
tag-switching ip
!
interface Serial1/0
ip address 9.0.0.9 255.255.255.252
mpls label protocol ldp
tag-switching ip
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
ip address 9.0.0.13 255.255.255.252
mpls label protocol ldp
tag-switching ip
serial restart-delay 0
no dce-terminal-timing-enable
router ospf 1
router-id 1.1.1.4
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 0
network 9.0.0.0 0.0.0.255 area 0
!
ip http server
ip classless
********************************* R2 *********************
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
!
!
ip vrf cusA
rd 1:10
route-target export 1:10
route-target import 1:10
!
ip vrf cusB
rd 1:20
route-target export 1:20
route-target import 1:20
!
tag-switching tdp router-id Loopback0
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
ip vrf forwarding cusA
ip address 20.1.0.1 255.255.255.0
!
!
interface Serial1/0
ip address 9.0.0.10 255.255.255.252
mpls label protocol ldp
tag-switching ip
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
description connect to CE Backup
ip vrf forwarding cusA
ip address 9.0.0.5 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
router eigrp 1
auto-summary
!
address-family ipv4 vrf cusA
redistribute bgp 7643 metric 10000 100 255 1 1500
redistribute static metric 10000 100 255 1 1500
network 9.0.0.4 0.0.0.3
network 20.0.0.0
distance eigrp 90 210
no auto-summary
autonomous-system 123
exit-address-family
!
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 9.0.0.8 0.0.0.3 area 0
!
router bgp 7643
no synchronization
bgp log-neighbor-changes
redistribute connected
redistribute static
neighbor CORE peer-group
neighbor CORE remote-as 7643
neighbor CORE update-source Loopback0
neighbor 1.1.1.2 peer-group CORE
neighbor 1.1.1.3 peer-group CORE
no auto-summary
!
address-family vpnv4
neighbor CORE send-community both
neighbor CORE next-hop-self
neighbor 1.1.1.2 activate
neighbor 1.1.1.3 activate
exit-address-family
!
!
address-family ipv4 vrf cusA
redistribute static metric 20
redistribute eigrp 123 metric 100
no auto-summary
no synchronization
exit-address-family
!
ip http server
ip classless
ip route vrf cusA 40.0.0.0 255.0.0.0 20.1.0.2
********************************* R3 ****************
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
!
!
ip vrf cusA
rd 1:10
route-target export 1:10
route-target import 1:10
!
interface Loopback1
ip vrf forwarding cusA
ip address 20.0.0.1 255.255.255.0
!
interface Serial1/0
ip vrf forwarding cusA
ip address 9.0.0.1 255.255.255.252
delay 10
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
ip address 9.0.0.14 255.255.255.252
mpls label protocol ldp
tag-switching ip
serial restart-delay 0
no dce-terminal-timing-enable
!
router eigrp 1
auto-summary
!
address-family ipv4 vrf cusA
redistribute bgp 7643 metric 10000 100 255 1 1500
network 9.0.0.0 0.0.0.3
network 20.0.0.0
distance eigrp 90 210
no auto-summary
autonomous-system 123
exit-address-family
!
router ospf 1
router-id 1.1.1.2
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 0
network 9.0.0.12 0.0.0.3 area 0
!
router bgp 7643
no synchronization
bgp log-neighbor-changes
neighbor CORE peer-group
neighbor CORE remote-as 7643
neighbor CORE update-source Loopback0
neighbor 1.1.1.1 peer-group CORE
neighbor 1.1.1.3 peer-group CORE
no auto-summary
!
address-family vpnv4
neighbor CORE send-community extended
neighbor CORE next-hop-self
neighbor 1.1.1.1 activate
neighbor 1.1.1.3 activate
exit-address-family
!
!
address-family ipv4 vrf cusA
redistribute static
redistribute eigrp 123 metric 100
no auto-summary
no synchronization
exit-address-family
!
ip http server
ip classless
************************************ R5 *************
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
interface Loopback0
ip address 20.3.0.1 255.255.255.0
!
interface Serial1/0
ip address 9.0.0.2 255.255.255.252
delay 10
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
ip address 9.0.0.6 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
router eigrp 123
network 9.0.0.0 0.0.0.255
network 20.3.0.0 0.0.0.255
distance eigrp 90 210
no auto-summary
!
ip http server
ip classless
Em đang cần triển khai 1 KH MPLS/VPN như sơ đồ sau
KH có 4 site trong đó CE của site kết nối tới 2 router PE, chạy EIGRP để chọn 1 đường chính, 1 đường backup. Hiện tại em đang xử lý loop = cách thay dổi distance của EIGRP từ 170 lên 210. Tuy nhiên em có cảm giác topo này không đươc stable cho lắm. mong các bác góp ý
========================
Here are the configurations
************************** R1 ***************
R1#sh run
Building configuration...
Current configuration : 1624 bytes
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
hostname R1
no aaa new-model
resource policy
memory-size iomem 5
ip subnet-zero
ip cef
no ip domain lookup
no ip dhcp use vrf connected
tag-switching tdp router-id Loopback0
interface Loopback0
ip address 1.1.1.4 255.255.255.255
!
interface FastEthernet0/0
ip address 9.0.0.17 255.255.255.252
duplex auto
speed auto
mpls label protocol ldp
tag-switching ip
!
interface Serial1/0
ip address 9.0.0.9 255.255.255.252
mpls label protocol ldp
tag-switching ip
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
ip address 9.0.0.13 255.255.255.252
mpls label protocol ldp
tag-switching ip
serial restart-delay 0
no dce-terminal-timing-enable
router ospf 1
router-id 1.1.1.4
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 0
network 9.0.0.0 0.0.0.255 area 0
!
ip http server
ip classless
********************************* R2 *********************
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
!
!
ip vrf cusA
rd 1:10
route-target export 1:10
route-target import 1:10
!
ip vrf cusB
rd 1:20
route-target export 1:20
route-target import 1:20
!
tag-switching tdp router-id Loopback0
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
ip vrf forwarding cusA
ip address 20.1.0.1 255.255.255.0
!
!
interface Serial1/0
ip address 9.0.0.10 255.255.255.252
mpls label protocol ldp
tag-switching ip
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
description connect to CE Backup
ip vrf forwarding cusA
ip address 9.0.0.5 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
router eigrp 1
auto-summary
!
address-family ipv4 vrf cusA
redistribute bgp 7643 metric 10000 100 255 1 1500
redistribute static metric 10000 100 255 1 1500
network 9.0.0.4 0.0.0.3
network 20.0.0.0
distance eigrp 90 210
no auto-summary
autonomous-system 123
exit-address-family
!
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 9.0.0.8 0.0.0.3 area 0
!
router bgp 7643
no synchronization
bgp log-neighbor-changes
redistribute connected
redistribute static
neighbor CORE peer-group
neighbor CORE remote-as 7643
neighbor CORE update-source Loopback0
neighbor 1.1.1.2 peer-group CORE
neighbor 1.1.1.3 peer-group CORE
no auto-summary
!
address-family vpnv4
neighbor CORE send-community both
neighbor CORE next-hop-self
neighbor 1.1.1.2 activate
neighbor 1.1.1.3 activate
exit-address-family
!
!
address-family ipv4 vrf cusA
redistribute static metric 20
redistribute eigrp 123 metric 100
no auto-summary
no synchronization
exit-address-family
!
ip http server
ip classless
ip route vrf cusA 40.0.0.0 255.0.0.0 20.1.0.2
********************************* R3 ****************
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
!
!
ip vrf cusA
rd 1:10
route-target export 1:10
route-target import 1:10
!
interface Loopback1
ip vrf forwarding cusA
ip address 20.0.0.1 255.255.255.0
!
interface Serial1/0
ip vrf forwarding cusA
ip address 9.0.0.1 255.255.255.252
delay 10
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
ip address 9.0.0.14 255.255.255.252
mpls label protocol ldp
tag-switching ip
serial restart-delay 0
no dce-terminal-timing-enable
!
router eigrp 1
auto-summary
!
address-family ipv4 vrf cusA
redistribute bgp 7643 metric 10000 100 255 1 1500
network 9.0.0.0 0.0.0.3
network 20.0.0.0
distance eigrp 90 210
no auto-summary
autonomous-system 123
exit-address-family
!
router ospf 1
router-id 1.1.1.2
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 0
network 9.0.0.12 0.0.0.3 area 0
!
router bgp 7643
no synchronization
bgp log-neighbor-changes
neighbor CORE peer-group
neighbor CORE remote-as 7643
neighbor CORE update-source Loopback0
neighbor 1.1.1.1 peer-group CORE
neighbor 1.1.1.3 peer-group CORE
no auto-summary
!
address-family vpnv4
neighbor CORE send-community extended
neighbor CORE next-hop-self
neighbor 1.1.1.1 activate
neighbor 1.1.1.3 activate
exit-address-family
!
!
address-family ipv4 vrf cusA
redistribute static
redistribute eigrp 123 metric 100
no auto-summary
no synchronization
exit-address-family
!
ip http server
ip classless
************************************ R5 *************
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
interface Loopback0
ip address 20.3.0.1 255.255.255.0
!
interface Serial1/0
ip address 9.0.0.2 255.255.255.252
delay 10
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
ip address 9.0.0.6 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
router eigrp 123
network 9.0.0.0 0.0.0.255
network 20.3.0.0 0.0.0.255
distance eigrp 90 210
no auto-summary
!
ip http server
ip classless
Comment