Lab Ripv2 source validation
Yêu cầu:
Giải đáp:
Bước 1:
Cấu hình trên R1
R1(config)#int s0/0
R1(config-if)#no shut
R1(config-if)#encapsulation PPP
R1(config-if)#ip add negotiated
Cấu hình trên R2
R2(config)#int s0/0
R2(config-if)#no shut
R2(config-if)#ip address 155.1.13.2 255.255.255.0
R2(config-if)#encapsulation ppp
R2(config-if)#peer default ip address 155.1.13.1
Kiểm tra trên R1 về việc đã nhận được địa chỉ IP từ R2
R1#sh ip int br
Interface IP-Address OK? Method Status Protocol
Serial0/0 155.1.13.1 YES IPCP up up
Như vậy R1 đã nhận được IP từ R2 cấp qua giao thức IPCP
Tiếp tục kiểm tra bảng định tuyến trên R1 và R2
R1#sh ip route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
155.1.0.0/32 is subnetted, 2 subnets
C 155.1.13.2 is directly connected, Serial0/0
C 155.1.13.1 is directly connected, Serial0/0
R2#sh ip route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
R 1.1.1.0 [120/1] via 155.1.13.1, 00:00:19, Serial0/0
2.0.0.0/24 is subnetted, 1 subnets
C 2.2.2.0 is directly connected, Loopback0
155.1.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 155.1.13.1/32 is directly connected, Serial0/0
C 155.1.13.0/24 is directly connected, Serial0/0
Sau khi R1 lấy được địa chỉ IP, nó sẽ thêm vào một host route 155.1.13.2/32 của R2 vào bảng định tuyến.
Trong liên kết này R1 đang có 155.1.13.1/32 không cùng subnet với IP trên R2. R1 không chấp nhận thông tin update từ R2, nhưng R2 vẫn chấp nhận thông tin update từ R1 vì 155.1.13.1 vẫn là 1 phần trong lớp mạng 155.1.13.0/24
Để khắc phục tình trạng trên thì gõ câu lệnh:
R1(config)#router rip
R1(config-router)# no validate-update-source
R1 tiến hành bỏ chức năng kiểm tra source của gói tin update.
Kiểm tra lại trên bảng định tuyến của R1:
R1#sh ip route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
2.0.0.0/24 is subnetted, 1 subnets
R 2.2.2.0 [120/1] via 155.1.13.2, 00:00:17
155.1.0.0/32 is subnetted, 2 subnets
C 155.1.13.2 is directly connected, Serial0/0
C 155.1.13.1 is directly connected, Serial0/0
R1 đã học được mạng 2.2.2.0 từ R2.
VnPro
Yêu cầu:
- Cấu hình encapsulation giữa R1 và R2 là PPP
- Interface của R2 là 155.1.13.2/24
- Cấu hình R2 gán IP 155.1.13.1/32 cho R1 bằng giao thức IPCP
- Đảm bảo mạng hội tụ bình thường.
Giải đáp:
Bước 1:
Cấu hình trên R1
R1(config)#int s0/0
R1(config-if)#no shut
R1(config-if)#encapsulation PPP
R1(config-if)#ip add negotiated
Cấu hình trên R2
R2(config)#int s0/0
R2(config-if)#no shut
R2(config-if)#ip address 155.1.13.2 255.255.255.0
R2(config-if)#encapsulation ppp
R2(config-if)#peer default ip address 155.1.13.1
Kiểm tra trên R1 về việc đã nhận được địa chỉ IP từ R2
R1#sh ip int br
Interface IP-Address OK? Method Status Protocol
Serial0/0 155.1.13.1 YES IPCP up up
Như vậy R1 đã nhận được IP từ R2 cấp qua giao thức IPCP
Tiếp tục kiểm tra bảng định tuyến trên R1 và R2
R1#sh ip route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
155.1.0.0/32 is subnetted, 2 subnets
C 155.1.13.2 is directly connected, Serial0/0
C 155.1.13.1 is directly connected, Serial0/0
R2#sh ip route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
R 1.1.1.0 [120/1] via 155.1.13.1, 00:00:19, Serial0/0
2.0.0.0/24 is subnetted, 1 subnets
C 2.2.2.0 is directly connected, Loopback0
155.1.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 155.1.13.1/32 is directly connected, Serial0/0
C 155.1.13.0/24 is directly connected, Serial0/0
Sau khi R1 lấy được địa chỉ IP, nó sẽ thêm vào một host route 155.1.13.2/32 của R2 vào bảng định tuyến.
Trong liên kết này R1 đang có 155.1.13.1/32 không cùng subnet với IP trên R2. R1 không chấp nhận thông tin update từ R2, nhưng R2 vẫn chấp nhận thông tin update từ R1 vì 155.1.13.1 vẫn là 1 phần trong lớp mạng 155.1.13.0/24
Để khắc phục tình trạng trên thì gõ câu lệnh:
R1(config)#router rip
R1(config-router)# no validate-update-source
R1 tiến hành bỏ chức năng kiểm tra source của gói tin update.
Kiểm tra lại trên bảng định tuyến của R1:
R1#sh ip route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
2.0.0.0/24 is subnetted, 1 subnets
R 2.2.2.0 [120/1] via 155.1.13.2, 00:00:17
155.1.0.0/32 is subnetted, 2 subnets
C 155.1.13.2 is directly connected, Serial0/0
C 155.1.13.1 is directly connected, Serial0/0
R1 đã học được mạng 2.2.2.0 từ R2.
VnPro