Xin chào ! Nếu đây là lần đầu tiên bạn đến với diễn đàn, xin vui lòng danh ra một phút bấm vào đây để đăng kí và tham gia thảo luận cùng VnPro.

Announcement

Collapse
No announcement yet.

Giúp mình??

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Giúp mình??

    Có ai biết về Extended Ping ko?
    Chỉ rõ giúp mình với?
    Để kiểm tra nó chạy thì làm thế nào?
    Connecting ...

  • #2
    hi,

    bạn tham khảo link sau nhé:

    Comment


    • #3
      Còn đây là ping một dãy ip bằng script cho việc troubleshoot nằm trong Academy v5



      TCLScriptReferenceandDemonstration



      Learning Objectives

      ·Learn to use TCL scripts to verify full connectivity
      ·Identify causes of failures

      Topology Diagram




      Quick TCL Reference

      Refer back to this

      tclsh



      foreach address {
      10.1.1.1
      10.1.2.1
      10.1.3.1
      10.1.4.1
      10.100.12.1
      10.2.1.1
      10.2.2.1
      10.2.3.1
      10.2.4.1
      10.100.12.2
      } {
      ping $address
      }

      tclquit


      Step 1: Initial Configuration

      Paste in the initial configurations below:

      R1:
      !
      hostname R1
      !
      interface loopback 1
      ip address 10.1.1.1 255.255.255.252
      !
      interface loopback 2
      ip address 10.1.2.1 255.255.255.252
      !
      interface loopback 3
      ip address 10.1.3.1 255.255.255.252
      !
      interface loopback 4
      ip address 10.1.4.1 255.255.255.252
      !
      interface serial 0/0/0
      ip address 10.100.12.1 255.255.255.252
      clock rate 64000
      no shutdown
      !
      router rip version 2
      network 10.0.0.0
      no auto-summary
      !
      end

      R2:
      !
      hostname R2
      !
      interface loopback 1
      ip address 10.2.1.1 255.255.255.252
      !
      interface loopback 2
      ip address 10.2.2.1 255.255.255.252
      !
      interface loopback 3
      ip address 10.2.3.1 255.255.255.252
      !
      interface loopback 4
      ip address 10.2.4.1 255.255.255.252
      !
      interface serial 0/0/0
      no shutdown
      !
      router rip version 2
      network 10.0.0.0
      no auto-summary
      !
      end

      Do you think that these configurations will achieve full connectivity between R1
      and R2? Explain.


      Step 2: Verify Connectivity

      The simplest way to verify OSI Layer 3 connectivity between two routers is to use the Internet Control Message Protocol (ICMP). ICMP defines a number of message types in RFC 792 for IPv4 and RFC 4443 for IPv6. (For copies, go to
      www.ietf.org.)

      ICMP defines procedures for echo (ping), traceroute, and source notification of unreachable networks. Pinging an IP address can result in a variety of ICMP messages, but the only message indicating that a ping is successful is the
      ICMP echo reply message indicated by an exclamation point (!) in the output of the ping command.

      R1# ping 10.1.1.1

      !!!!!

      In Step 1, you may have noticed that R2’s configuration omits an IP address on
      Serial0/0/0. R2 does not exchange updates with R1, because the IP protocol is not running on R2’s serial interface until the IP address has been configured.

      Without this IP address, for which addresses in the topology diagram do you expect the ping to fail?






      Cisco IOS Release 12.3(2)T and later supports TCL scripting in the Cisco IOS. To construct a simple connectivity verification script, do the following:
      1. Open a text editor and create a new document. Using a text file saves time, especially if you are pasting the TCL script into multiple devices.

      2. On the first line, enter the tclsh command and then press Return four times to leave a pause while the TCL shell starts. The tclsh command,
      when entered on a supported switch or router, enters TCL shell mode, in which you can use native TCL instructions like foreach or issue EXEC- mode commands. You can also access configuration mode from within
      the TCL shell and issue configuration commands from their respective menus, although these features are not explored in this lab.

      tclsh





      3. Begin a loop using the foreach instruction. The loop iterates over a sequence of values, executing a defined sequence of instructions once


      for each value. Think of it as “for each value in Values, do each instruction in Instructions.” For each iteration of the loop, $identifier reflects the current value in Values. The foreach instruction follows the model given below.

      foreach identifier {
      value1
      value2
      .
      .
      .
      valueX
      } { instruction1 instruction2
      .
      .
      . instructionY
      }

      To create a TCL script that pings each IP address in the topology, enter each of the IP addresses in the value list. Issue the ping $address command as the only instruction in the instruction list.

      foreach address {
      10.1.1.1
      10.1.2.1
      10.1.3.1
      10.1.4.1
      10.100.12.1
      10.2.1.1
      10.2.2.1
      10.2.3.1
      10.2.4.1
      10.100.12.2
      } {
      ping $address
      }

      4. Copy the TCL script from the text file and paste it into each device.

      R1# tclsh R1(tcl)# R1(tcl)# R1(tcl)#
      R1(tcl)# foreach address {
      +>(tcl)# 10.1.1.1
      +>(tcl)# 10.1.2.1
      +>(tcl)# 10.1.3.1
      +>(tcl)# 10.1.4.1
      +>(tcl)# 10.100.12.1
      +>(tcl)# 10.2.1.1
      +>(tcl)# 10.2.2.1
      +>(tcl)# 10.2.3.1
      +>(tcl)# 10.2.4.1
      +>(tcl)# 10.100.12.2
      +>(tcl)# } {
      +>(tcl)# ping $address
      +>(tcl)# }



      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.1.2.1, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.1.3.1, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.1.4.1, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.100.12.1, timeout is 2 seconds:
      .....
      Success rate is 0 percent (0/5)
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.2.1.1, timeout is 2 seconds:
      .....
      Success rate is 0 percent (0/5) Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.2.2.1, timeout is 2 seconds:
      .....
      Success rate is 0 percent (0/5) Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.2.3.1, timeout is 2 seconds:
      .....
      Success rate is 0 percent (0/5) Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.2.4.1, timeout is 2 seconds:
      .....
      Success rate is 0 percent (0/5) Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.100.12.2, timeout is 2 seconds:
      .....
      Success rate is 0 percent (0/5)


      R2# tclsh R2(tcl)# R2(tcl)# R2(tcl)#
      R2(tcl)# foreach address {
      +>(tcl)# 10.1.1.1
      +>(tcl)# 10.1.2.1
      +>(tcl)# 10.1.3.1
      +>(tcl)# 10.1.4.1
      +>(tcl)# 10.100.12.1
      +>(tcl)# 10.2.1.1
      +>(tcl)# 10.2.2.1
      +>(tcl)# 10.2.3.1
      +>(tcl)# 10.2.4.1
      +>(tcl)# 10.100.12.2
      +>(tcl)# } {
      +>(tcl)# ping $address
      +>(tcl)# }

      Type escape sequence to abort.


      Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
      .....
      Success rate is 0 percent (0/5) Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.1.2.1, timeout is 2 seconds:
      .....
      Success rate is 0 percent (0/5) Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.1.3.1, timeout is 2 seconds:
      .....
      Success rate is 0 percent (0/5) Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.1.4.1, timeout is 2 seconds:
      .....
      Success rate is 0 percent (0/5) Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.100.12.1, timeout is 2 seconds:
      .....
      Success rate is 0 percent (0/5) Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.2.1.1, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.2.2.1, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.2.3.1, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.2.4.1, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.100.12.2, timeout is 2 seconds:
      .....
      Success rate is 0 percent (0/5)

      5. Exit the TCL script using the tclquit command on each device.

      R1(tcl)# tclquit

      R2(tcl)# tclquit

      Notice that in the previous output, R1 and R2 could not route pings to the remote loopback networks for which they did not have routes installed in their routing tables.

      You may have also noticed that R1 could not ping its local address on Serial0/0/0. In HDLC, Frame Relay, and ATM serial technologies, all packets, including pings to the local interface, must be forwarded across the link.

      For instance, R1 attempts to ping 10.100.12.1 and routes the packet out Serial0/0/0, even though the address is a local interface. Assume that there are working configurations with an IP address of 10.100.12.2/30 assigned to the Serial0/0/0 interface on R2. Once a ping from R1 to 10.100.12.1 reaches R2,


      R2 evaluates that this is not its address on the 10.100.12.0/30 subnet and
      routes the packet back to R1 on its Serial0/0/0 interface. R1 receives the packet and evaluates that 10.100.12.1 is the address of the local interface. R1 opens
      this packet using ICMP, and responds to the ICMP echo request (ping) with an echo reply destined for 10.100.12.1. R1 encapsulates the echo reply at Serial0/0/0 and routes the packet to R2. R2 receives the packet and routes it
      back to R1, the originator of the ICMP echo. The ICMP protocol on R1 receives the echo reply, associates it with the ICMP echo it sent, and prints the output in the form of an exclamation point.

      To understand this behavior, observe the output of the debug ip icmp and debug ip packet commands on R1 and R2 while pinging with the configurations given in Step 3.

      Step 3: Resolve Connectivity Issues

      On R2, assign the IP address 10.100.12.2/30 to Serial0/0/0.

      R2# conf t
      R2(config)# interface serial 0/0/0
      R2(config-if)# ip address 10.100.12.2 255.255.255.0

      On each router, verify the receipt of RIPv2 routing information with the show ip protocols command.

      R1# show ip protocols
      Routing Protocol is "rip"
      Outgoing update filter list for all interfaces is not set Incoming update filter list for all interfaces is not set Sending updates every 30 seconds, next due in 28 seconds Invalid after 180 seconds, hold down 180, flushed after 240
      Redistributing: rip
      Default version control: send version 2, receive version 2
      Interface Send Recv Triggered RIP Key-chain
      Serial0/0/0 2 2
      Loopback1 2 2
      Loopback2 2 2
      Loopback3 2 2
      Loopback4 2 2
      Automatic network summarization is not in effect
      Maximum path: 4
      Routing for Networks:
      [IMG]file:///C:/DOCUME%7E1/ADMINI%7E1/LOCALS%7E1/Temp/msohtml1/01/clip_image001.gif[/IMG]10.0.0.0
      Routing Information Sources:
      Gateway Distance Last Update
      10.100.12.2 120 00:00:13
      Distance: (default is 120)

      R2# show ip protocols
      Routing Protocol is "rip"
      Outgoing update filter list for all interfaces is not set Incoming update filter list for all interfaces is not set Sending updates every 30 seconds, next due in 26 seconds Invalid after 180 seconds, hold down 180, flushed after 240
      Redistributing: rip
      Default version control: send version 2, receive version 2
      Interface Send Recv Triggered RIP Key-chain


      Serial0/0/0 2 2
      Serial0/0/1 2 2
      Loopback1 2 2
      Loopback2 2 2
      Loopback3 2 2
      Loopback4 2 2
      Automatic network summarization is not in effect
      Maximum path: 4
      Routing for Networks:
      [IMG]file:///C:/DOCUME%7E1/ADMINI%7E1/LOCALS%7E1/Temp/msohtml1/01/clip_image002.gif[/IMG]10.0.0.0
      Routing Information Sources:
      Gateway Distance Last Update
      10.100.12.1 120 00:00:14
      Distance: (default is 120)

      On each router, verify full connectivity to all subnets in the diagram by pasting the TCL script on the command line in privileged EXEC mode.

      R1# tclsh R1(tcl)# R1(tcl)# R1(tcl)#
      R1(tcl)# foreach address {
      +>(tcl)# 10.1.1.1
      +>(tcl)# 10.1.2.1
      +>(tcl)# 10.1.3.1
      +>(tcl)# 10.1.4.1
      +>(tcl)# 10.100.12.1
      +>(tcl)# 10.2.1.1
      +>(tcl)# 10.2.2.1
      +>(tcl)# 10.2.3.1
      +>(tcl)# 10.2.4.1
      +>(tcl)# 10.100.12.2
      +>(tcl)# } {
      +>(tcl)# ping $address
      +>(tcl)# }

      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.1.2.1, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.1.3.1, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.1.4.1, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.100.12.1, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 56/57/64 ms
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.2.1.1, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
      Type escape sequence to abort.


      Sending 5, 100-byte ICMP Echos to 10.2.2.1, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.2.3.1, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.2.4.1, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.100.12.2, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
      R1(tcl)# tclquit


      R2# tclsh R2(tcl)# R2(tcl)# R2(tcl)#
      R2(tcl)# foreach address {
      +>(tcl)# 10.1.1.1
      +>(tcl)# 10.1.2.1
      +>(tcl)# 10.1.3.1
      +>(tcl)# 10.1.4.1
      +>(tcl)# 10.100.12.1
      +>(tcl)# 10.2.1.1
      +>(tcl)# 10.2.2.1
      +>(tcl)# 10.2.3.1
      +>(tcl)# 10.2.4.1
      +>(tcl)# 10.100.12.2
      +>(tcl)# } {
      +>(tcl)# ping $address
      +>(tcl)# }

      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.1.2.1, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.1.3.1, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.1.4.1, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.100.12.1, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.2.1.1, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.2.2.1, timeout is 2 seconds:


      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.2.3.1, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.2.4.1, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.100.12.2, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 56/58/68 ms
      R2(tcl)# tclquit

      Notice that the average round-trip time for an ICMP packet from R1 to
      10.100.12.1 is approximately twice that of a ping from R1 to Loopback1 on R2. This verifies the conclusion reached in Step 2 that the ICMP echo request to
      10.100.12.1 and the ICMP echo reply from 10.100.12.1 each traverse the link
      twice to verify full connectivity across the link.

      Conclusion

      Use TCL scripts to verify all your configurations in this course and observe the output. If you verify your work, both academically and in production networks, you will gain knowledge and save time in troubleshooting.
      Phạm Minh Tuấn

      Email : phamminhtuan@vnpro.org
      Yahoo : phamminhtuan_vnpro
      -----------------------------------------------------------------------------------------------
      Trung Tâm Tin Học VnPro
      149/1D Ung Văn Khiêm P25 Q.Bình thạnh TPHCM
      Tel : (08) 35124257 (5 lines)
      Fax: (08) 35124314

      Home page: http://www.vnpro.vn
      Support Forum: http://www.vnpro.org
      - Chuyên đào tạo quản trị mạng và hạ tầng Internet
      - Phát hành sách chuyên môn
      - Tư vấn và tuyển dụng nhân sự IT
      - Tư vấn thiết kế và hỗ trợ kỹ thuật hệ thống mạng

      Network channel: http://www.dancisco.com
      Blog: http://www.vnpro.org/blog

      Comment


      • #4
        Bác nên đặt một cái tiêu đề dễ hiểu hơn đi

        Comment


        • #5
          Originally posted by blackspy View Post
          Có ai biết về Extended Ping ko?
          Chỉ rõ giúp mình với?
          Để kiểm tra nó chạy thì làm thế nào?
          (192.168.1.1)Router1(1.1.1.1)---------(1.1.1.2)router2(3.3.3.3)-------
          Router1#ping 3.3.3.3 source 192.168.1.1
          !!!!!
          Trịnh Anh Luân
          - Email : trinhanhluan@vnpro.org
          - Search my site
          - Search VNPRO.ORG

          Trung Tâm Tin Học VnPro
          Địa chỉ: 149/1D Ung Văn Khiêm P25 Q.Bình thạnh TPHCM
          Tel: (08) 35124257 (5 lines)
          Fax: (08) 35124314

          Home page: http://www.vnpro.vn
          Support Forum: http://www.vnpro.org
          Network channel: http://www.dancisco.com
          • Chuyên đào tạo quản trị mạng và hạ tầng Internet
          • Phát hành sách chuyên môn
          • Tư vấn và tuyển dụng nhân sự IT
          • Tư vấn thiết kế và hỗ trợ kỹ thuật hệ thống mạng

          Blog: http://www.vnpro.org/blog
          Wifi forum: http://www.wifipro.org

          Comment


          • #6
            Extended Ping đc dùng với mục đích kiểm tra kết nối những interface trên thiết này đến thiết bị kia mà không nối trực tiếp với nó ví dụ:
            192.168.1.1(R1)192.168.12.1------------------192.168.12.2(R2)
            R1#ping 192.168.12.2 source 192.168.1.1

            Chú ý: địa chỉ source địa chỉ nằm trên thiết bị cần ping mở rộng ở trường hợp này là router (địa chỉ 192.168.1.1 nằm trên router)

            Comment

            Working...
            X